Bug 292054 - muon software center se bloque
Summary: muon software center se bloque
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 18:13 UTC by Abdelkrim Talbi
Modified: 2012-01-20 18:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Abdelkrim Talbi 2012-01-20 18:13:10 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
quand j'ouvre muon software center il se ferme

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b3930 (LWP 3103))]

Thread 2 (Thread 0xb589ab70 (LWP 3110)):
#0  0x00c63d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x001d27d5 in do_gettime (frac=0xb589a020, sec=0xb589a018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x002a54b6 in QTimerInfoList::updateCurrentTime (this=0x984e55c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x002a580a in QTimerInfoList::timerWait (this=0x984e55c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x002a4053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb589a12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x002a40ed in timerSourcePrepare (source=0x984e528, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0159988c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x0159a637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0159ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x002a4b37 in QEventDispatcherGlib::processEvents (this=0x9824680, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x002751dd in QEventLoop::processEvents (this=0xb589a2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00275421 in QEventLoop::exec (this=0xb589a2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0017890b in QThread::exec (this=0x97c6830) at thread/qthread.cpp:498
#14 0x00255e2d in QInotifyFileSystemWatcherEngine::run (this=0x97c6830) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0017b7b3 in QThreadPrivate::start (arg=0x97c6830) at thread/qthread_unix.cpp:331
#16 0x00c36d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0097e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77b3930 (LWP 3103)):
[KCrash Handler]
#7  0x001cfe11 in QtPrivate::QStringList_contains (that=0xbff556c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff556c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x97c1828) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x97c1828, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff558e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0027cb7d in metacall (argv=0xbff558e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x97c1828) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x97c1828, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbff558e4) at kernel/qmetaobject.cpp:232
#13 0x0028ba6a in QMetaObject::activate (sender=0x981d580, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x981d580) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x981d580, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff55a28) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0027cb7d in metacall (argv=0xbff55a28, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x981d580) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x981d580, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbff55a28) at kernel/qmetaobject.cpp:232
#18 0x0028ba6a in QMetaObject::activate (sender=0x97c1828, m=0x80950c0, local_signal_index=0, argv=0xbff55a28) at kernel/qobject.cpp:3278
#19 0x008787c5 in MuonMainWindow::backendReady (this=0x97c1828, _t1=0x97c2db0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00878933 in MuonMainWindow::initObject (this=0x97c1828) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x97c1828) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x97c1828, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff55b54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0027cb7d in metacall (argv=0xbff55b54, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x97c1828) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x97c1828, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbff55b54) at kernel/qmetaobject.cpp:232
#25 0x0028ba6a in QMetaObject::activate (sender=0x9803708, m=0x3ac238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00293375 in QSingleShotTimer::timeout (this=0x9803708) at .moc/release-shared/qtimer.moc:82
#27 0x0029342c in QSingleShotTimer::timerEvent (this=0x9803708) at kernel/qtimer.cpp:308
#28 0x0028e994 in QObject::event (this=0x9803708, e=0xbff55f4c) at kernel/qobject.cpp:1181
#29 0x05dead54 in notify_helper (e=0xbff55f4c, receiver=0x9803708, this=0x96c1bf8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x96c1bf8, receiver=0x9803708, e=0xbff55f4c) at kernel/qapplication.cpp:4458
#31 0x05df0103 in QApplication::notify (this=0xbff55f4c, receiver=0x9803708, e=0xbff55f4c) at kernel/qapplication.cpp:3886
#32 0x011cf681 in KApplication::notify (this=0xbff56260, receiver=0x9803708, event=0xbff55f4c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0027619e in QCoreApplication::notifyInternal (this=0xbff56260, receiver=0x9803708, event=0xbff55f4c) at kernel/qcoreapplication.cpp:787
#34 0x002a6c10 in sendEvent (event=0xbff55f4c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x96c9e74) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002a4122 in timerSourceDispatch (source=0x96c9e40) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0159a25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0159a990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0159ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x002a4ada in QEventDispatcherGlib::processEvents (this=0x96a5238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05ea2e3a in QGuiEventDispatcherGlib::processEvents (this=0x96a5238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x002751dd in QEventLoop::processEvents (this=0xbff561c4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00275421 in QEventLoop::exec (this=0xbff561c4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0027a19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05de88f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292031, bug 292025, bug 292023, bug 292006, bug 292000.

Reported using DrKonqi
Comment 1 Thijs 2012-01-20 18:44:30 UTC

*** This bug has been marked as a duplicate of bug 291262 ***