Bug 292074 - Crashing app muon
Summary: Crashing app muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-20 22:29 UTC by infants
Modified: 2012-01-21 02:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description infants 2012-01-20 22:29:13 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Fresh install on new HDD, from first time launch, the app is crashing.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4804930 (LWP 2586))]

Thread 2 (Thread 0xb24c2b70 (LWP 2587)):
#0  0xb5350d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb722b7d5 in do_gettime (frac=0xb24c2020, sec=0xb24c2018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb72fe4b6 in QTimerInfoList::updateCurrentTime (this=0x9bf344c) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb72fe80a in QTimerInfoList::timerWait (this=0x9bf344c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb72fd053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb24c212c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb72fd0ed in timerSourcePrepare (source=0x9bf3418, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb529688c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb5297637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb5297c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb72fdb37 in QEventDispatcherGlib::processEvents (this=0x9bb30a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb72ce1dd in QEventLoop::processEvents (this=0xb24c22b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb72ce421 in QEventLoop::exec (this=0xb24c22b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb71d190b in QThread::exec (this=0x9bad138) at thread/qthread.cpp:498
#14 0xb72aee2d in QInotifyFileSystemWatcherEngine::run (this=0x9bad138) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb71d47b3 in QThreadPrivate::start (arg=0x9bad138) at thread/qthread_unix.cpp:331
#16 0xb537dd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5dca0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb4804930 (LWP 2586)):
[KCrash Handler]
#7  0xb7228e11 in QtPrivate::QStringList_contains (that=0xbfcc0204, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfcc0204) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9b5aa70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9b5aa70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcc0424) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb72d5b7d in metacall (argv=0xbfcc0424, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9b5aa70) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9b5aa70, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfcc0424) at kernel/qmetaobject.cpp:232
#13 0xb72e4a6a in QMetaObject::activate (sender=0x9bc2e30, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9bc2e30) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9bc2e30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcc0568) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb72d5b7d in metacall (argv=0xbfcc0568, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9bc2e30) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9bc2e30, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfcc0568) at kernel/qmetaobject.cpp:232
#18 0xb72e4a6a in QMetaObject::activate (sender=0x9b5aa70, m=0x80950c0, local_signal_index=0, argv=0xbfcc0568) at kernel/qobject.cpp:3278
#19 0xb77437c5 in MuonMainWindow::backendReady (this=0x9b5aa70, _t1=0x9a660e0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb7743933 in MuonMainWindow::initObject (this=0x9b5aa70) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9b5aa70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9b5aa70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcc0694) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb72d5b7d in metacall (argv=0xbfcc0694, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9b5aa70) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9b5aa70, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfcc0694) at kernel/qmetaobject.cpp:232
#25 0xb72e4a6a in QMetaObject::activate (sender=0x9bc2a48, m=0xb7405238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb72ec375 in QSingleShotTimer::timeout (this=0x9bc2a48) at .moc/release-shared/qtimer.moc:82
#27 0xb72ec42c in QSingleShotTimer::timerEvent (this=0x9bc2a48) at kernel/qtimer.cpp:308
#28 0xb72e7994 in QObject::event (this=0x9bc2a48, e=0xbfcc0a8c) at kernel/qobject.cpp:1181
#29 0xb60b6d54 in notify_helper (e=0xbfcc0a8c, receiver=0x9bc2a48, this=0x9a601d0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9a601d0, receiver=0x9bc2a48, e=0xbfcc0a8c) at kernel/qapplication.cpp:4458
#31 0xb60bc103 in QApplication::notify (this=0xbfcc0a8c, receiver=0x9bc2a48, e=0xbfcc0a8c) at kernel/qapplication.cpp:3886
#32 0xb6ed5681 in KApplication::notify (this=0xbfcc0da0, receiver=0x9bc2a48, event=0xbfcc0a8c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb72cf19e in QCoreApplication::notifyInternal (this=0xbfcc0da0, receiver=0x9bc2a48, event=0xbfcc0a8c) at kernel/qcoreapplication.cpp:787
#34 0xb72ffc10 in sendEvent (event=0xbfcc0a8c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9a624c4) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb72fd122 in timerSourceDispatch (source=0x9a62490) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb529725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb5297990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb5297c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb72fdada in QEventDispatcherGlib::processEvents (this=0x9a42238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb616ee3a in QGuiEventDispatcherGlib::processEvents (this=0x9a42238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb72ce1dd in QEventLoop::processEvents (this=0xbfcc0d04, flags=...) at kernel/qeventloop.cpp:149
#43 0xb72ce421 in QEventLoop::exec (this=0xbfcc0d04, flags=...) at kernel/qeventloop.cpp:201
#44 0xb72d319d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb60b48f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292054, bug 292031, bug 292025, bug 292023, bug 292006.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-21 02:31:29 UTC

*** This bug has been marked as a duplicate of bug 291262 ***