Bug 292000 - Muon-installer crash on startup
Summary: Muon-installer crash on startup
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-19 23:37 UTC by joente
Modified: 2012-01-20 06:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joente 2012-01-19 23:37:59 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Starting Muon Installed
After starting it immediatly crashed

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4dfa46a780 (LWP 2656))]

Thread 2 (Thread 0x7f4de3218700 (LWP 2664)):
#0  0x00007f4df703e773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f4df38b3f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4df38b4429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4df91fbf3e in QEventDispatcherGlib::processEvents (this=0x1f326b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f4df91cfcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4df91cfef7 in QEventLoop::exec (this=0x7f4de3217dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f4df90e727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f4df91b2cbf in QInotifyFileSystemWatcherEngine::run (this=0x208a3c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f4df90e9d05 in QThreadPrivate::start (arg=0x208a3c0) at thread/qthread_unix.cpp:331
#9  0x00007f4df4395efc in start_thread (arg=0x7f4de3218700) at pthread_create.c:304
#10 0x00007f4df704a89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4dfa46a780 (LWP 2656)):
[KCrash Handler]
#6  0x00007f4df9137a5e in QtPrivate::QStringList_contains (that=0x7fff15b3ce20, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff15b3ce20) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1ea0950) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1ea0950, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff15b3d3f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f4df91e3eba in QMetaObject::activate (sender=0x1d34c60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1d34c60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff15b3d550) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f4df91e3eba in QMetaObject::activate (sender=0x1ea0950, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff15b3d550) at kernel/qobject.cpp:3278
#13 0x00007f4dfa056e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1edd8d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f4dfa056f8e in MuonMainWindow::initObject (this=0x1ea0950) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1ea0950) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1ea0950, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff15b3d620) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f4df91e3eba in QMetaObject::activate (sender=0x1f581c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f4df91ebf7f in QSingleShotTimer::timerEvent (this=0x1f581c0) at kernel/qtimer.cpp:308
#19 0x00007f4df91e7789 in QObject::event (this=0x1f581c0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f4df780b424 in notify_helper (e=0x7fff15b3db90, receiver=0x1f581c0, this=0x1d42c90) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1d42c90, receiver=0x1f581c0, e=0x7fff15b3db90) at kernel/qapplication.cpp:4458
#22 0x00007f4df7810291 in QApplication::notify (this=0x7fff15b3de90, receiver=0x1f581c0, e=0x7fff15b3db90) at kernel/qapplication.cpp:4365
#23 0x00007f4df89ef126 in KApplication::notify (this=0x7fff15b3de90, receiver=0x1f581c0, event=0x7fff15b3db90) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f4df91d0afc in QCoreApplication::notifyInternal (this=0x7fff15b3de90, receiver=0x1f581c0, event=0x7fff15b3db90) at kernel/qcoreapplication.cpp:787
#25 0x00007f4df91fdd62 in sendEvent (event=0x7fff15b3db90, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1d48030) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f4df91fb514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f4df38b3a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f4df38b4258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f4df38b4429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f4df91fbed6 in QEventDispatcherGlib::processEvents (this=0x1d1e6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f4df78b307e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f4df91cfcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f4df91cfef7 in QEventLoop::exec (this=0x7fff15b3de20, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f4df91d4789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff15b3e108) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291996, bug 291979, bug 291975, bug 291920, bug 291881.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-20 01:13:53 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 webmaster 2012-01-20 06:50:31 UTC
try the following workaround:
perhaps: "sudo apt-get install libkutils4"
then: in muon-Packetmanger under settings:
      Software-Sources 
        other_Software
        X canonical partner (mark)
then the muon-programmanager will work