Bug 291996 - Muon crashes (seg.fault) at start-up
Summary: Muon crashes (seg.fault) at start-up
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-19 21:40 UTC by ka6ope
Modified: 2012-01-20 01:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ka6ope 2012-01-19 21:40:26 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I started Muon from the application launcher just after starting Kubuntu.
Behaviour is systematic.

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4f0f6e0780 (LWP 2693))]

Thread 2 (Thread 0x7f4efae84700 (LWP 2694)):
#0  0x00007f4f0c2b9773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f4f08b2ef68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4f08b2f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4f0e476f3e in QEventDispatcherGlib::processEvents (this=0x833fd0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f4f0e44acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4f0e44aef7 in QEventLoop::exec (this=0x7f4efae83dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f4f0e36227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f4f0e42dcbf in QInotifyFileSystemWatcherEngine::run (this=0x8a2e60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f4f0e364d05 in QThreadPrivate::start (arg=0x8a2e60) at thread/qthread_unix.cpp:331
#9  0x00007f4f09610efc in start_thread (arg=0x7f4efae84700) at pthread_create.c:304
#10 0x00007f4f0c2c589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4f0f6e0780 (LWP 2693)):
[KCrash Handler]
#6  0x00007f4f0e3b2a5e in QtPrivate::QStringList_contains (that=0x7fffbdde7460, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffbdde7460) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x811c40) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x811c40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbdde7a30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f4f0e45eeba in QMetaObject::activate (sender=0x8be8d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x8be8d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbdde7b90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f4f0e45eeba in QMetaObject::activate (sender=0x811c40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbdde7b90) at kernel/qobject.cpp:3278
#13 0x00007f4f0f2d1e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x82def0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f4f0f2d1f8e in MuonMainWindow::initObject (this=0x811c40) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x811c40) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x811c40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbdde7c60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f4f0e45eeba in QMetaObject::activate (sender=0x878c60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f4f0e466f7f in QSingleShotTimer::timerEvent (this=0x878c60) at kernel/qtimer.cpp:308
#19 0x00007f4f0e462789 in QObject::event (this=0x878c60, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f4f0ca86424 in notify_helper (e=0x7fffbdde81d0, receiver=0x878c60, this=0x68eef0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x68eef0, receiver=0x878c60, e=0x7fffbdde81d0) at kernel/qapplication.cpp:4458
#22 0x00007f4f0ca8b291 in QApplication::notify (this=0x7fffbdde84d0, receiver=0x878c60, e=0x7fffbdde81d0) at kernel/qapplication.cpp:4365
#23 0x00007f4f0dc6a126 in KApplication::notify (this=0x7fffbdde84d0, receiver=0x878c60, event=0x7fffbdde81d0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f4f0e44bafc in QCoreApplication::notifyInternal (this=0x7fffbdde84d0, receiver=0x878c60, event=0x7fffbdde81d0) at kernel/qcoreapplication.cpp:787
#25 0x00007f4f0e478d62 in sendEvent (event=0x7fffbdde81d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x68c190) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f4f0e476514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f4f08b2ea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f4f08b2f258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f4f08b2f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f4f0e476ed6 in QEventDispatcherGlib::processEvents (this=0x6676f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f4f0cb2e07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f4f0e44acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f4f0e44aef7 in QEventLoop::exec (this=0x7fffbdde8460, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f4f0e44f789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffbdde8748) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291979, bug 291975, bug 291920, bug 291881, bug 291852.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-20 01:14:20 UTC

*** This bug has been marked as a duplicate of bug 291262 ***