Bug 291852 - Muon installer crushed on every launch
Summary: Muon installer crushed on every launch
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 11:41 UTC by Kollmann
Modified: 2012-01-18 13:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kollmann 2012-01-18 11:41:04 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I restarted my machine. Muon is still crushin (sementation fault) on launch.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f94ba00a780 (LWP 1864))]

Thread 2 (Thread 0x7f94a54b4700 (LWP 1865)):
#0  0x00007f94b6be3773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f94b3458f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94b3459429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f94b8da0f3e in QEventDispatcherGlib::processEvents (this=0x144bf30, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f94b8d74cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f94b8d74ef7 in QEventLoop::exec (this=0x7f94a54b3dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f94b8c8c27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f94b8d57cbf in QInotifyFileSystemWatcherEngine::run (this=0x151d000) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f94b8c8ed05 in QThreadPrivate::start (arg=0x151d000) at thread/qthread_unix.cpp:331
#9  0x00007f94b3f3aefc in start_thread (arg=0x7f94a54b4700) at pthread_create.c:304
#10 0x00007f94b6bef89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f94ba00a780 (LWP 1864)):
[KCrash Handler]
#6  0x00007f94b8cdca5e in QtPrivate::QStringList_contains (that=0x7fffb443f8a0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffb443f8a0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x15206b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x15206b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb443fe70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f94b8d88eba in QMetaObject::activate (sender=0x15a5310, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x15a5310, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb443ffd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f94b8d88eba in QMetaObject::activate (sender=0x15206b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffb443ffd0) at kernel/qobject.cpp:3278
#13 0x00007f94b9bfbe7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x15c31a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f94b9bfbf8e in MuonMainWindow::initObject (this=0x15206b0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x15206b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x15206b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb44400a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f94b8d88eba in QMetaObject::activate (sender=0x15a9fb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f94b8d90f7f in QSingleShotTimer::timerEvent (this=0x15a9fb0) at kernel/qtimer.cpp:308
#19 0x00007f94b8d8c789 in QObject::event (this=0x15a9fb0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f94b73b0424 in notify_helper (e=0x7fffb4440610, receiver=0x15a9fb0, this=0x13a35d0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x13a35d0, receiver=0x15a9fb0, e=0x7fffb4440610) at kernel/qapplication.cpp:4458
#22 0x00007f94b73b5291 in QApplication::notify (this=0x7fffb4440910, receiver=0x15a9fb0, e=0x7fffb4440610) at kernel/qapplication.cpp:4365
#23 0x00007f94b8594126 in KApplication::notify (this=0x7fffb4440910, receiver=0x15a9fb0, event=0x7fffb4440610) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f94b8d75afc in QCoreApplication::notifyInternal (this=0x7fffb4440910, receiver=0x15a9fb0, event=0x7fffb4440610) at kernel/qcoreapplication.cpp:787
#25 0x00007f94b8da2d62 in sendEvent (event=0x7fffb4440610, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x13a49a0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f94b8da0514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f94b3458a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f94b3459258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f94b3459429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f94b8da0ed6 in QEventDispatcherGlib::processEvents (this=0x137a6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f94b745807e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f94b8d74cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f94b8d74ef7 in QEventLoop::exec (this=0x7fffb44408a0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f94b8d79789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffb4440b88) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291832, bug 291811, bug 291804, bug 291793, bug 291790.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-18 13:54:03 UTC

*** This bug has been marked as a duplicate of bug 291262 ***