Bug 291975 - Muon crashes upon opening
Summary: Muon crashes upon opening
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-19 18:19 UTC by Ady
Modified: 2012-01-26 06:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.09 KB, text/plain)
2012-01-26 06:29 UTC, Benjamin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ady 2012-01-19 18:19:15 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Nothing, simply started muon via  the application launcher

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7873930 (LWP 2324))]

Thread 2 (Thread 0xb59adb70 (LWP 2327)):
#0  0x00d09416 in __kernel_vsyscall ()
#1  0x00a0140e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x02f5c34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x02f4d896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x02f4dc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0072eb37 in QEventDispatcherGlib::processEvents (this=0x8dea4e8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x006ff1dd in QEventLoop::processEvents (this=0xb59ad2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x006ff421 in QEventLoop::exec (this=0xb59ad2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0060290b in QThread::exec (this=0x8e265d8) at thread/qthread.cpp:498
#9  0x006dfe2d in QInotifyFileSystemWatcherEngine::run (this=0x8e265d8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x006057b3 in QThreadPrivate::start (arg=0x8e265d8) at thread/qthread_unix.cpp:331
#11 0x00b23d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00a100ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7873930 (LWP 2324)):
[KCrash Handler]
#7  0x00659e11 in QtPrivate::QStringList_contains (that=0xbf844d94, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf844d94) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8d7a9d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8d7a9d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf844fb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00706b7d in metacall (argv=0xbf844fb4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8d7a9d0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8d7a9d0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf844fb4) at kernel/qmetaobject.cpp:232
#13 0x00715a6a in QMetaObject::activate (sender=0x8defc70, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8defc70) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8defc70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8450f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00706b7d in metacall (argv=0xbf8450f8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8defc70) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8defc70, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8450f8) at kernel/qmetaobject.cpp:232
#18 0x00715a6a in QMetaObject::activate (sender=0x8d7a9d0, m=0x80950c0, local_signal_index=0, argv=0xbf8450f8) at kernel/qobject.cpp:3278
#19 0x0090a7c5 in MuonMainWindow::backendReady (this=0x8d7a9d0, _t1=0x8dd1b38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0090a933 in MuonMainWindow::initObject (this=0x8d7a9d0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8d7a9d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8d7a9d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf845224) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00706b7d in metacall (argv=0xbf845224, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8d7a9d0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8d7a9d0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf845224) at kernel/qmetaobject.cpp:232
#25 0x00715a6a in QMetaObject::activate (sender=0x8df2d68, m=0x836238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0071d375 in QSingleShotTimer::timeout (this=0x8df2d68) at .moc/release-shared/qtimer.moc:82
#27 0x0071d42c in QSingleShotTimer::timerEvent (this=0x8df2d68) at kernel/qtimer.cpp:308
#28 0x00718994 in QObject::event (this=0x8df2d68, e=0xbf84561c) at kernel/qobject.cpp:1181
#29 0x01732d54 in notify_helper (e=0xbf84561c, receiver=0x8df2d68, this=0x8c91cb8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8c91cb8, receiver=0x8df2d68, e=0xbf84561c) at kernel/qapplication.cpp:4458
#31 0x01738103 in QApplication::notify (this=0xbf84561c, receiver=0x8df2d68, e=0xbf84561c) at kernel/qapplication.cpp:3886
#32 0x01002681 in KApplication::notify (this=0xbf845930, receiver=0x8df2d68, event=0xbf84561c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0070019e in QCoreApplication::notifyInternal (this=0xbf845930, receiver=0x8df2d68, event=0xbf84561c) at kernel/qcoreapplication.cpp:787
#34 0x00730c10 in sendEvent (event=0xbf84561c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8c8d484) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0072e155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x8c8d4b8) at kernel/qeventdispatcher_glib.cpp:231
#38 0x02f4d25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02f4d990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x02f4dc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x0072eada in QEventDispatcherGlib::processEvents (this=0x8c6f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0x017eae3a in QGuiEventDispatcherGlib::processEvents (this=0x8c6f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x006ff1dd in QEventLoop::processEvents (this=0xbf845894, flags=...) at kernel/qeventloop.cpp:149
#44 0x006ff421 in QEventLoop::exec (this=0xbf845894, flags=...) at kernel/qeventloop.cpp:201
#45 0x0070419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0x017308f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291920, bug 291881, bug 291852, bug 291832, bug 291811.

Reported using DrKonqi
Comment 1 Thijs 2012-01-19 18:21:05 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Benjamin 2012-01-26 06:29:13 UTC
Created attachment 68186 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Launched muon via application menu, would show menu bar and window panes and then crash.

-- Backtrace (Reduced):
#6  0x00007ffeb7ca9a5e in QtPrivate::QStringList_contains (that=0x7fff6fdd3b10, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff6fdd3b10) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1bc5e30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1bc5e30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6fdd40e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1c85740, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6fdd4240) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109