Bug 291920 - Muon crash all the time
Summary: Muon crash all the time
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-19 03:06 UTC by andré gomez
Modified: 2012-01-20 15:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andré gomez 2012-01-19 03:06:32 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I was using mozilla firefox, kopete, skype, and when I started the K3b to copy a Dvd, this program informed to me that is necessary to install a package about dvd formats. I copyed the name of the package and just started Muon. Before the comand or any other texts or button of Muon appeared, it just crashed and Kde asked to send this relatory.

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7742930 (LWP 4671))]

Thread 2 (Thread 0xb52c3b70 (LWP 4675)):
#0  0x00656dbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00593f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x043deceb in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x043df8f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x043dfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00dd8b37 in QEventDispatcherGlib::processEvents (this=0x9196560, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00da91dd in QEventLoop::processEvents (this=0xb52c32b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00da9421 in QEventLoop::exec (this=0xb52c32b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00cac90b in QThread::exec (this=0x92e0168) at thread/qthread.cpp:498
#9  0x00d89e2d in QInotifyFileSystemWatcherEngine::run (this=0x92e0168) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00caf7b3 in QThreadPrivate::start (arg=0x92e0168) at thread/qthread_unix.cpp:331
#11 0x00654d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x005860ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7742930 (LWP 4671)):
[KCrash Handler]
#7  0x00d03e11 in QtPrivate::QStringList_contains (that=0xbf937224, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf937224) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x919e740) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x919e740, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf937444) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00db0b7d in metacall (argv=0xbf937444, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x919e740) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x919e740, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf937444) at kernel/qmetaobject.cpp:232
#13 0x00dbfa6a in QMetaObject::activate (sender=0x91dca50, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x91dca50) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x91dca50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf937588) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00db0b7d in metacall (argv=0xbf937588, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x91dca50) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x91dca50, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf937588) at kernel/qmetaobject.cpp:232
#18 0x00dbfa6a in QMetaObject::activate (sender=0x919e740, m=0x80950c0, local_signal_index=0, argv=0xbf937588) at kernel/qobject.cpp:3278
#19 0x00bcd7c5 in MuonMainWindow::backendReady (this=0x919e740, _t1=0x91d49e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00bcd933 in MuonMainWindow::initObject (this=0x919e740) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x919e740) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x919e740, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9376b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00db0b7d in metacall (argv=0xbf9376b4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x919e740) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x919e740, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9376b4) at kernel/qmetaobject.cpp:232
#25 0x00dbfa6a in QMetaObject::activate (sender=0x91e7bd8, m=0xee0238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00dc7375 in QSingleShotTimer::timeout (this=0x91e7bd8) at .moc/release-shared/qtimer.moc:82
#27 0x00dc742c in QSingleShotTimer::timerEvent (this=0x91e7bd8) at kernel/qtimer.cpp:308
#28 0x00dc2994 in QObject::event (this=0x91e7bd8, e=0xbf937aac) at kernel/qobject.cpp:1181
#29 0x01475d54 in notify_helper (e=0xbf937aac, receiver=0x91e7bd8, this=0x908f428) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x908f428, receiver=0x91e7bd8, e=0xbf937aac) at kernel/qapplication.cpp:4458
#31 0x0147b103 in QApplication::notify (this=0xbf937aac, receiver=0x91e7bd8, e=0xbf937aac) at kernel/qapplication.cpp:3886
#32 0x010cc681 in KApplication::notify (this=0xbf937dc0, receiver=0x91e7bd8, event=0xbf937aac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00daa19e in QCoreApplication::notifyInternal (this=0xbf937dc0, receiver=0x91e7bd8, event=0xbf937aac) at kernel/qcoreapplication.cpp:787
#34 0x00ddac10 in sendEvent (event=0xbf937aac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x908b73c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00dd8122 in timerSourceDispatch (source=0x908b708) at kernel/qeventdispatcher_glib.cpp:184
#37 0x043df25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x043df990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x043dfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00dd8ada in QEventDispatcherGlib::processEvents (this=0x906d238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0152de3a in QGuiEventDispatcherGlib::processEvents (this=0x906d238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00da91dd in QEventLoop::processEvents (this=0xbf937d24, flags=...) at kernel/qeventloop.cpp:149
#43 0x00da9421 in QEventLoop::exec (this=0xbf937d24, flags=...) at kernel/qeventloop.cpp:201
#44 0x00dae19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x014738f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291811, bug 291804, bug 291793, bug 291790, bug 291783.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-19 04:35:42 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 andré gomez 2012-01-20 15:36:41 UTC
Good afternoon, sir!

The solution of the duplicated bug report (showed bellow) didn't worked in
my system.
Muon, in my Kubuntu system, still crashing all the time, at it's startup,
and show just a window, without buttons or texts
So, I ask you for some other procedure.

Thank you!

André Gomez

******************************************************************
--- Comment #108 from  <webmaster sqlplus org>  2012-01-19 17:17:41 ---
Try thefollowing workaround:
perhaps: "sudo apt-get install libkutils4"
then: in muon-Packetmanger under settings:
     Software-Sources
       other_Software
       X canonical partner (mark)

then the muon-programmanager will start wihout Problems
***********************************************************************


2012/1/19 Jekyll Wu <adaptee@gmail.com>

> https://bugs.kde.org/show_bug.cgi?id=291920
>
>
> Jekyll Wu <adaptee@gmail.com> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |RESOLVED
>                 CC|                            |adaptee@gmail.com
>         Resolution|                            |DUPLICATE
>
>
>
>
> --- Comment #1 from Jekyll Wu <adaptee gmail com>  2012-01-19 04:35:42 ---
>
>
> *** This bug has been marked as a duplicate of bug 291262 ***
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>