Bug 291881 - Центр программ Muon вылетает сразу же при попытке запуска
Summary: Центр программ Muon вылетает сразу же при попытке запуска
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 17:10 UTC by Pavel
Modified: 2012-01-18 17:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel 2012-01-18 17:10:39 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Центр программ Muon вылетает сразу же при попытке запуска. Ошибка повторяется с каждой новой попыткой перезапустить программу.

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7825930 (LWP 2256))]

Thread 2 (Thread 0xb5564b70 (LWP 2260)):
#0  0x00a0d416 in __kernel_vsyscall ()
#1  0x00bb540e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x024e534b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x024d6896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x024d6c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x007f1b37 in QEventDispatcherGlib::processEvents (this=0x86fc2e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x007c21dd in QEventLoop::processEvents (this=0xb55642b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x007c2421 in QEventLoop::exec (this=0xb55642b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x006c590b in QThread::exec (this=0x85f8798) at thread/qthread.cpp:498
#9  0x007a2e2d in QInotifyFileSystemWatcherEngine::run (this=0x85f8798) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x006c87b3 in QThreadPrivate::start (arg=0x85f8798) at thread/qthread_unix.cpp:331
#11 0x009dfd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00bc40ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7825930 (LWP 2256)):
[KCrash Handler]
#7  0x0071ce11 in QtPrivate::QStringList_contains (that=0xbfec29d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfec29d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8592118) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8592118, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec2bf4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x007c9b7d in metacall (argv=0xbfec2bf4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8592118) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8592118, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfec2bf4) at kernel/qmetaobject.cpp:232
#13 0x007d8a6a in QMetaObject::activate (sender=0x85ea6f0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x85ea6f0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x85ea6f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec2d38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x007c9b7d in metacall (argv=0xbfec2d38, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x85ea6f0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x85ea6f0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfec2d38) at kernel/qmetaobject.cpp:232
#18 0x007d8a6a in QMetaObject::activate (sender=0x8592118, m=0x80950c0, local_signal_index=0, argv=0xbfec2d38) at kernel/qobject.cpp:3278
#19 0x00abe7c5 in MuonMainWindow::backendReady (this=0x8592118, _t1=0x84a4890) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00abe933 in MuonMainWindow::initObject (this=0x8592118) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8592118) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8592118, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfec2e64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x007c9b7d in metacall (argv=0xbfec2e64, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8592118) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8592118, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfec2e64) at kernel/qmetaobject.cpp:232
#25 0x007d8a6a in QMetaObject::activate (sender=0x8606aa8, m=0x8f9238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x007e0375 in QSingleShotTimer::timeout (this=0x8606aa8) at .moc/release-shared/qtimer.moc:82
#27 0x007e042c in QSingleShotTimer::timerEvent (this=0x8606aa8) at kernel/qtimer.cpp:308
#28 0x007db994 in QObject::event (this=0x8606aa8, e=0xbfec325c) at kernel/qobject.cpp:1181
#29 0x018e6d54 in notify_helper (e=0xbfec325c, receiver=0x8606aa8, this=0x84a1db0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x84a1db0, receiver=0x8606aa8, e=0xbfec325c) at kernel/qapplication.cpp:4458
#31 0x018ec103 in QApplication::notify (this=0xbfec325c, receiver=0x8606aa8, e=0xbfec325c) at kernel/qapplication.cpp:3886
#32 0x00edf681 in KApplication::notify (this=0xbfec3570, receiver=0x8606aa8, event=0xbfec325c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x007c319e in QCoreApplication::notifyInternal (this=0xbfec3570, receiver=0x8606aa8, event=0xbfec325c) at kernel/qcoreapplication.cpp:787
#34 0x007f3c10 in sendEvent (event=0xbfec325c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x849e34c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x007f1155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x849e380) at kernel/qeventdispatcher_glib.cpp:231
#38 0x024d625f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x024d6990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x024d6c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x007f1ada in QEventDispatcherGlib::processEvents (this=0x847f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0x0199ee3a in QGuiEventDispatcherGlib::processEvents (this=0x847f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x007c21dd in QEventLoop::processEvents (this=0xbfec34d4, flags=...) at kernel/qeventloop.cpp:149
#44 0x007c2421 in QEventLoop::exec (this=0xbfec34d4, flags=...) at kernel/qeventloop.cpp:201
#45 0x007c719d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0x018e48f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291852, bug 291832, bug 291811, bug 291804, bug 291793.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-18 17:14:22 UTC

*** This bug has been marked as a duplicate of bug 291262 ***