Bug 291811 - error
Summary: error
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 23:00 UTC by jose barrios pantoja
Modified: 2012-01-18 13:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jose barrios pantoja 2012-01-17 23:00:53 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
no me deja entrar al muon

The crash can be reproduced some of the time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb783a930 (LWP 1745))]

Thread 2 (Thread 0xb56d5b70 (LWP 1749)):
#0  0x02690887 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x02690c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x00ff3b37 in QEventDispatcherGlib::processEvents (this=0x8f11ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00fc41dd in QEventLoop::processEvents (this=0xb56d52b0, flags=...) at kernel/qeventloop.cpp:149
#4  0x00fc4421 in QEventLoop::exec (this=0xb56d52b0, flags=...) at kernel/qeventloop.cpp:201
#5  0x00ec790b in QThread::exec (this=0x8dfc9f0) at thread/qthread.cpp:498
#6  0x00fa4e2d in QInotifyFileSystemWatcherEngine::run (this=0x8dfc9f0) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00eca7b3 in QThreadPrivate::start (arg=0x8dfc9f0) at thread/qthread_unix.cpp:331
#8  0x00996d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0x00a910ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb783a930 (LWP 1745)):
[KCrash Handler]
#7  0x00f1ee11 in QtPrivate::QStringList_contains (that=0xbfc2a8d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc2a8d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8dab6d8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8dab6d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc2aaf4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00fcbb7d in metacall (argv=0xbfc2aaf4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8dab6d8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8dab6d8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc2aaf4) at kernel/qmetaobject.cpp:232
#13 0x00fdaa6a in QMetaObject::activate (sender=0x8dfc230, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8dfc230) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8dfc230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc2ac38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00fcbb7d in metacall (argv=0xbfc2ac38, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8dfc230) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8dfc230, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc2ac38) at kernel/qmetaobject.cpp:232
#18 0x00fdaa6a in QMetaObject::activate (sender=0x8dab6d8, m=0x80950c0, local_signal_index=0, argv=0xbfc2ac38) at kernel/qobject.cpp:3278
#19 0x005a07c5 in MuonMainWindow::backendReady (this=0x8dab6d8, _t1=0x8e09ad8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x005a0933 in MuonMainWindow::initObject (this=0x8dab6d8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8dab6d8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8dab6d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc2ad64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00fcbb7d in metacall (argv=0xbfc2ad64, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8dab6d8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8dab6d8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc2ad64) at kernel/qmetaobject.cpp:232
#25 0x00fdaa6a in QMetaObject::activate (sender=0x8e22898, m=0x10fb238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00fe2375 in QSingleShotTimer::timeout (this=0x8e22898) at .moc/release-shared/qtimer.moc:82
#27 0x00fe242c in QSingleShotTimer::timerEvent (this=0x8e22898) at kernel/qtimer.cpp:308
#28 0x00fdd994 in QObject::event (this=0x8e22898, e=0xbfc2b15c) at kernel/qobject.cpp:1181
#29 0x034a1d54 in notify_helper (e=0xbfc2b15c, receiver=0x8e22898, this=0x8cb8660) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8cb8660, receiver=0x8e22898, e=0xbfc2b15c) at kernel/qapplication.cpp:4458
#31 0x034a7103 in QApplication::notify (this=0xbfc2b15c, receiver=0x8e22898, e=0xbfc2b15c) at kernel/qapplication.cpp:3886
#32 0x015c8681 in KApplication::notify (this=0xbfc2b470, receiver=0x8e22898, event=0xbfc2b15c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00fc519e in QCoreApplication::notifyInternal (this=0xbfc2b470, receiver=0x8e22898, event=0xbfc2b15c) at kernel/qcoreapplication.cpp:787
#34 0x00ff5c10 in sendEvent (event=0xbfc2b15c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8cb9434) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00ff3122 in timerSourceDispatch (source=0x8cb9400) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0269025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x02690990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02690c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00ff3ada in QEventDispatcherGlib::processEvents (this=0x8c9b238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03559e3a in QGuiEventDispatcherGlib::processEvents (this=0x8c9b238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00fc41dd in QEventLoop::processEvents (this=0xbfc2b3d4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00fc4421 in QEventLoop::exec (this=0xbfc2b3d4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00fc919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0349f8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291804, bug 291793, bug 291790, bug 291783, bug 291782.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-18 13:53:51 UTC

*** This bug has been marked as a duplicate of bug 291262 ***