Bug 291832 - muon-installer always crashing
Summary: muon-installer always crashing
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 03:29 UTC by nonameismyname
Modified: 2012-01-18 14:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.70 KB, text/plain)
2012-01-18 04:44 UTC, Eugen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nonameismyname 2012-01-18 03:29:19 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
No further infos available

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0ea31d1780 (LWP 20939))]

Thread 2 (Thread 0x7f0e8e612700 (LWP 20940)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f0e8e611af0 in ?? ()
#2  0x00007fff92dff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f0ea31d1780 (LWP 20939)):
[KCrash Handler]
#6  0x00007f0ea1ea4a5e in QtPrivate::QStringList_contains (that=0x7fff92c84670, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff92c84670) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x110a760) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x110a760, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff92c84c40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f0ea1f50eba in QMetaObject::activate (sender=0x11d4c30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x11d4c30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff92c84da0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f0ea1f50eba in QMetaObject::activate (sender=0x110a760, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff92c84da0) at kernel/qobject.cpp:3278
#13 0x00007f0ea2dc3e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1173f40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f0ea2dc3f8e in MuonMainWindow::initObject (this=0x110a760) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x110a760) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x110a760, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff92c84e70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f0ea1f50eba in QMetaObject::activate (sender=0x11a5b50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f0ea1f58f7f in QSingleShotTimer::timerEvent (this=0x11a5b50) at kernel/qtimer.cpp:308
#19 0x00007f0ea1f54789 in QObject::event (this=0x11a5b50, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f0ea0578424 in notify_helper (e=0x7fff92c853e0, receiver=0x11a5b50, this=0xfb6410) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xfb6410, receiver=0x11a5b50, e=0x7fff92c853e0) at kernel/qapplication.cpp:4458
#22 0x00007f0ea057d291 in QApplication::notify (this=0x7fff92c856e0, receiver=0x11a5b50, e=0x7fff92c853e0) at kernel/qapplication.cpp:4365
#23 0x00007f0ea175c126 in KApplication::notify (this=0x7fff92c856e0, receiver=0x11a5b50, event=0x7fff92c853e0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f0ea1f3dafc in QCoreApplication::notifyInternal (this=0x7fff92c856e0, receiver=0x11a5b50, event=0x7fff92c853e0) at kernel/qcoreapplication.cpp:787
#25 0x00007f0ea1f6ad62 in sendEvent (event=0x7fff92c853e0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xfb3ed0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f0ea1f68514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f0e9c620a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f0e9c621258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f0e9c621429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f0ea1f68ed6 in QEventDispatcherGlib::processEvents (this=0xf8e6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f0ea062007e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f0ea1f3ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f0ea1f3cef7 in QEventLoop::exec (this=0x7fff92c85670, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f0ea1f41789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff92c85958) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291811, bug 291804, bug 291793, bug 291790, bug 291783.

Reported using DrKonqi
Comment 1 Eugen 2012-01-18 04:44:07 UTC
Created attachment 67959 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

After updating of mine Ubuntu, Muon began to fall constantly. It isn't started at all, at once gives out an error.

-- Backtrace (Reduced):
#7  0x007efe11 in QtPrivate::QStringList_contains (that=0xbfde2d04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfde2d04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa095138) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa095138, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfde2f24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0089cb7d in metacall (argv=0xbfde2f24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa095138) at kernel/qmetaobject.cpp:237
Comment 2 Jekyll Wu 2012-01-18 14:10:08 UTC

*** This bug has been marked as a duplicate of bug 291262 ***