Bug 291804 - muon software center crashed when being opened
Summary: muon software center crashed when being opened
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 19:58 UTC by Steve
Modified: 2012-01-18 00:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.62 KB, text/plain)
2012-01-18 00:27 UTC, Andrius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve 2012-01-17 19:58:58 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

running devede and tried to open muon software center no other applications were running.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fdf2667c780 (LWP 10153))]

Thread 2 (Thread 0x7fdf11cc5700 (LWP 10157)):
#0  0x00007fffaed6592c in clock_gettime ()
#1  0x00007fdf1fd7307b in __GI_clock_gettime (clock_id=1, tp=0x7fdf11cc4b40) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007fdf25344074 in do_gettime (frac=0x7fdf11cc4b58, sec=0x7fdf11cc4b50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fdf254066ed in QTimerInfoList::updateCurrentTime (this=0xa5db70) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007fdf25406a33 in QTimerInfoList::timerWait (this=0xa5db70, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007fdf2540544c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fdf11cc4c3c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fdf254054f5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fdf1fabcff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fdf1fabddfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fdf1fabe429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fdf25405f3e in QEventDispatcherGlib::processEvents (this=0xa5cd60, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007fdf253d9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fdf253d9ef7 in QEventLoop::exec (this=0x7fdf11cc4dd0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007fdf252f127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007fdf253bccbf in QInotifyFileSystemWatcherEngine::run (this=0x8daa80) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fdf252f3d05 in QThreadPrivate::start (arg=0x8daa80) at thread/qthread_unix.cpp:331
#17 0x00007fdf2059fefc in start_thread (arg=0x7fdf11cc5700) at pthread_create.c:304
#18 0x00007fdf2325489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fdf2667c780 (LWP 10153)):
[KCrash Handler]
#6  0x00007fdf25341a5e in QtPrivate::QStringList_contains (that=0x7fffaed03f80, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffaed03f80) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x8787d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x8787d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffaed04550) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fdf253edeba in QMetaObject::activate (sender=0x8b2150, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x8b2150, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffaed046b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fdf253edeba in QMetaObject::activate (sender=0x8787d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffaed046b0) at kernel/qobject.cpp:3278
#13 0x00007fdf26260e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x8ec760) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fdf26260f8e in MuonMainWindow::initObject (this=0x8787d0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x8787d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x8787d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffaed04780) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fdf253edeba in QMetaObject::activate (sender=0x8f7390, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fdf253f5f7f in QSingleShotTimer::timerEvent (this=0x8f7390) at kernel/qtimer.cpp:308
#19 0x00007fdf253f1789 in QObject::event (this=0x8f7390, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fdf23a15424 in notify_helper (e=0x7fffaed04cf0, receiver=0x8f7390, this=0x727f40) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x727f40, receiver=0x8f7390, e=0x7fffaed04cf0) at kernel/qapplication.cpp:4458
#22 0x00007fdf23a1a291 in QApplication::notify (this=0x7fffaed04ff0, receiver=0x8f7390, e=0x7fffaed04cf0) at kernel/qapplication.cpp:4365
#23 0x00007fdf24bf9126 in KApplication::notify (this=0x7fffaed04ff0, receiver=0x8f7390, event=0x7fffaed04cf0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fdf253daafc in QCoreApplication::notifyInternal (this=0x7fffaed04ff0, receiver=0x8f7390, event=0x7fffaed04cf0) at kernel/qcoreapplication.cpp:787
#25 0x00007fdf25407d62 in sendEvent (event=0x7fffaed04cf0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x722550) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fdf25405514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fdf1fabda5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fdf1fabe258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fdf1fabe429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fdf25405ed6 in QEventDispatcherGlib::processEvents (this=0x6fe6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fdf23abd07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fdf253d9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fdf253d9ef7 in QEventLoop::exec (this=0x7fffaed04f80, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fdf253de789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffaed05268) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291793, bug 291790, bug 291783, bug 291782, bug 291778.

Reported using DrKonqi
Comment 1 Andrius 2012-01-18 00:27:15 UTC
Created attachment 67946 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:
when i trying to open it it crash's, just one time it run property.

-- Backtrace (Reduced):
#7  0x00739e11 in QtPrivate::QStringList_contains (that=0xbfacf394, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfacf394) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9365720) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9365720, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfacf5b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x007e6b7d in metacall (argv=0xbfacf5b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9365720) at kernel/qmetaobject.cpp:237
Comment 2 Jekyll Wu 2012-01-18 00:45:36 UTC

*** This bug has been marked as a duplicate of bug 291262 ***