Bug 291793 - Centro de Software Muon cae al iniciar
Summary: Centro de Software Muon cae al iniciar
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 17:11 UTC by Cesar
Modified: 2012-01-17 17:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cesar 2012-01-17 17:11:59 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: el centro de software muon cae al lanzar la aplicacion no habia sucedido antes de la primer actualizacion de software que se hizo...

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77fe930 (LWP 4672))]

Thread 2 (Thread 0xb548eb70 (LWP 4676)):
#0  operator!= (value=2, this=0x910979c) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:75
#1  postEventSourcePrepare (s=0x9109768, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:265
#2  0x01fe088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01fe1637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01fe1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00822b37 in QEventDispatcherGlib::processEvents (this=0x90da958, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x007f31dd in QEventLoop::processEvents (this=0xb548e2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x007f3421 in QEventLoop::exec (this=0xb548e2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x006f690b in QThread::exec (this=0x8fc7858) at thread/qthread.cpp:498
#9  0x007d3e2d in QInotifyFileSystemWatcherEngine::run (this=0x8fc7858) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x006f97b3 in QThreadPrivate::start (arg=0x8fc7858) at thread/qthread_unix.cpp:331
#11 0x00632d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00aa00ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77fe930 (LWP 4672)):
[KCrash Handler]
#7  0x0074de11 in QtPrivate::QStringList_contains (that=0xbfd9a7a4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd9a7a4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x908a098) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x908a098, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd9a9c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x007fab7d in metacall (argv=0xbfd9a9c4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x908a098) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x908a098, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd9a9c4) at kernel/qmetaobject.cpp:232
#13 0x00809a6a in QMetaObject::activate (sender=0x90ff008, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x90ff008) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x90ff008, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd9ab08) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x007fab7d in metacall (argv=0xbfd9ab08, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x90ff008) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x90ff008, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd9ab08) at kernel/qmetaobject.cpp:232
#18 0x00809a6a in QMetaObject::activate (sender=0x908a098, m=0x80950c0, local_signal_index=0, argv=0xbfd9ab08) at kernel/qobject.cpp:3278
#19 0x005857c5 in MuonMainWindow::backendReady (this=0x908a098, _t1=0x90c87f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00585933 in MuonMainWindow::initObject (this=0x908a098) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x908a098) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x908a098, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd9ac34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x007fab7d in metacall (argv=0xbfd9ac34, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x908a098) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x908a098, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd9ac34) at kernel/qmetaobject.cpp:232
#25 0x00809a6a in QMetaObject::activate (sender=0x90ceba8, m=0x92a238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00811375 in QSingleShotTimer::timeout (this=0x90ceba8) at .moc/release-shared/qtimer.moc:82
#27 0x0081142c in QSingleShotTimer::timerEvent (this=0x90ceba8) at kernel/qtimer.cpp:308
#28 0x0080c994 in QObject::event (this=0x90ceba8, e=0xbfd9b02c) at kernel/qobject.cpp:1181
#29 0x022b9d54 in notify_helper (e=0xbfd9b02c, receiver=0x90ceba8, this=0x8f59ed0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8f59ed0, receiver=0x90ceba8, e=0xbfd9b02c) at kernel/qapplication.cpp:4458
#31 0x022bf103 in QApplication::notify (this=0xbfd9b02c, receiver=0x90ceba8, e=0xbfd9b02c) at kernel/qapplication.cpp:3886
#32 0x0109c681 in KApplication::notify (this=0xbfd9b340, receiver=0x90ceba8, event=0xbfd9b02c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x007f419e in QCoreApplication::notifyInternal (this=0xbfd9b340, receiver=0x90ceba8, event=0xbfd9b02c) at kernel/qcoreapplication.cpp:787
#34 0x00824c10 in sendEvent (event=0xbfd9b02c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8f51874) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00822122 in timerSourceDispatch (source=0x8f51840) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01fe125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01fe1990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01fe1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00822ada in QEventDispatcherGlib::processEvents (this=0x8f33238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02371e3a in QGuiEventDispatcherGlib::processEvents (this=0x8f33238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x007f31dd in QEventLoop::processEvents (this=0xbfd9b2a4, flags=...) at kernel/qeventloop.cpp:149
#43 0x007f3421 in QEventLoop::exec (this=0xbfd9b2a4, flags=...) at kernel/qeventloop.cpp:201
#44 0x007f819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x022b78f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291782.

Possible duplicates by query: bug 291790, bug 291783, bug 291782, bug 291778, bug 291776.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-17 17:22:02 UTC

*** This bug has been marked as a duplicate of bug 291262 ***