Bug 291790 - muon crache @ start
Summary: muon crache @ start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 16:39 UTC by elmo86wagt
Modified: 2012-01-17 17:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description elmo86wagt 2012-01-17 16:39:18 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
startet one week a go. rest of pc is stebel

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb47aa930 (LWP 16618))]

Thread 2 (Thread 0xb09beb70 (LWP 16626)):
#0  0xb52f7d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb71d27d5 in do_gettime (frac=0xb09be020, sec=0xb09be018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb72a54b6 in QTimerInfoList::updateCurrentTime (this=0xb000107c) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb72a580a in QTimerInfoList::timerWait (this=0xb000107c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb72a4053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb09be12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb72a40ed in timerSourcePrepare (source=0xb0001048, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb523d88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb523e637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb523ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb72a4b37 in QEventDispatcherGlib::processEvents (this=0x9f0d490, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb72751dd in QEventLoop::processEvents (this=0xb09be2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb7275421 in QEventLoop::exec (this=0xb09be2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb717890b in QThread::exec (this=0x9f5d3e0) at thread/qthread.cpp:498
#14 0xb7255e2d in QInotifyFileSystemWatcherEngine::run (this=0x9f5d3e0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb717b7b3 in QThreadPrivate::start (arg=0x9f5d3e0) at thread/qthread_unix.cpp:331
#16 0xb5324d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5d710ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb47aa930 (LWP 16618)):
[KCrash Handler]
#7  0xb71cfe11 in QtPrivate::QStringList_contains (that=0xbf88c844, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf88c844) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9edee10) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9edee10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf88ca64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb727cb7d in metacall (argv=0xbf88ca64, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9edee10) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9edee10, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf88ca64) at kernel/qmetaobject.cpp:232
#13 0xb728ba6a in QMetaObject::activate (sender=0x9f696e8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9f696e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9f696e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf88cba8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb727cb7d in metacall (argv=0xbf88cba8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9f696e8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9f696e8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf88cba8) at kernel/qmetaobject.cpp:232
#18 0xb728ba6a in QMetaObject::activate (sender=0x9edee10, m=0x80950c0, local_signal_index=0, argv=0xbf88cba8) at kernel/qobject.cpp:3278
#19 0xb76ea7c5 in MuonMainWindow::backendReady (this=0x9edee10, _t1=0x9f48358) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb76ea933 in MuonMainWindow::initObject (this=0x9edee10) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9edee10) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9edee10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf88ccd4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb727cb7d in metacall (argv=0xbf88ccd4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9edee10) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9edee10, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf88ccd4) at kernel/qmetaobject.cpp:232
#25 0xb728ba6a in QMetaObject::activate (sender=0x9f2cf88, m=0xb73ac238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7293375 in QSingleShotTimer::timeout (this=0x9f2cf88) at .moc/release-shared/qtimer.moc:82
#27 0xb729342c in QSingleShotTimer::timerEvent (this=0x9f2cf88) at kernel/qtimer.cpp:308
#28 0xb728e994 in QObject::event (this=0x9f2cf88, e=0xbf88d0cc) at kernel/qobject.cpp:1181
#29 0xb605dd54 in notify_helper (e=0xbf88d0cc, receiver=0x9f2cf88, this=0x9e1a500) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9e1a500, receiver=0x9f2cf88, e=0xbf88d0cc) at kernel/qapplication.cpp:4458
#31 0xb6063103 in QApplication::notify (this=0xbf88d0cc, receiver=0x9f2cf88, e=0xbf88d0cc) at kernel/qapplication.cpp:3886
#32 0xb6e7c681 in KApplication::notify (this=0xbf88d3e0, receiver=0x9f2cf88, event=0xbf88d0cc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb727619e in QCoreApplication::notifyInternal (this=0xbf88d3e0, receiver=0x9f2cf88, event=0xbf88d0cc) at kernel/qcoreapplication.cpp:787
#34 0xb72a6c10 in sendEvent (event=0xbf88d0cc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9e15934) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb72a4155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x9e15968) at kernel/qeventdispatcher_glib.cpp:231
#38 0xb523e25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb523e990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb523ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0xb72a4ada in QEventDispatcherGlib::processEvents (this=0x9df7238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0xb6115e3a in QGuiEventDispatcherGlib::processEvents (this=0x9df7238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0xb72751dd in QEventLoop::processEvents (this=0xbf88d344, flags=...) at kernel/qeventloop.cpp:149
#44 0xb7275421 in QEventLoop::exec (this=0xbf88d344, flags=...) at kernel/qeventloop.cpp:201
#45 0xb727a19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0xb605b8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291783, bug 291782, bug 291778, bug 291776, bug 291767.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-17 17:01:34 UTC

*** This bug has been marked as a duplicate of bug 261292 ***
Comment 2 Jekyll Wu 2012-01-17 17:02:51 UTC

*** This bug has been marked as a duplicate of bug 291262 ***