Bug 285580 - Muo Software Center crashes
Summary: Muo Software Center crashes
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-02 17:55 UTC by georg.pap
Modified: 2011-11-02 22:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description georg.pap 2011-11-02 17:55:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Only install programms from the Muon Software Center. After crashing i restart the application.

-- Backtrace:
Application: Κέντρο λογισμικού Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb776e930 (LWP 1809))]

Thread 3 (Thread 0xb5465b70 (LWP 1813)):
#0  0x01353a17 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x00000001 in ?? ()
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xb2b97b70 (LWP 5478)):
#0  0x0080cd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x008f07d5 in do_gettime (frac=0xb2b97020, sec=0xb2b97018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x009c34b6 in QTimerInfoList::updateCurrentTime (this=0xa86ca34) at kernel/qeventdispatcher_unix.cpp:339
#4  0x009c380a in QTimerInfoList::timerWait (this=0xa86ca34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x009c2053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb2b9712c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x009c20ed in timerSourcePrepare (source=0xa86ca00, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0138288c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01383637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01383c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x009c2b37 in QEventDispatcherGlib::processEvents (this=0x8c5dd50, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x009931dd in QEventLoop::processEvents (this=0xb2b972b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00993421 in QEventLoop::exec (this=0xb2b972b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0089690b in QThread::exec (this=0x8e86868) at thread/qthread.cpp:498
#14 0x00973e2d in QInotifyFileSystemWatcherEngine::run (this=0x8e86868) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x008997b3 in QThreadPrivate::start (arg=0x8e86868) at thread/qthread_unix.cpp:331
#16 0x007b2d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x05b6e0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb776e930 (LWP 1809)):
[KCrash Handler]
#7  0x0805e766 in value (akey=..., this=0xb4d275c) at /usr/include/qt4/QtCore/qhash.h:607
#8  Application::getField (this=0xb4d2758, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#9  0x0805f0d7 in Application::untranslatedName (this=0xb4d2758) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#10 0x0805f29d in Application::name (this=0xb4d2758) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#11 0x08083b74 in ReviewsBackend::reviewsFetched (this=0x89a67c8, job=0xaa2a870) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#12 0x0805e465 in ReviewsBackend::qt_metacall (this=0x89a67c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc77928) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#13 0x0099ab7d in metacall (argv=0xbfc77928, idx=6, cl=QMetaObject::InvokeMetaMethod, object=0x89a67c8) at kernel/qmetaobject.cpp:237
#14 QMetaObject::metacall (object=0x89a67c8, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfc77928) at kernel/qmetaobject.cpp:232
#15 0x009a9a6a in QMetaObject::activate (sender=0xaa2a870, m=0xe0d58c, local_signal_index=3, argv=0xbfc77928) at kernel/qobject.cpp:3278
#16 0x00c5feb5 in KJob::result (this=0xaa2a870, _t1=0xaa2a870) at ./kjob.moc:194
#17 0x00c5ff08 in KJob::emitResult (this=0xaa2a870) at ../../kdecore/jobs/kjob.cpp:312
#18 0x00417ffc in KIO::FileCopyJob::slotResult (this=0xaa2a870, job=0x921bcb8) at ../../kio/kio/job.cpp:2440
#19 0x00417d8d in KIO::FileCopyJob::qt_metacall (this=0xaa2a870, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc77aa8) at ./jobclasses.moc:724
#20 0x0099ab7d in metacall (argv=0xbfc77aa8, idx=32, cl=QMetaObject::InvokeMetaMethod, object=0xaa2a870) at kernel/qmetaobject.cpp:237
#21 QMetaObject::metacall (object=0xaa2a870, cl=QMetaObject::InvokeMetaMethod, idx=32, argv=0xbfc77aa8) at kernel/qmetaobject.cpp:232
#22 0x009a9a6a in QMetaObject::activate (sender=0x921bcb8, m=0xe0d58c, local_signal_index=3, argv=0xbfc77aa8) at kernel/qobject.cpp:3278
#23 0x00c5feb5 in KJob::result (this=0x921bcb8, _t1=0x921bcb8) at ./kjob.moc:194
#24 0x00c5ff08 in KJob::emitResult (this=0x921bcb8) at ../../kdecore/jobs/kjob.cpp:312
#25 0x0040f6d8 in KIO::SimpleJob::slotFinished (this=0x921bcb8) at ../../kio/kio/job.cpp:494
#26 0x0041825d in KIO::TransferJob::slotFinished (this=0x921bcb8) at ../../kio/kio/job.cpp:1081
#27 0x00416894 in KIO::TransferJob::qt_metacall (this=0x921bcb8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc77d44) at ./jobclasses.moc:369
#28 0x0099ab7d in metacall (argv=0xbfc77d44, idx=47, cl=QMetaObject::InvokeMetaMethod, object=0x921bcb8) at kernel/qmetaobject.cpp:237
#29 QMetaObject::metacall (object=0x921bcb8, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbfc77d44) at kernel/qmetaobject.cpp:232
#30 0x009a9a6a in QMetaObject::activate (sender=0x8ccfe00, m=0x5eb6a0, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3278
#31 0x004cb675 in KIO::SlaveInterface::finished (this=0x8ccfe00) at ./slaveinterface.moc:171
#32 0x004ce4f9 in KIO::SlaveInterface::dispatch (this=0x8ccfe00, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#33 0x004cac5a in KIO::SlaveInterface::dispatch (this=0x8ccfe00) at ../../kio/kio/slaveinterface.cpp:88
#34 0x004bc348 in KIO::Slave::gotInput (this=0x8ccfe00) at ../../kio/kio/slave.cpp:344
#35 0x004bcbbc in KIO::Slave::qt_metacall (this=0x8ccfe00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc78024) at ./slave.moc:82
#36 0x0099ab7d in metacall (argv=0xbfc78024, idx=30, cl=QMetaObject::InvokeMetaMethod, object=0x8ccfe00) at kernel/qmetaobject.cpp:237
#37 QMetaObject::metacall (object=0x8ccfe00, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbfc78024) at kernel/qmetaobject.cpp:232
#38 0x009a9a6a in QMetaObject::activate (sender=0x8d29a00, m=0x5e8508, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#39 0x003daf65 in KIO::Connection::readyRead (this=0x8d29a00) at ./connection.moc:92
#40 0x003db79a in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#41 KIO::ConnectionPrivate::dequeue (this=0x9255448) at ../../kio/kio/connection.cpp:71
#42 0x003db86f in KIO::Connection::qt_metacall (this=0x8d29a00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xb5512c8) at ./connection.moc:79
#43 0x0099ab7d in metacall (argv=0xb5512c8, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x8d29a00) at kernel/qmetaobject.cpp:237
#44 QMetaObject::metacall (object=0x8d29a00, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0xb5512c8) at kernel/qmetaobject.cpp:232
#45 0x009a5685 in QMetaCallEvent::placeMetaCall (this=0xb14e510, object=0x8d29a00) at kernel/qobject.cpp:535
#46 0x009acb52 in QObject::event (this=0x8d29a00, e=0xb14e510) at kernel/qobject.cpp:1217
#47 0x0351bd54 in notify_helper (e=0xb14e510, receiver=0x8d29a00, this=0x89a5468) at kernel/qapplication.cpp:4486
#48 QApplicationPrivate::notify_helper (this=0x89a5468, receiver=0x8d29a00, e=0xb14e510) at kernel/qapplication.cpp:4458
#49 0x03521103 in QApplication::notify (this=0xb14e510, receiver=0x8d29a00, e=0xb14e510) at kernel/qapplication.cpp:3886
#50 0x010ee681 in KApplication::notify (this=0xbfc787f0, receiver=0x8d29a00, event=0xb14e510) at ../../kdeui/kernel/kapplication.cpp:311
#51 0x0099419e in QCoreApplication::notifyInternal (this=0xbfc787f0, receiver=0x8d29a00, event=0xb14e510) at kernel/qcoreapplication.cpp:787
#52 0x00997f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#53 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8982300) at kernel/qcoreapplication.cpp:1428
#54 0x009980ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#55 0x009c26a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#56 postEventSourceDispatch (s=0x89a7900) at kernel/qeventdispatcher_glib.cpp:277
#57 0x0138325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#58 0x01383990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#59 0x01383c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#60 0x009c2ada in QEventDispatcherGlib::processEvents (this=0x8983238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#61 0x035d3e3a in QGuiEventDispatcherGlib::processEvents (this=0x8983238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#62 0x009931dd in QEventLoop::processEvents (this=0xbfc78754, flags=...) at kernel/qeventloop.cpp:149
#63 0x00993421 in QEventLoop::exec (this=0xbfc78754, flags=...) at kernel/qeventloop.cpp:201
#64 0x0099819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#65 0x035198f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#66 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 283728.

Possible duplicates by query: bug 285299.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-02 22:12:26 UTC

*** This bug has been marked as a duplicate of bug 283728 ***