Bug 290145 - Muon crashed
Summary: Muon crashed
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-30 02:08 UTC by Scott
Modified: 2011-12-30 12:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott 2011-12-30 02:08:52 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I had just installed Eclipse using Muon when this occurred. I wasn't really doing much, I was doing something in Firefox while it was installing and it just crashed. It appears that everything installed OK so I don't know what happened...

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78aa930 (LWP 2829))]

Thread 2 (Thread 0xb5a50b70 (LWP 2833)):
#0  0x008e8d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x001ed7d5 in do_gettime (frac=0xb5a50020, sec=0xb5a50018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x002c04b6 in QTimerInfoList::updateCurrentTime (this=0x8631094) at kernel/qeventdispatcher_unix.cpp:339
#4  0x002c080a in QTimerInfoList::timerWait (this=0x8631094, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x002bf053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5a5012c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x002bf0ed in timerSourcePrepare (source=0x8631060, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0588c88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x0588d637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0588dc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x002bfb37 in QEventDispatcherGlib::processEvents (this=0x853b480, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x002901dd in QEventLoop::processEvents (this=0xb5a502b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00290421 in QEventLoop::exec (this=0xb5a502b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0019390b in QThread::exec (this=0x862cfb8) at thread/qthread.cpp:498
#14 0x00270e2d in QInotifyFileSystemWatcherEngine::run (this=0x862cfb8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x001967b3 in QThreadPrivate::start (arg=0x862cfb8) at thread/qthread_unix.cpp:331
#16 0x008d0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x005ca0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78aa930 (LWP 2829)):
[KCrash Handler]
#7  same_key (key0=..., h0=346165, this=0x891cec83) at /usr/include/qt4/QtCore/qhash.h:225
#8  QHash<QByteArray, QByteArray>::findNode (this=0x8cc7e84, akey=..., ahp=0x0) at /usr/include/qt4/QtCore/qhash.h:885
#9  0x0805e7ab in value (akey=..., this=0x8cc7e84) at /usr/include/qt4/QtCore/qhash.h:607
#10 Application::getField (this=0x8cc7e80, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#11 0x0805f0d7 in Application::untranslatedName (this=0x8cc7e80) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#12 0x0805f29d in Application::name (this=0x8cc7e80) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#13 0x08083b74 in ReviewsBackend::reviewsFetched (this=0x84d9270, job=0x9578db0) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#14 0x0805e465 in ReviewsBackend::qt_metacall (this=0x84d9270, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa4ede8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#15 0x00297b7d in metacall (argv=0xbfa4ede8, idx=6, cl=QMetaObject::InvokeMetaMethod, object=0x84d9270) at kernel/qmetaobject.cpp:237
#16 QMetaObject::metacall (object=0x84d9270, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfa4ede8) at kernel/qmetaobject.cpp:232
#17 0x002a6a6a in QMetaObject::activate (sender=0x9578db0, m=0x7b2e58c, local_signal_index=3, argv=0xbfa4ede8) at kernel/qobject.cpp:3278
#18 0x07980ea5 in KJob::result (this=0x9578db0, _t1=0x9578db0) at ./kjob.moc:194
#19 0x07980ef8 in KJob::emitResult (this=0x9578db0) at ../../kdecore/jobs/kjob.cpp:312
#20 0x00dfd8ec in KIO::FileCopyJob::slotResult (this=0x9578db0, job=0x9562cd0) at ../../kio/kio/job.cpp:2449
#21 0x00dfd67d in KIO::FileCopyJob::qt_metacall (this=0x9578db0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa4ef68) at ./jobclasses.moc:724
#22 0x00297b7d in metacall (argv=0xbfa4ef68, idx=32, cl=QMetaObject::InvokeMetaMethod, object=0x9578db0) at kernel/qmetaobject.cpp:237
#23 QMetaObject::metacall (object=0x9578db0, cl=QMetaObject::InvokeMetaMethod, idx=32, argv=0xbfa4ef68) at kernel/qmetaobject.cpp:232
#24 0x002a6a6a in QMetaObject::activate (sender=0x9562cd0, m=0x7b2e58c, local_signal_index=3, argv=0xbfa4ef68) at kernel/qobject.cpp:3278
#25 0x07980ea5 in KJob::result (this=0x9562cd0, _t1=0x9562cd0) at ./kjob.moc:194
#26 0x07980ef8 in KJob::emitResult (this=0x9562cd0) at ../../kdecore/jobs/kjob.cpp:312
#27 0x00df4e18 in KIO::SimpleJob::slotFinished (this=0x9562cd0) at ../../kio/kio/job.cpp:494
#28 0x00dfdb4d in KIO::TransferJob::slotFinished (this=0x9562cd0) at ../../kio/kio/job.cpp:1081
#29 0x00dfc184 in KIO::TransferJob::qt_metacall (this=0x9562cd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa4f204) at ./jobclasses.moc:369
#30 0x00297b7d in metacall (argv=0xbfa4f204, idx=47, cl=QMetaObject::InvokeMetaMethod, object=0x9562cd0) at kernel/qmetaobject.cpp:237
#31 QMetaObject::metacall (object=0x9562cd0, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbfa4f204) at kernel/qmetaobject.cpp:232
#32 0x002a6a6a in QMetaObject::activate (sender=0x84db9f8, m=0xfd26a0, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3278
#33 0x00eb1e35 in KIO::SlaveInterface::finished (this=0x84db9f8) at ./slaveinterface.moc:171
#34 0x00eb4cb9 in KIO::SlaveInterface::dispatch (this=0x84db9f8, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#35 0x00eb141a in KIO::SlaveInterface::dispatch (this=0x84db9f8) at ../../kio/kio/slaveinterface.cpp:88
#36 0x00ea2a48 in KIO::Slave::gotInput (this=0x84db9f8) at ../../kio/kio/slave.cpp:344
#37 0x00ea32bc in KIO::Slave::qt_metacall (this=0x84db9f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa4f4e4) at ./slave.moc:82
#38 0x00297b7d in metacall (argv=0xbfa4f4e4, idx=30, cl=QMetaObject::InvokeMetaMethod, object=0x84db9f8) at kernel/qmetaobject.cpp:237
#39 QMetaObject::metacall (object=0x84db9f8, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbfa4f4e4) at kernel/qmetaobject.cpp:232
#40 0x002a6a6a in QMetaObject::activate (sender=0x84d9c08, m=0xfcf4a8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#41 0x00dc0025 in KIO::Connection::readyRead (this=0x84d9c08) at ./connection.moc:92
#42 0x00dc085a in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#43 KIO::ConnectionPrivate::dequeue (this=0x856cd68) at ../../kio/kio/connection.cpp:71
#44 0x00dc092f in KIO::Connection::qt_metacall (this=0x84d9c08, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x92c5828) at ./connection.moc:79
#45 0x00297b7d in metacall (argv=0x92c5828, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x84d9c08) at kernel/qmetaobject.cpp:237
#46 QMetaObject::metacall (object=0x84d9c08, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0x92c5828) at kernel/qmetaobject.cpp:232
#47 0x002a2685 in QMetaCallEvent::placeMetaCall (this=0x9550598, object=0x84d9c08) at kernel/qobject.cpp:535
#48 0x002a9b52 in QObject::event (this=0x84d9c08, e=0x9550598) at kernel/qobject.cpp:1217
#49 0x06dbed54 in notify_helper (e=0x9550598, receiver=0x84d9c08, this=0x83e9f80) at kernel/qapplication.cpp:4486
#50 QApplicationPrivate::notify_helper (this=0x83e9f80, receiver=0x84d9c08, e=0x9550598) at kernel/qapplication.cpp:4458
#51 0x06dc4103 in QApplication::notify (this=0x9550598, receiver=0x84d9c08, e=0x9550598) at kernel/qapplication.cpp:3886
#52 0x011c1681 in KApplication::notify (this=0xbfa4fcb0, receiver=0x84d9c08, event=0x9550598) at ../../kdeui/kernel/kapplication.cpp:311
#53 0x0029119e in QCoreApplication::notifyInternal (this=0xbfa4fcb0, receiver=0x84d9c08, event=0x9550598) at kernel/qcoreapplication.cpp:787
#54 0x00294f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x83cb300) at kernel/qcoreapplication.cpp:1428
#56 0x002950ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#57 0x002bf6a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#58 postEventSourceDispatch (s=0x83ecea8) at kernel/qeventdispatcher_glib.cpp:277
#59 0x0588d25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#60 0x0588d990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#61 0x0588dc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#62 0x002bfada in QEventDispatcherGlib::processEvents (this=0x83cc238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#63 0x06e76e3a in QGuiEventDispatcherGlib::processEvents (this=0x83cc238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#64 0x002901dd in QEventLoop::processEvents (this=0xbfa4fc14, flags=...) at kernel/qeventloop.cpp:149
#65 0x00290421 in QEventLoop::exec (this=0xbfa4fc14, flags=...) at kernel/qeventloop.cpp:201
#66 0x0029519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#67 0x06dbc8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#68 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Christoph Feck 2011-12-30 12:54:51 UTC

*** This bug has been marked as a duplicate of bug 283728 ***