Bug 286903 - Muon Software Center crashed when navigating through installed softwares
Summary: Muon Software Center crashed when navigating through installed softwares
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-18 04:36 UTC by Michael Leocádio
Modified: 2011-11-18 11:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Leocádio 2011-11-18 04:36:00 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Removing applications, then while I was just navigating through the installed softwares it used to bring me back to the main page several times. After insisting on that, it crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f51923d9780 (LWP 2210))]

Thread 2 (Thread 0x7f517d42a700 (LWP 2213)):
#0  0x00007f518efb8773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f518b82df68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f518b82e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5191175f3e in QEventDispatcherGlib::processEvents (this=0xf0b1f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f5191149cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5191149ef7 in QEventLoop::exec (this=0x7f517d429dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f519106127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f519112ccbf in QInotifyFileSystemWatcherEngine::run (this=0xefc210) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f5191063d05 in QThreadPrivate::start (arg=0xefc210) at thread/qthread_unix.cpp:331
#9  0x00007f518c30fefc in start_thread (arg=0x7f517d42a700) at pthread_create.c:304
#10 0x00007f518efc489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f51923d9780 (LWP 2210)):
[KCrash Handler]
#6  value (akey=..., this=0x1a34478) at /usr/include/qt4/QtCore/qhash.h:607
#7  Application::getField (this=0x1a34470, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#8  0x000000000041d0dd in Application::untranslatedName (this=0x1a34470) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#9  0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#10 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0xee0a60, job=0x2e6da80) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#11 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0xee0a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff38545d60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#12 0x00007f519115deba in QMetaObject::activate (sender=0x2e6da80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff38545d60) at kernel/qobject.cpp:3278
#13 0x00007f51903995b2 in KJob::result (this=<optimized out>, _t1=0x2e6da80) at ./kjob.moc:194
#14 0x00007f51903995f0 in KJob::emitResult (this=0x2e6da80) at ../../kdecore/jobs/kjob.cpp:312
#15 0x00007f5191befa4a in KIO::FileCopyJob::slotResult (this=0x2e6da80, job=0x1917600) at ../../kio/kio/job.cpp:2440
#16 0x00007f5191bef7f0 in KIO::FileCopyJob::qt_metacall (this=0x2e6da80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff38545ed0) at ./jobclasses.moc:724
#17 0x00007f519115deba in QMetaObject::activate (sender=0x1917600, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff38545ed0) at kernel/qobject.cpp:3278
#18 0x00007f51903995b2 in KJob::result (this=<optimized out>, _t1=0x1917600) at ./kjob.moc:194
#19 0x00007f51903995f0 in KJob::emitResult (this=0x1917600) at ../../kdecore/jobs/kjob.cpp:312
#20 0x00007f5191be82c4 in KIO::SimpleJob::slotFinished (this=0x1917600) at ../../kio/kio/job.cpp:494
#21 0x00007f5191befc9d in KIO::TransferJob::slotFinished (this=0x1917600) at ../../kio/kio/job.cpp:1081
#22 0x00007f5191bee601 in KIO::TransferJob::qt_metacall (this=0x1917600, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff38546280) at ./jobclasses.moc:369
#23 0x00007f519115deba in QMetaObject::activate (sender=0xf78c40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#24 0x00007f5191c949c1 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#25 0x00007f5191c91875 in KIO::SlaveInterface::dispatch (this=0xf78c40) at ../../kio/kio/slaveinterface.cpp:88
#26 0x00007f5191c84ace in KIO::Slave::gotInput (this=0xf78c40) at ../../kio/kio/slave.cpp:344
#27 0x00007f5191c8522c in KIO::Slave::qt_metacall (this=0xf78c40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff385466b0) at ./slave.moc:82
#28 0x00007f519115deba in QMetaObject::activate (sender=0xfa3880, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#29 0x00007f5191bb93a7 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#30 KIO::ConnectionPrivate::dequeue (this=0xf6b700) at ../../kio/kio/connection.cpp:71
#31 0x00007f5191bb944d in KIO::Connection::qt_metacall (this=0xfa3880, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x1b8f650) at ./connection.moc:79
#32 0x00007f5191161a5e in QObject::event (this=0xfa3880, e=<optimized out>) at kernel/qobject.cpp:1217
#33 0x00007f518f785424 in notify_helper (e=0x1e1e360, receiver=0xfa3880, this=0xd0a530) at kernel/qapplication.cpp:4486
#34 QApplicationPrivate::notify_helper (this=0xd0a530, receiver=0xfa3880, e=0x1e1e360) at kernel/qapplication.cpp:4458
#35 0x00007f518f78a291 in QApplication::notify (this=0x7fff38546f60, receiver=0xfa3880, e=0x1e1e360) at kernel/qapplication.cpp:4365
#36 0x00007f5190969126 in KApplication::notify (this=0x7fff38546f60, receiver=0xfa3880, event=0x1e1e360) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007f519114aafc in QCoreApplication::notifyInternal (this=0x7fff38546f60, receiver=0xfa3880, event=0x1e1e360) at kernel/qcoreapplication.cpp:787
#38 0x00007f519114e51f in sendEvent (event=0x1e1e360, receiver=0xfa3880) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xce0be0) at kernel/qcoreapplication.cpp:1428
#40 0x00007f5191175a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#42 0x00007f518b82da5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f518b82e258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007f518b82e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f5191175ed6 in QEventDispatcherGlib::processEvents (this=0xce26f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#46 0x00007f518f82d07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007f5191149cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007f5191149ef7 in QEventLoop::exec (this=0x7fff38546ef0, flags=...) at kernel/qeventloop.cpp:201
#49 0x00007f519114e789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#50 0x000000000041bd67 in main (argc=5, argv=0x7fff385471d8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 285580, bug 285299.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-11-18 11:37:52 UTC

*** This bug has been marked as a duplicate of bug 283728 ***