Bug 288692 - more crashes
Summary: more crashes
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-11 01:55 UTC by silentanonimus
Modified: 2011-12-11 02:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description silentanonimus 2011-12-11 01:55:32 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
uninstall software
after check for update 
install software

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7713930 (LWP 2471))]

Thread 2 (Thread 0xb5985b70 (LWP 2472)):
#0  0x005f9d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00c107d5 in do_gettime (frac=0xb5985020, sec=0xb5985018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00ce34b6 in QTimerInfoList::updateCurrentTime (this=0x87ec9b4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00ce380a in QTimerInfoList::timerWait (this=0x87ec9b4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00ce2053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb598512c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00ce20ed in timerSourcePrepare (source=0x87ec980, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0239988c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x0239a637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0239ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00ce2b37 in QEventDispatcherGlib::processEvents (this=0x8781ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00cb31dd in QEventLoop::processEvents (this=0xb59852b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00cb3421 in QEventLoop::exec (this=0xb59852b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00bb690b in QThread::exec (this=0x87d8700) at thread/qthread.cpp:498
#14 0x00c93e2d in QInotifyFileSystemWatcherEngine::run (this=0x87d8700) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00bb97b3 in QThreadPrivate::start (arg=0x87d8700) at thread/qthread_unix.cpp:331
#16 0x080b6d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x005460ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7713930 (LWP 2471)):
[KCrash Handler]
#7  0x0805e766 in value (akey=..., this=0x8e90874) at /usr/include/qt4/QtCore/qhash.h:607
#8  Application::getField (this=0x8e90870, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#9  0x0805f0d7 in Application::untranslatedName (this=0x8e90870) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#10 0x0805f29d in Application::name (this=0x8e90870) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#11 0x08083b74 in ReviewsBackend::reviewsFetched (this=0x87ce060, job=0x9952198) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#12 0x0805e465 in ReviewsBackend::qt_metacall (this=0x87ce060, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb43e08) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#13 0x00cbab7d in metacall (argv=0xbfb43e08, idx=6, cl=QMetaObject::InvokeMetaMethod, object=0x87ce060) at kernel/qmetaobject.cpp:237
#14 QMetaObject::metacall (object=0x87ce060, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfb43e08) at kernel/qmetaobject.cpp:232
#15 0x00cc9a6a in QMetaObject::activate (sender=0x9952198, m=0x49eb58c, local_signal_index=3, argv=0xbfb43e08) at kernel/qobject.cpp:3278
#16 0x0483dea5 in KJob::result (this=0x9952198, _t1=0x9952198) at ./kjob.moc:194
#17 0x0483def8 in KJob::emitResult (this=0x9952198) at ../../kdecore/jobs/kjob.cpp:312
#18 0x001d78ec in KIO::FileCopyJob::slotResult (this=0x9952198, job=0x9a44748) at ../../kio/kio/job.cpp:2449
#19 0x001d767d in KIO::FileCopyJob::qt_metacall (this=0x9952198, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb43f88) at ./jobclasses.moc:724
#20 0x00cbab7d in metacall (argv=0xbfb43f88, idx=32, cl=QMetaObject::InvokeMetaMethod, object=0x9952198) at kernel/qmetaobject.cpp:237
#21 QMetaObject::metacall (object=0x9952198, cl=QMetaObject::InvokeMetaMethod, idx=32, argv=0xbfb43f88) at kernel/qmetaobject.cpp:232
#22 0x00cc9a6a in QMetaObject::activate (sender=0x9a44748, m=0x49eb58c, local_signal_index=3, argv=0xbfb43f88) at kernel/qobject.cpp:3278
#23 0x0483dea5 in KJob::result (this=0x9a44748, _t1=0x9a44748) at ./kjob.moc:194
#24 0x0483def8 in KJob::emitResult (this=0x9a44748) at ../../kdecore/jobs/kjob.cpp:312
#25 0x001cee18 in KIO::SimpleJob::slotFinished (this=0x9a44748) at ../../kio/kio/job.cpp:494
#26 0x001d7b4d in KIO::TransferJob::slotFinished (this=0x9a44748) at ../../kio/kio/job.cpp:1081
#27 0x001d6184 in KIO::TransferJob::qt_metacall (this=0x9a44748, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb44224) at ./jobclasses.moc:369
#28 0x00cbab7d in metacall (argv=0xbfb44224, idx=47, cl=QMetaObject::InvokeMetaMethod, object=0x9a44748) at kernel/qmetaobject.cpp:237
#29 QMetaObject::metacall (object=0x9a44748, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbfb44224) at kernel/qmetaobject.cpp:232
#30 0x00cc9a6a in QMetaObject::activate (sender=0x87f6ea8, m=0x3ac6a0, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3278
#31 0x0028be35 in KIO::SlaveInterface::finished (this=0x87f6ea8) at ./slaveinterface.moc:171
#32 0x0028ecb9 in KIO::SlaveInterface::dispatch (this=0x87f6ea8, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#33 0x0028b41a in KIO::SlaveInterface::dispatch (this=0x87f6ea8) at ../../kio/kio/slaveinterface.cpp:88
#34 0x0027ca48 in KIO::Slave::gotInput (this=0x87f6ea8) at ../../kio/kio/slave.cpp:344
#35 0x0027d2bc in KIO::Slave::qt_metacall (this=0x87f6ea8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb44504) at ./slave.moc:82
#36 0x00cbab7d in metacall (argv=0xbfb44504, idx=30, cl=QMetaObject::InvokeMetaMethod, object=0x87f6ea8) at kernel/qmetaobject.cpp:237
#37 QMetaObject::metacall (object=0x87f6ea8, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbfb44504) at kernel/qmetaobject.cpp:232
#38 0x00cc9a6a in QMetaObject::activate (sender=0x8730360, m=0x3a94a8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#39 0x0019a025 in KIO::Connection::readyRead (this=0x8730360) at ./connection.moc:92
#40 0x0019a85a in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#41 KIO::ConnectionPrivate::dequeue (this=0x87c50e8) at ../../kio/kio/connection.cpp:71
#42 0x0019a92f in KIO::Connection::qt_metacall (this=0x8730360, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x8a32650) at ./connection.moc:79
#43 0x00cbab7d in metacall (argv=0x8a32650, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x8730360) at kernel/qmetaobject.cpp:237
#44 QMetaObject::metacall (object=0x8730360, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0x8a32650) at kernel/qmetaobject.cpp:232
#45 0x00cc5685 in QMetaCallEvent::placeMetaCall (this=0x936fea8, object=0x8730360) at kernel/qobject.cpp:535
#46 0x00cccb52 in QObject::event (this=0x8730360, e=0x936fea8) at kernel/qobject.cpp:1217
#47 0x0137fd54 in notify_helper (e=0x936fea8, receiver=0x8730360, this=0x86849b8) at kernel/qapplication.cpp:4486
#48 QApplicationPrivate::notify_helper (this=0x86849b8, receiver=0x8730360, e=0x936fea8) at kernel/qapplication.cpp:4458
#49 0x01385103 in QApplication::notify (this=0x936fea8, receiver=0x8730360, e=0x936fea8) at kernel/qapplication.cpp:3886
#50 0x00fd6681 in KApplication::notify (this=0xbfb44cd0, receiver=0x8730360, event=0x936fea8) at ../../kdeui/kernel/kapplication.cpp:311
#51 0x00cb419e in QCoreApplication::notifyInternal (this=0xbfb44cd0, receiver=0x8730360, event=0x936fea8) at kernel/qcoreapplication.cpp:787
#52 0x00cb7f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#53 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8666300) at kernel/qcoreapplication.cpp:1428
#54 0x00cb80ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#55 0x00ce26a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#56 postEventSourceDispatch (s=0x868c0d0) at kernel/qeventdispatcher_glib.cpp:277
#57 0x0239a25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#58 0x0239a990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#59 0x0239ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#60 0x00ce2ada in QEventDispatcherGlib::processEvents (this=0x8667238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#61 0x01437e3a in QGuiEventDispatcherGlib::processEvents (this=0x8667238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#62 0x00cb31dd in QEventLoop::processEvents (this=0xbfb44c34, flags=...) at kernel/qeventloop.cpp:149
#63 0x00cb3421 in QEventLoop::exec (this=0xbfb44c34, flags=...) at kernel/qeventloop.cpp:201
#64 0x00cb819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#65 0x0137d8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#66 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 286903, bug 285580, bug 285299.

Reported using DrKonqi
Comment 1 Jekyll Wu 2011-12-11 02:03:11 UTC

*** This bug has been marked as a duplicate of bug 283728 ***