Bug 291522 - muon software center crushed in start
Summary: muon software center crushed in start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 15:37 UTC by sanikitin
Modified: 2012-01-14 16:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sanikitin 2012-01-14 15:37:45 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
muon software center crushed in start always

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6b6a26b780 (LWP 5137))]

Thread 2 (Thread 0x7f6b5555a700 (LWP 5140)):
#0  0x00007f6b641a0028 in __pthread_mutex_lock (mutex=0xfb4348) at pthread_mutex_lock.c:61
#1  0x00007f6b636bae5d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6b636bbdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6b636bc429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6b69003f3e in QEventDispatcherGlib::processEvents (this=0xfe2e90, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f6b68fd7cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f6b68fd7ef7 in QEventLoop::exec (this=0x7f6b55559dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f6b68eef27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f6b68fbacbf in QInotifyFileSystemWatcherEngine::run (this=0xfe4620) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f6b68ef1d05 in QThreadPrivate::start (arg=0xfe4620) at thread/qthread_unix.cpp:331
#10 0x00007f6b6419defc in start_thread (arg=0x7f6b5555a700) at pthread_create.c:304
#11 0x00007f6b66e5289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6b6a26b780 (LWP 5137)):
[KCrash Handler]
#6  0x00007f6b68f3fa5e in QtPrivate::QStringList_contains (that=0x7fffdbf286c0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffdbf286c0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xf2ce20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xf2ce20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdbf28c90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f6b68febeba in QMetaObject::activate (sender=0xf73540, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xf73540, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdbf28df0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f6b68febeba in QMetaObject::activate (sender=0xf2ce20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffdbf28df0) at kernel/qobject.cpp:3278
#13 0x00007f6b69e5ee7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xf9eaf0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f6b69e5ef8e in MuonMainWindow::initObject (this=0xf2ce20) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xf2ce20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xf2ce20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdbf28ec0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f6b68febeba in QMetaObject::activate (sender=0xfb1b10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f6b68ff3f7f in QSingleShotTimer::timerEvent (this=0xfb1b10) at kernel/qtimer.cpp:308
#19 0x00007f6b68fef789 in QObject::event (this=0xfb1b10, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f6b67613424 in notify_helper (e=0x7fffdbf29430, receiver=0xfb1b10, this=0xdbc500) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xdbc500, receiver=0xfb1b10, e=0x7fffdbf29430) at kernel/qapplication.cpp:4458
#22 0x00007f6b67618291 in QApplication::notify (this=0x7fffdbf29730, receiver=0xfb1b10, e=0x7fffdbf29430) at kernel/qapplication.cpp:4365
#23 0x00007f6b687f7126 in KApplication::notify (this=0x7fffdbf29730, receiver=0xfb1b10, event=0x7fffdbf29430) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f6b68fd8afc in QCoreApplication::notifyInternal (this=0x7fffdbf29730, receiver=0xfb1b10, event=0x7fffdbf29430) at kernel/qcoreapplication.cpp:787
#25 0x00007f6b69005d62 in sendEvent (event=0x7fffdbf29430, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xdb8050) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f6b69003514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f6b636bba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f6b636bc258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f6b636bc429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f6b69003ed6 in QEventDispatcherGlib::processEvents (this=0xd946f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f6b676bb07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f6b68fd7cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f6b68fd7ef7 in QEventLoop::exec (this=0x7fffdbf296c0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f6b68fdc789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffdbf299a8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291520.

Possible duplicates by query: bug 291520, bug 291513, bug 291509, bug 291492, bug 291490.

Reported using DrKonqi
Comment 1 Thijs 2012-01-14 16:12:11 UTC

*** This bug has been marked as a duplicate of bug 291262 ***