Bug 291513 - Muon software center crash on launch
Summary: Muon software center crash on launch
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 13:38 UTC by mpmc
Modified: 2012-01-14 16:12 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.03 KB, text/plain)
2012-01-14 14:20 UTC, Sah4ez
Details
New crash information added by DrKonqi (7.24 KB, text/plain)
2012-01-14 14:41 UTC, Giotis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mpmc 2012-01-14 13:38:31 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Rebooted after updating a fresh install, attempted to run the software center and it just exited.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9bcd0e5780 (LWP 2822))]

Thread 2 (Thread 0x7f9bb8835700 (LWP 2823)):
#0  0x00007f9bc9cb3773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9bc6528f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9bc6529429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9bcbe70f3e in QEventDispatcherGlib::processEvents (this=0x1c0be10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9bcbe44cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9bcbe44ef7 in QEventLoop::exec (this=0x7f9bb8834dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9bcbd5c27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f9bcbe27cbf in QInotifyFileSystemWatcherEngine::run (this=0x1bbc110) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9bcbd5ed05 in QThreadPrivate::start (arg=0x1bbc110) at thread/qthread_unix.cpp:331
#9  0x00007f9bc700aefc in start_thread (arg=0x7f9bb8835700) at pthread_create.c:304
#10 0x00007f9bc9cbf89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9bcd0e5780 (LWP 2822)):
[KCrash Handler]
#6  0x00007f9bcbdaca5e in QtPrivate::QStringList_contains (that=0x7fff3bff1ba0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff3bff1ba0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1ba6f00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1ba6f00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3bff2170) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f9bcbe58eba in QMetaObject::activate (sender=0x1d69980, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1d69980, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3bff22d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f9bcbe58eba in QMetaObject::activate (sender=0x1ba6f00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff3bff22d0) at kernel/qobject.cpp:3278
#13 0x00007f9bccccbe7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1c2b7d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f9bccccbf8e in MuonMainWindow::initObject (this=0x1ba6f00) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1ba6f00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1ba6f00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3bff23a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f9bcbe58eba in QMetaObject::activate (sender=0x1c349e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f9bcbe60f7f in QSingleShotTimer::timerEvent (this=0x1c349e0) at kernel/qtimer.cpp:308
#19 0x00007f9bcbe5c789 in QObject::event (this=0x1c349e0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f9bca480424 in notify_helper (e=0x7fff3bff2910, receiver=0x1c349e0, this=0x1a52570) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1a52570, receiver=0x1c349e0, e=0x7fff3bff2910) at kernel/qapplication.cpp:4458
#22 0x00007f9bca485291 in QApplication::notify (this=0x7fff3bff2c10, receiver=0x1c349e0, e=0x7fff3bff2910) at kernel/qapplication.cpp:4365
#23 0x00007f9bcb664126 in KApplication::notify (this=0x7fff3bff2c10, receiver=0x1c349e0, event=0x7fff3bff2910) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f9bcbe45afc in QCoreApplication::notifyInternal (this=0x7fff3bff2c10, receiver=0x1c349e0, event=0x7fff3bff2910) at kernel/qcoreapplication.cpp:787
#25 0x00007f9bcbe72d62 in sendEvent (event=0x7fff3bff2910, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1a4dcd0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f9bcbe70514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f9bc6528a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f9bc6529258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f9bc6529429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f9bcbe70ed6 in QEventDispatcherGlib::processEvents (this=0x1a296f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f9bca52807e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f9bcbe44cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f9bcbe44ef7 in QEventLoop::exec (this=0x7fff3bff2ba0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f9bcbe49789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff3bff2e88) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291509.

Possible duplicates by query: bug 291509, bug 291492, bug 291490, bug 291489, bug 291486.

Reported using DrKonqi
Comment 1 Sah4ez 2012-01-14 14:20:11 UTC
Created attachment 67820 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

I ran the Muon to install the application, then Muon has given me an error and it just exited.

-- Backtrace (Reduced):
#6  0x00007fb703348a5e in QtPrivate::QStringList_contains (that=0x7fffc321b460, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffc321b460) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xcaf570) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xcaf570, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc321ba30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xd4e8b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc321bb90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 2 Giotis 2012-01-14 14:41:35 UTC
Created attachment 67824 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:Idle system, just finished compilingNmap

-- Backtrace (Reduced):
#7  0x00d5ee11 in QtPrivate::QStringList_contains (that=0xbfd959f4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd959f4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9d20ec0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9d20ec0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd95c14) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00e0bb7d in metacall (argv=0xbfd95c14, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9d20ec0) at kernel/qmetaobject.cpp:237
Comment 3 Thijs 2012-01-14 16:12:45 UTC

*** This bug has been marked as a duplicate of bug 291262 ***