Bug 291492 - muon-installer crash (muon runs fine)
Summary: muon-installer crash (muon runs fine)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 03:31 UTC by Tommy Quist
Modified: 2012-01-14 09:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tommy Quist 2012-01-14 03:31:36 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Started it as the first thing ona clean install. 

- Probably unimportant:
What may or may not be important is the unorthodox method of the install: From the hard disk (I dd'd the installation disk to a partition on the hard disk and then installed from there).

-Very very likely to be unimportant:
Running a mid-2011 Mac Mini using rEFIt loader with a hybrid MBR in a triple-boot setup (Mac OS X 10.7, Windows 7, Kubuntu 11.04

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f68dc780780 (LWP 3117))]

Thread 2 (Thread 0x7f68c7f3a700 (LWP 3118)):
#0  0x00007f68d934e773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f68d5bc3f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f68d5bc4429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f68db50bf3e in QEventDispatcherGlib::processEvents (this=0xd922c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f68db4dfcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f68db4dfef7 in QEventLoop::exec (this=0x7f68c7f39dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f68db3f727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f68db4c2cbf in QInotifyFileSystemWatcherEngine::run (this=0xd6b0a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f68db3f9d05 in QThreadPrivate::start (arg=0xd6b0a0) at thread/qthread_unix.cpp:331
#9  0x00007f68d66a5efc in start_thread (arg=0x7f68c7f3a700) at pthread_create.c:304
#10 0x00007f68d935a89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f68dc780780 (LWP 3117)):
[KCrash Handler]
#6  0x00007f68db447a5e in QtPrivate::QStringList_contains (that=0x7fff8dbc17f0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff8dbc17f0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xcee490) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xcee490, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8dbc1dc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f68db4f3eba in QMetaObject::activate (sender=0xec08b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xec08b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8dbc1f20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f68db4f3eba in QMetaObject::activate (sender=0xcee490, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8dbc1f20) at kernel/qobject.cpp:3278
#13 0x00007f68dc366e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xdc5220) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f68dc366f8e in MuonMainWindow::initObject (this=0xcee490) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xcee490) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xcee490, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8dbc1ff0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f68db4f3eba in QMetaObject::activate (sender=0xd88b60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f68db4fbf7f in QSingleShotTimer::timerEvent (this=0xd88b60) at kernel/qtimer.cpp:308
#19 0x00007f68db4f7789 in QObject::event (this=0xd88b60, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f68d9b1b424 in notify_helper (e=0x7fff8dbc2560, receiver=0xd88b60, this=0xbb0780) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xbb0780, receiver=0xd88b60, e=0x7fff8dbc2560) at kernel/qapplication.cpp:4458
#22 0x00007f68d9b20291 in QApplication::notify (this=0x7fff8dbc2860, receiver=0xd88b60, e=0x7fff8dbc2560) at kernel/qapplication.cpp:4365
#23 0x00007f68dacff126 in KApplication::notify (this=0x7fff8dbc2860, receiver=0xd88b60, event=0x7fff8dbc2560) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f68db4e0afc in QCoreApplication::notifyInternal (this=0x7fff8dbc2860, receiver=0xd88b60, event=0x7fff8dbc2560) at kernel/qcoreapplication.cpp:787
#25 0x00007f68db50dd62 in sendEvent (event=0x7fff8dbc2560, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xbad0d0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f68db50b514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f68d5bc3a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f68d5bc4258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f68d5bc4429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f68db50bed6 in QEventDispatcherGlib::processEvents (this=0xb886f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f68d9bc307e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f68db4dfcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f68db4dfef7 in QEventLoop::exec (this=0x7fff8dbc27f0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f68db4e4789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff8dbc2ad8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291490, bug 291489, bug 291486, bug 291485, bug 291482.

Possible duplicates by query: bug 291490, bug 291489, bug 291486, bug 291485, bug 291482.

Reported using DrKonqi
Comment 1 Tommy Quist 2012-01-14 03:41:17 UTC
sorry, don't know why I wrote 10.04 in the "very very likely to be unimportant part. I meant 11.10 of course.
Comment 2 Tommy Quist 2012-01-14 03:58:13 UTC
Oh, and by my comment in the title, I meant to say that the "muon" and "muon-updater" application both run fine. muon-installer alone shows this behavior. I should also add that purging the package and reinstalling it had no effect on the behavior.
Comment 3 Thijs 2012-01-14 09:03:21 UTC

*** This bug has been marked as a duplicate of bug 291262 ***