Bug 291509 - muon software crash
Summary: muon software crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 12:16 UTC by john
Modified: 2012-01-14 16:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john 2012-01-14 12:16:57 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: i tried to open muon software installer, it started to boot...however after the gui starte and before the lists loaded into the list it closed out, repeatedly

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb786c930 (LWP 2292))]

Thread 2 (Thread 0xb598bb70 (LWP 2296)):
#0  0x0096d970 in pthread_getspecific () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00c7de83 in ?? () from /usr/lib/i386-linux-gnu/libgthread-2.0.so.0
#2  0x08daf6dc in g_thread_self () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x08d85ea7 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x08d8756d in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x08d87c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x00b18b37 in QEventDispatcherGlib::processEvents (this=0x97fcca0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#7  0x00ae91dd in QEventLoop::processEvents (this=0xb598b2b0, flags=...) at kernel/qeventloop.cpp:149
#8  0x00ae9421 in QEventLoop::exec (this=0xb598b2b0, flags=...) at kernel/qeventloop.cpp:201
#9  0x009ec90b in QThread::exec (this=0x98008c8) at thread/qthread.cpp:498
#10 0x00ac9e2d in QInotifyFileSystemWatcherEngine::run (this=0x98008c8) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x009ef7b3 in QThreadPrivate::start (arg=0x98008c8) at thread/qthread_unix.cpp:331
#12 0x00968d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0x092c90ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb786c930 (LWP 2292)):
[KCrash Handler]
#7  0x00a43e11 in QtPrivate::QStringList_contains (that=0xbf91dac4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf91dac4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x969f4a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x969f4a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf91dce4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00af0b7d in metacall (argv=0xbf91dce4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x969f4a0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x969f4a0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf91dce4) at kernel/qmetaobject.cpp:232
#13 0x00affa6a in QMetaObject::activate (sender=0x96fe6d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x96fe6d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x96fe6d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf91de28) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00af0b7d in metacall (argv=0xbf91de28, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x96fe6d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x96fe6d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf91de28) at kernel/qmetaobject.cpp:232
#18 0x00affa6a in QMetaObject::activate (sender=0x969f4a0, m=0x80950c0, local_signal_index=0, argv=0xbf91de28) at kernel/qobject.cpp:3278
#19 0x003957c5 in MuonMainWindow::backendReady (this=0x969f4a0, _t1=0x96fffb8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00395933 in MuonMainWindow::initObject (this=0x969f4a0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x969f4a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x969f4a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf91df54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00af0b7d in metacall (argv=0xbf91df54, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x969f4a0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x969f4a0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf91df54) at kernel/qmetaobject.cpp:232
#25 0x00affa6a in QMetaObject::activate (sender=0x9713750, m=0xc20238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00b07375 in QSingleShotTimer::timeout (this=0x9713750) at .moc/release-shared/qtimer.moc:82
#27 0x00b0742c in QSingleShotTimer::timerEvent (this=0x9713750) at kernel/qtimer.cpp:308
#28 0x00b02994 in QObject::event (this=0x9713750, e=0xbf91e34c) at kernel/qobject.cpp:1181
#29 0x0578ed54 in notify_helper (e=0xbf91e34c, receiver=0x9713750, this=0x95bef90) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x95bef90, receiver=0x9713750, e=0xbf91e34c) at kernel/qapplication.cpp:4458
#31 0x05794103 in QApplication::notify (this=0xbf91e34c, receiver=0x9713750, e=0xbf91e34c) at kernel/qapplication.cpp:3886
#32 0x006e6681 in KApplication::notify (this=0xbf91e660, receiver=0x9713750, event=0xbf91e34c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00aea19e in QCoreApplication::notifyInternal (this=0xbf91e660, receiver=0x9713750, event=0xbf91e34c) at kernel/qcoreapplication.cpp:787
#34 0x00b1ac10 in sendEvent (event=0xbf91e34c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x95bae74) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00b18122 in timerSourceDispatch (source=0x95bae40) at kernel/qeventdispatcher_glib.cpp:184
#37 0x08d8725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x08d87990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x08d87c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00b18ada in QEventDispatcherGlib::processEvents (this=0x959c238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05846e3a in QGuiEventDispatcherGlib::processEvents (this=0x959c238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00ae91dd in QEventLoop::processEvents (this=0xbf91e5c4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00ae9421 in QEventLoop::exec (this=0xbf91e5c4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00aee19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0578c8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291492, bug 291490, bug 291489, bug 291486, bug 291485.

Reported using DrKonqi
Comment 1 Thijs 2012-01-14 16:12:56 UTC

*** This bug has been marked as a duplicate of bug 291262 ***