Bug 291520 - muon software center crashes on start
Summary: muon software center crashes on start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 15:16 UTC by bear1650
Modified: 2012-01-14 16:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bear1650 2012-01-14 15:16:38 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Just finished installing most recent updates and rebooted

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77ad930 (LWP 3208))]

Thread 2 (Thread 0xb56ffb70 (LWP 3209)):
#0  0x00dd5d44 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x0064cf54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x012e987f in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x012ea637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x012eac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00aeab37 in QEventDispatcherGlib::processEvents (this=0x8c945f0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00abb1dd in QEventLoop::processEvents (this=0xb56ff2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00abb421 in QEventLoop::exec (this=0xb56ff2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x009be90b in QThread::exec (this=0x8c8a560) at thread/qthread.cpp:498
#9  0x00a9be2d in QInotifyFileSystemWatcherEngine::run (this=0x8c8a560) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x009c17b3 in QThreadPrivate::start (arg=0x8c8a560) at thread/qthread_unix.cpp:331
#11 0x00dd2d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0063f0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77ad930 (LWP 3208)):
[KCrash Handler]
#7  0x00a15e11 in QtPrivate::QStringList_contains (that=0xbf907494, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf907494) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8c1e508) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8c1e508, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9076b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00ac2b7d in metacall (argv=0xbf9076b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8c1e508) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8c1e508, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9076b4) at kernel/qmetaobject.cpp:232
#13 0x00ad1a6a in QMetaObject::activate (sender=0x8cc6518, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8cc6518) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8cc6518, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9077f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00ac2b7d in metacall (argv=0xbf9077f8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8cc6518) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8cc6518, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9077f8) at kernel/qmetaobject.cpp:232
#18 0x00ad1a6a in QMetaObject::activate (sender=0x8c1e508, m=0x80950c0, local_signal_index=0, argv=0xbf9077f8) at kernel/qobject.cpp:3278
#19 0x00cbb7c5 in MuonMainWindow::backendReady (this=0x8c1e508, _t1=0x8c567e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00cbb933 in MuonMainWindow::initObject (this=0x8c1e508) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8c1e508) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8c1e508, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf907924) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00ac2b7d in metacall (argv=0xbf907924, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8c1e508) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8c1e508, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf907924) at kernel/qmetaobject.cpp:232
#25 0x00ad1a6a in QMetaObject::activate (sender=0x8c95348, m=0xbf2238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00ad9375 in QSingleShotTimer::timeout (this=0x8c95348) at .moc/release-shared/qtimer.moc:82
#27 0x00ad942c in QSingleShotTimer::timerEvent (this=0x8c95348) at kernel/qtimer.cpp:308
#28 0x00ad4994 in QObject::event (this=0x8c95348, e=0xbf907d1c) at kernel/qobject.cpp:1181
#29 0x065f4d54 in notify_helper (e=0xbf907d1c, receiver=0x8c95348, this=0x8b39a88) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8b39a88, receiver=0x8c95348, e=0xbf907d1c) at kernel/qapplication.cpp:4458
#31 0x065fa103 in QApplication::notify (this=0xbf907d1c, receiver=0x8c95348, e=0xbf907d1c) at kernel/qapplication.cpp:3886
#32 0x01055681 in KApplication::notify (this=0xbf908030, receiver=0x8c95348, event=0xbf907d1c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00abc19e in QCoreApplication::notifyInternal (this=0xbf908030, receiver=0x8c95348, event=0xbf907d1c) at kernel/qcoreapplication.cpp:787
#34 0x00aecc10 in sendEvent (event=0xbf907d1c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8b40534) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00aea122 in timerSourceDispatch (source=0x8b40500) at kernel/qeventdispatcher_glib.cpp:184
#37 0x012ea25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x012ea990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x012eac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00aeaada in QEventDispatcherGlib::processEvents (this=0x8b1c238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x066ace3a in QGuiEventDispatcherGlib::processEvents (this=0x8b1c238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00abb1dd in QEventLoop::processEvents (this=0xbf907f94, flags=...) at kernel/qeventloop.cpp:149
#43 0x00abb421 in QEventLoop::exec (this=0xbf907f94, flags=...) at kernel/qeventloop.cpp:201
#44 0x00ac019d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x065f28f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291513.

Possible duplicates by query: bug 291513, bug 291509, bug 291492, bug 291490, bug 291489.

Reported using DrKonqi
Comment 1 Thijs 2012-01-14 16:12:33 UTC

*** This bug has been marked as a duplicate of bug 291262 ***