Bug 291490 - Crash when attempting to open Muon
Summary: Crash when attempting to open Muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 01:54 UTC by fsanchez
Modified: 2012-01-14 09:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fsanchez 2012-01-14 01:54:00 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I attempted to launch Muon and it crashed. Launching it from Konsole didn't gave me any information.

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6dd0ad0780 (LWP 1947))]

Thread 2 (Thread 0x7f6dbbaf2700 (LWP 1951)):
#0  0x00007f6dcd69e773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6dc9f13f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6dc9f14429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6dcf85bf3e in QEventDispatcherGlib::processEvents (this=0x15a2180, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f6dcf82fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6dcf82fef7 in QEventLoop::exec (this=0x7f6dbbaf1dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f6dcf74727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f6dcf812cbf in QInotifyFileSystemWatcherEngine::run (this=0x159bbd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6dcf749d05 in QThreadPrivate::start (arg=0x159bbd0) at thread/qthread_unix.cpp:331
#9  0x00007f6dca9f5efc in start_thread (arg=0x7f6dbbaf2700) at pthread_create.c:304
#10 0x00007f6dcd6aa89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6dd0ad0780 (LWP 1947)):
[KCrash Handler]
#6  0x00007f6dcf797a5e in QtPrivate::QStringList_contains (that=0x7fffbc526500, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffbc526500) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1531e40) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1531e40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbc526ad0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f6dcf843eba in QMetaObject::activate (sender=0x1543290, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1543290, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbc526c30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f6dcf843eba in QMetaObject::activate (sender=0x1531e40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbc526c30) at kernel/qobject.cpp:3278
#13 0x00007f6dd06b6e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x15430f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f6dd06b6f8e in MuonMainWindow::initObject (this=0x1531e40) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1531e40) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1531e40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbc526d00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f6dcf843eba in QMetaObject::activate (sender=0x15d9030, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f6dcf84bf7f in QSingleShotTimer::timerEvent (this=0x15d9030) at kernel/qtimer.cpp:308
#19 0x00007f6dcf847789 in QObject::event (this=0x15d9030, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f6dcde6b424 in notify_helper (e=0x7fffbc527270, receiver=0x15d9030, this=0x13eac30) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x13eac30, receiver=0x15d9030, e=0x7fffbc527270) at kernel/qapplication.cpp:4458
#22 0x00007f6dcde70291 in QApplication::notify (this=0x7fffbc527570, receiver=0x15d9030, e=0x7fffbc527270) at kernel/qapplication.cpp:4365
#23 0x00007f6dcf04f126 in KApplication::notify (this=0x7fffbc527570, receiver=0x15d9030, event=0x7fffbc527270) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f6dcf830afc in QCoreApplication::notifyInternal (this=0x7fffbc527570, receiver=0x15d9030, event=0x7fffbc527270) at kernel/qcoreapplication.cpp:787
#25 0x00007f6dcf85dd62 in sendEvent (event=0x7fffbc527270, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x13f9440) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f6dcf85b514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f6dc9f13a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f6dc9f14258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f6dc9f14429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f6dcf85bed6 in QEventDispatcherGlib::processEvents (this=0x13c66f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f6dcdf1307e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f6dcf82fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f6dcf82fef7 in QEventLoop::exec (this=0x7fffbc527500, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f6dcf834789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fffbc5277e8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291486, bug 291482.

Possible duplicates by query: bug 291489, bug 291486, bug 291485, bug 291482, bug 291477.

Reported using DrKonqi
Comment 1 Thijs 2012-01-14 09:02:08 UTC

*** This bug has been marked as a duplicate of bug 29162 ***
Comment 2 Thijs 2012-01-14 09:02:33 UTC

*** This bug has been marked as a duplicate of bug 291262 ***