Bug 291453 - muon
Summary: muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-13 15:38 UTC by przemek
Modified: 2012-01-13 15:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description przemek 2012-01-13 15:38:11 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Nie można włączyć "Centrum oprogramowania".

The crash can be reproduced every time.

-- Backtrace:
Application: Centrum oprogramowania Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77f1930 (LWP 1791))]

Thread 2 (Thread 0xb5601b70 (LWP 1795)):
#0  0x00cd2d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0073d7d5 in do_gettime (frac=0xb5601020, sec=0xb5601018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x008104b6 in QTimerInfoList::updateCurrentTime (this=0xb4d0107c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0081080a in QTimerInfoList::timerWait (this=0xb4d0107c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0080f053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb560112c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0080f0ed in timerSourcePrepare (source=0xb4d01048, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0598d88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x0598e637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0598ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0080fb37 in QEventDispatcherGlib::processEvents (this=0x9681710, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x007e01dd in QEventLoop::processEvents (this=0xb56012b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x007e0421 in QEventLoop::exec (this=0xb56012b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x006e390b in QThread::exec (this=0x9679a88) at thread/qthread.cpp:498
#14 0x007c0e2d in QInotifyFileSystemWatcherEngine::run (this=0x9679a88) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x006e67b3 in QThreadPrivate::start (arg=0x9679a88) at thread/qthread_unix.cpp:331
#16 0x00cb4d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00ba90ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77f1930 (LWP 1791)):
[KCrash Handler]
#7  0x0073ae11 in QtPrivate::QStringList_contains (that=0xbfcd77a4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfcd77a4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x952de40) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x952de40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcd79c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x007e7b7d in metacall (argv=0xbfcd79c4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x952de40) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x952de40, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfcd79c4) at kernel/qmetaobject.cpp:232
#13 0x007f6a6a in QMetaObject::activate (sender=0x9565980, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9565980) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9565980, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcd7b08) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x007e7b7d in metacall (argv=0xbfcd7b08, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9565980) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9565980, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfcd7b08) at kernel/qmetaobject.cpp:232
#18 0x007f6a6a in QMetaObject::activate (sender=0x952de40, m=0x80950c0, local_signal_index=0, argv=0xbfcd7b08) at kernel/qobject.cpp:3278
#19 0x00aa37c5 in MuonMainWindow::backendReady (this=0x952de40, _t1=0x9563040) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00aa3933 in MuonMainWindow::initObject (this=0x952de40) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x952de40) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x952de40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcd7c34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x007e7b7d in metacall (argv=0xbfcd7c34, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x952de40) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x952de40, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfcd7c34) at kernel/qmetaobject.cpp:232
#25 0x007f6a6a in QMetaObject::activate (sender=0x958c508, m=0x917238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x007fe375 in QSingleShotTimer::timeout (this=0x958c508) at .moc/release-shared/qtimer.moc:82
#27 0x007fe42c in QSingleShotTimer::timerEvent (this=0x958c508) at kernel/qtimer.cpp:308
#28 0x007f9994 in QObject::event (this=0x958c508, e=0xbfcd802c) at kernel/qobject.cpp:1181
#29 0x01354d54 in notify_helper (e=0xbfcd802c, receiver=0x958c508, this=0x942a718) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x942a718, receiver=0x958c508, e=0xbfcd802c) at kernel/qapplication.cpp:4458
#31 0x0135a103 in QApplication::notify (this=0xbfcd802c, receiver=0x958c508, e=0xbfcd802c) at kernel/qapplication.cpp:3886
#32 0x00fab681 in KApplication::notify (this=0xbfcd8340, receiver=0x958c508, event=0xbfcd802c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x007e119e in QCoreApplication::notifyInternal (this=0xbfcd8340, receiver=0x958c508, event=0xbfcd802c) at kernel/qcoreapplication.cpp:787
#34 0x00811c10 in sendEvent (event=0xbfcd802c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9431b04) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0080f122 in timerSourceDispatch (source=0x9431ad0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0598e25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0598e990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0598ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0080fada in QEventDispatcherGlib::processEvents (this=0x940d238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0140ce3a in QGuiEventDispatcherGlib::processEvents (this=0x940d238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x007e01dd in QEventLoop::processEvents (this=0xbfcd82a4, flags=...) at kernel/qeventloop.cpp:149
#43 0x007e0421 in QEventLoop::exec (this=0xbfcd82a4, flags=...) at kernel/qeventloop.cpp:201
#44 0x007e519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x013528f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291411, bug 291394, bug 291393, bug 291388, bug 291387.

Reported using DrKonqi
Comment 1 Thijs 2012-01-13 15:41:26 UTC

*** This bug has been marked as a duplicate of bug 291262 ***