Bug 291387 - Muon Software Center crash on starting everytimes
Summary: Muon Software Center crash on starting everytimes
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 17:51 UTC by xiaosavage
Modified: 2012-01-12 18:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.67 KB, text/plain)
2012-01-12 18:04 UTC, turin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xiaosavage 2012-01-12 17:51:53 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Muon Software Center crash on starting everytimes

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[KCrash Handler]
#7  0x00b35e11 in QtPrivate::QStringList_contains (that=0xbf8efb34, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8efb34) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9fd3d20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9fd3d20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8efd54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00be2b7d in metacall (argv=0xbf8efd54, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9fd3d20) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9fd3d20, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8efd54) at kernel/qmetaobject.cpp:232
#13 0x00bf1a6a in QMetaObject::activate (sender=0xa198798, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa198798) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa198798, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8efe98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00be2b7d in metacall (argv=0xbf8efe98, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa198798) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa198798, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8efe98) at kernel/qmetaobject.cpp:232
#18 0x00bf1a6a in QMetaObject::activate (sender=0x9fd3d20, m=0x80950c0, local_signal_index=0, argv=0xbf8efe98) at kernel/qobject.cpp:3278
#19 0x00f3c7c5 in MuonMainWindow::backendReady (this=0x9fd3d20, _t1=0xa1937c0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00f3c933 in MuonMainWindow::initObject (this=0x9fd3d20) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9fd3d20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9fd3d20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8effc4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00be2b7d in metacall (argv=0xbf8effc4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9fd3d20) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9fd3d20, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf8effc4) at kernel/qmetaobject.cpp:232
#25 0x00bf1a6a in QMetaObject::activate (sender=0xa1934b0, m=0xd12238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00bf9375 in QSingleShotTimer::timeout (this=0xa1934b0) at .moc/release-shared/qtimer.moc:82
#27 0x00bf942c in QSingleShotTimer::timerEvent (this=0xa1934b0) at kernel/qtimer.cpp:308
#28 0x00bf4994 in QObject::event (this=0xa1934b0, e=0xbf8f03bc) at kernel/qobject.cpp:1181
#29 0x06f1cd54 in notify_helper (e=0xbf8f03bc, receiver=0xa1934b0, this=0x9ee4518) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9ee4518, receiver=0xa1934b0, e=0xbf8f03bc) at kernel/qapplication.cpp:4458
#31 0x06f22103 in QApplication::notify (this=0xbf8f03bc, receiver=0xa1934b0, e=0xbf8f03bc) at kernel/qapplication.cpp:3886
#32 0x01157681 in KApplication::notify (this=0xbf8f06d0, receiver=0xa1934b0, event=0xbf8f03bc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00bdc19e in QCoreApplication::notifyInternal (this=0xbf8f06d0, receiver=0xa1934b0, event=0xbf8f03bc) at kernel/qcoreapplication.cpp:787
#34 0x00c0cc10 in sendEvent (event=0xbf8f03bc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9ee4d5c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00c0a122 in timerSourceDispatch (source=0x9ee4d28) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01e0c25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01e0c990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01e0cc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00c0aada in QEventDispatcherGlib::processEvents (this=0x9ec7238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x06fd4e3a in QGuiEventDispatcherGlib::processEvents (this=0x9ec7238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00bdb1dd in QEventLoop::processEvents (this=0xbf8f0634, flags=...) at kernel/qeventloop.cpp:149
#43 0x00bdb421 in QEventLoop::exec (this=0xbf8f0634, flags=...) at kernel/qeventloop.cpp:201
#44 0x00be019d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x06f1a8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291385, bug 291384, bug 291382, bug 291368, bug 291365.

Reported using DrKonqi
Comment 1 turin 2012-01-12 18:04:56 UTC
Created attachment 67743 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:
everytime i try to open muon software center it crash

-- Backtrace (Reduced):
#7  0x00d1ee11 in QtPrivate::QStringList_contains (that=0xbfe10c24, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe10c24) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9ac9e60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9ac9e60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe10e44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00dcbb7d in metacall (argv=0xbfe10e44, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9ac9e60) at kernel/qmetaobject.cpp:237
Comment 2 Thijs 2012-01-12 18:06:50 UTC

*** This bug has been marked as a duplicate of bug 291262 ***