Bug 291411 - Muon crashes after start
Summary: Muon crashes after start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-13 02:32 UTC by matthias
Modified: 2012-01-13 07:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matthias 2012-01-13 02:32:44 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Started muon. Crashes anytime, regardless of other programms.
Crashes with open firefox, dolphin etc as well as right after a restart.

- Unusual behavior I noticed:

Pops up shortly, approximately 5 seconds. Then crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77a7930 (LWP 5030))]

Thread 2 (Thread 0xb55e6b70 (LWP 5034)):
#0  0x082ececc in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x082ee56d in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x082eec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00e5bb37 in QEventDispatcherGlib::processEvents (this=0x9641bd8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00e2c1dd in QEventLoop::processEvents (this=0xb55e62b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00e2c421 in QEventLoop::exec (this=0xb55e62b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00d2f90b in QThread::exec (this=0x9612098) at thread/qthread.cpp:498
#7  0x00e0ce2d in QInotifyFileSystemWatcherEngine::run (this=0x9612098) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00d327b3 in QThreadPrivate::start (arg=0x9612098) at thread/qthread_unix.cpp:331
#9  0x00619d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x002d10ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77a7930 (LWP 5030)):
[KCrash Handler]
#7  0x00d86e11 in QtPrivate::QStringList_contains (that=0xbf875874, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf875874) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x95bca48) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x95bca48, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf875a94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00e33b7d in metacall (argv=0xbf875a94, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x95bca48) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x95bca48, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf875a94) at kernel/qmetaobject.cpp:232
#13 0x00e42a6a in QMetaObject::activate (sender=0x95b76f8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x95b76f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x95b76f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf875bd8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00e33b7d in metacall (argv=0xbf875bd8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x95b76f8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x95b76f8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf875bd8) at kernel/qmetaobject.cpp:232
#18 0x00e42a6a in QMetaObject::activate (sender=0x95bca48, m=0x80950c0, local_signal_index=0, argv=0xbf875bd8) at kernel/qobject.cpp:3278
#19 0x001287c5 in MuonMainWindow::backendReady (this=0x95bca48, _t1=0x96297c0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00128933 in MuonMainWindow::initObject (this=0x95bca48) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x95bca48) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x95bca48, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf875d04) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00e33b7d in metacall (argv=0xbf875d04, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x95bca48) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x95bca48, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf875d04) at kernel/qmetaobject.cpp:232
#25 0x00e42a6a in QMetaObject::activate (sender=0x9640ba8, m=0xf63238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00e4a375 in QSingleShotTimer::timeout (this=0x9640ba8) at .moc/release-shared/qtimer.moc:82
#27 0x00e4a42c in QSingleShotTimer::timerEvent (this=0x9640ba8) at kernel/qtimer.cpp:308
#28 0x00e45994 in QObject::event (this=0x9640ba8, e=0xbf8760fc) at kernel/qobject.cpp:1181
#29 0x02629d54 in notify_helper (e=0xbf8760fc, receiver=0x9640ba8, this=0x94e4aa8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x94e4aa8, receiver=0x9640ba8, e=0xbf8760fc) at kernel/qapplication.cpp:4458
#31 0x0262f103 in QApplication::notify (this=0xbf8760fc, receiver=0x9640ba8, e=0xbf8760fc) at kernel/qapplication.cpp:3886
#32 0x0114f681 in KApplication::notify (this=0xbf876410, receiver=0x9640ba8, event=0xbf8760fc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00e2d19e in QCoreApplication::notifyInternal (this=0xbf876410, receiver=0x9640ba8, event=0xbf8760fc) at kernel/qcoreapplication.cpp:787
#34 0x00e5dc10 in sendEvent (event=0xbf8760fc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x94de6ec) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00e5b122 in timerSourceDispatch (source=0x94de6b8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x082ee25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x082ee990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x082eec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00e5bada in QEventDispatcherGlib::processEvents (this=0x94bf238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x026e1e3a in QGuiEventDispatcherGlib::processEvents (this=0x94bf238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00e2c1dd in QEventLoop::processEvents (this=0xbf876374, flags=...) at kernel/qeventloop.cpp:149
#43 0x00e2c421 in QEventLoop::exec (this=0xbf876374, flags=...) at kernel/qeventloop.cpp:201
#44 0x00e3119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x026278f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291394.

Possible duplicates by query: bug 291394, bug 291393, bug 291388, bug 291387, bug 291385.

Reported using DrKonqi
Comment 1 Thijs 2012-01-13 07:21:55 UTC

*** This bug has been marked as a duplicate of bug 291262 ***