Bug 291388 - Logitheque muon ne se lance pas
Summary: Logitheque muon ne se lance pas
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 18:29 UTC by tony.rivaud
Modified: 2012-02-10 13:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.26 KB, text/plain)
2012-02-10 13:01 UTC, maxime
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tony.rivaud 2012-01-12 18:29:41 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
lors du lancement de la logitheque muon, un message d'erreur s'affiche. elle réapparait à chaque fois

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76f6930 (LWP 2133))]

Thread 2 (Thread 0xb5655b70 (LWP 2137)):
#0  0x00c86416 in __kernel_vsyscall ()
#1  0x038bd40e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x01f3334b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01f24896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01f24c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x002c3b37 in QEventDispatcherGlib::processEvents (this=0x8993a48, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x002941dd in QEventLoop::processEvents (this=0xb56552b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00294421 in QEventLoop::exec (this=0xb56552b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0019790b in QThread::exec (this=0x8a9d510) at thread/qthread.cpp:498
#9  0x00274e2d in QInotifyFileSystemWatcherEngine::run (this=0x8a9d510) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0019a7b3 in QThreadPrivate::start (arg=0x8a9d510) at thread/qthread_unix.cpp:331
#11 0x009ebd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x038cc0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76f6930 (LWP 2133)):
[KCrash Handler]
#7  0x001eee11 in QtPrivate::QStringList_contains (that=0xbfcc0824, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfcc0824) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8958d68) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8958d68, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcc0a44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0029bb7d in metacall (argv=0xbfcc0a44, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8958d68) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8958d68, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfcc0a44) at kernel/qmetaobject.cpp:232
#13 0x002aaa6a in QMetaObject::activate (sender=0x89d7100, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x89d7100) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x89d7100, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcc0b88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0029bb7d in metacall (argv=0xbfcc0b88, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x89d7100) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x89d7100, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfcc0b88) at kernel/qmetaobject.cpp:232
#18 0x002aaa6a in QMetaObject::activate (sender=0x8958d68, m=0x80950c0, local_signal_index=0, argv=0xbfcc0b88) at kernel/qobject.cpp:3278
#19 0x00a197c5 in MuonMainWindow::backendReady (this=0x8958d68, _t1=0x8958a18) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00a19933 in MuonMainWindow::initObject (this=0x8958d68) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8958d68) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8958d68, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcc0cb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0029bb7d in metacall (argv=0xbfcc0cb4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8958d68) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8958d68, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfcc0cb4) at kernel/qmetaobject.cpp:232
#25 0x002aaa6a in QMetaObject::activate (sender=0x89bda20, m=0x3cb238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x002b2375 in QSingleShotTimer::timeout (this=0x89bda20) at .moc/release-shared/qtimer.moc:82
#27 0x002b242c in QSingleShotTimer::timerEvent (this=0x89bda20) at kernel/qtimer.cpp:308
#28 0x002ad994 in QObject::event (this=0x89bda20, e=0xbfcc10ac) at kernel/qobject.cpp:1181
#29 0x013fed54 in notify_helper (e=0xbfcc10ac, receiver=0x89bda20, this=0x885baa0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x885baa0, receiver=0x89bda20, e=0xbfcc10ac) at kernel/qapplication.cpp:4458
#31 0x01404103 in QApplication::notify (this=0xbfcc10ac, receiver=0x89bda20, e=0xbfcc10ac) at kernel/qapplication.cpp:3886
#32 0x0066b681 in KApplication::notify (this=0xbfcc13c0, receiver=0x89bda20, event=0xbfcc10ac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0029519e in QCoreApplication::notifyInternal (this=0xbfcc13c0, receiver=0x89bda20, event=0xbfcc10ac) at kernel/qcoreapplication.cpp:787
#34 0x002c5c10 in sendEvent (event=0xbfcc10ac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x885d5a4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002c3122 in timerSourceDispatch (source=0x885d570) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01f2425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01f24990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01f24c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x002c3ada in QEventDispatcherGlib::processEvents (this=0x883f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x014b6e3a in QGuiEventDispatcherGlib::processEvents (this=0x883f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x002941dd in QEventLoop::processEvents (this=0xbfcc1324, flags=...) at kernel/qeventloop.cpp:149
#43 0x00294421 in QEventLoop::exec (this=0xbfcc1324, flags=...) at kernel/qeventloop.cpp:201
#44 0x0029919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x013fc8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291387, bug 291385, bug 291384, bug 291382, bug 291368.

Reported using DrKonqi
Comment 1 Thijs 2012-01-12 19:08:54 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 maxime 2012-02-10 13:01:40 UTC
Created attachment 68676 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

As soon as I want to go to the logitheque muon to look for software, from his(her,its) launch, she(it) plants with an error message, the fenetre opens, there is nothing of posted(shown) on the fenetre and that plants with mesage of error
 kde 4.7.4 kubuntu 11.10

-- Backtrace (Reduced):
#6  0x00007f26749b5a5e in QtPrivate::QStringList_contains (that=0x7fff5d839c20, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff5d839c20) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x204adf0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x204adf0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5d83a1f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2231cc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5d83a350) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109