Bug 291394 - Muon software center
Summary: Muon software center
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 20:48 UTC by Chris Heathington
Modified: 2012-01-13 07:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Heathington 2012-01-12 20:48:47 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Opening Muon to install a app I needed, no other program was running at the time.
I have rebooted and tried agian with the same errors

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3f357c5780 (LWP 4195))]

Thread 2 (Thread 0x7f3f20db7700 (LWP 4199)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f3f20db6af0 in ?? ()
#2  0x00007fff0533e7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f3f357c5780 (LWP 4195)):
[KCrash Handler]
#6  0x00007f3f3448ca5e in QtPrivate::QStringList_contains (that=0x7fff05327dc0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff05327dc0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x118e9e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x118e9e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff05328390) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f3f34538eba in QMetaObject::activate (sender=0x120df80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x120df80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff053284f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f3f34538eba in QMetaObject::activate (sender=0x118e9e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff053284f0) at kernel/qobject.cpp:3278
#13 0x00007f3f353abe7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x120f7f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f3f353abf8e in MuonMainWindow::initObject (this=0x118e9e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x118e9e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x118e9e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff053285c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f3f34538eba in QMetaObject::activate (sender=0x120f850, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f3f34540f7f in QSingleShotTimer::timerEvent (this=0x120f850) at kernel/qtimer.cpp:308
#19 0x00007f3f3453c789 in QObject::event (this=0x120f850, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f3f32b60424 in notify_helper (e=0x7fff05328b30, receiver=0x120f850, this=0x1047b20) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1047b20, receiver=0x120f850, e=0x7fff05328b30) at kernel/qapplication.cpp:4458
#22 0x00007f3f32b65291 in QApplication::notify (this=0x7fff05328e30, receiver=0x120f850, e=0x7fff05328b30) at kernel/qapplication.cpp:4365
#23 0x00007f3f33d44126 in KApplication::notify (this=0x7fff05328e30, receiver=0x120f850, event=0x7fff05328b30) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f3f34525afc in QCoreApplication::notifyInternal (this=0x7fff05328e30, receiver=0x120f850, event=0x7fff05328b30) at kernel/qcoreapplication.cpp:787
#25 0x00007f3f34552d62 in sendEvent (event=0x7fff05328b30, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x104a8f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f3f34550514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f3f2ec08a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f3f2ec09258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f3f2ec09429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f3f34550ed6 in QEventDispatcherGlib::processEvents (this=0x10246f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f3f32c0807e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f3f34524cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f3f34524ef7 in QEventLoop::exec (this=0x7fff05328dc0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f3f34529789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff053290a8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291368, bug 291365, bug 291363, bug 291353, bug 291339.

Reported using DrKonqi
Comment 1 Thijs 2012-01-13 07:21:38 UTC

*** This bug has been marked as a duplicate of bug 291262 ***