Bug 291393 - Muon-Absturz
Summary: Muon-Absturz
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 20:17 UTC by bartos.g
Modified: 2012-01-12 20:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bartos.g 2012-01-12 20:17:26 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: dolphin open, firefox open and thunderbird open, tried to open muon and it crashed immediatley

- Unusual behavior I noticed: nothing unusual, nothing else was running

- Custom settings of the application: ???

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78be930 (LWP 2810))]

Thread 2 (Thread 0xb580cb70 (LWP 2811)):
#0  0x0047d416 in __kernel_vsyscall ()
#1  0x0054140e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0142734b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01418896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01418c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00888b37 in QEventDispatcherGlib::processEvents (this=0x8f1e7a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x008591dd in QEventLoop::processEvents (this=0xb580c2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00859421 in QEventLoop::exec (this=0xb580c2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0075c90b in QThread::exec (this=0x8f1cd58) at thread/qthread.cpp:498
#9  0x00839e2d in QInotifyFileSystemWatcherEngine::run (this=0x8f1cd58) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0075f7b3 in QThreadPrivate::start (arg=0x8f1cd58) at thread/qthread_unix.cpp:331
#11 0x00a6ed31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x005500ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78be930 (LWP 2810)):
[KCrash Handler]
#7  0x007b3e11 in QtPrivate::QStringList_contains (that=0xbfa691e4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfa691e4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8f197f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8f197f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa69404) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00860b7d in metacall (argv=0xbfa69404, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8f197f0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8f197f0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfa69404) at kernel/qmetaobject.cpp:232
#13 0x0086fa6a in QMetaObject::activate (sender=0x8f95b40, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8f95b40) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8f95b40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa69548) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00860b7d in metacall (argv=0xbfa69548, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8f95b40) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8f95b40, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfa69548) at kernel/qmetaobject.cpp:232
#18 0x0086fa6a in QMetaObject::activate (sender=0x8f197f0, m=0x80950c0, local_signal_index=0, argv=0xbfa69548) at kernel/qobject.cpp:3278
#19 0x001c97c5 in MuonMainWindow::backendReady (this=0x8f197f0, _t1=0x8f7c9c0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x001c9933 in MuonMainWindow::initObject (this=0x8f197f0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8f197f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8f197f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa69674) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00860b7d in metacall (argv=0xbfa69674, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8f197f0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8f197f0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfa69674) at kernel/qmetaobject.cpp:232
#25 0x0086fa6a in QMetaObject::activate (sender=0x8f8d030, m=0x990238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00877375 in QSingleShotTimer::timeout (this=0x8f8d030) at .moc/release-shared/qtimer.moc:82
#27 0x0087742c in QSingleShotTimer::timerEvent (this=0x8f8d030) at kernel/qtimer.cpp:308
#28 0x00872994 in QObject::event (this=0x8f8d030, e=0xbfa69a6c) at kernel/qobject.cpp:1181
#29 0x01e4cd54 in notify_helper (e=0xbfa69a6c, receiver=0x8f8d030, this=0x8e057f0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8e057f0, receiver=0x8f8d030, e=0xbfa69a6c) at kernel/qapplication.cpp:4458
#31 0x01e52103 in QApplication::notify (this=0xbfa69a6c, receiver=0x8f8d030, e=0xbfa69a6c) at kernel/qapplication.cpp:3886
#32 0x00fd3681 in KApplication::notify (this=0xbfa69d80, receiver=0x8f8d030, event=0xbfa69a6c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0085a19e in QCoreApplication::notifyInternal (this=0xbfa69d80, receiver=0x8f8d030, event=0xbfa69a6c) at kernel/qcoreapplication.cpp:787
#34 0x0088ac10 in sendEvent (event=0xbfa69a6c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8e08304) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00888122 in timerSourceDispatch (source=0x8e082d0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0141825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01418990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01418c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00888ada in QEventDispatcherGlib::processEvents (this=0x8de7238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01f04e3a in QGuiEventDispatcherGlib::processEvents (this=0x8de7238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x008591dd in QEventLoop::processEvents (this=0xbfa69ce4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00859421 in QEventLoop::exec (this=0xbfa69ce4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0085e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01e4a8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291388, bug 291387, bug 291385, bug 291384, bug 291382.

Reported using DrKonqi
Comment 1 Thijs 2012-01-12 20:28:06 UTC

*** This bug has been marked as a duplicate of bug 291262 ***