Bug 291385 - Muhon crached
Summary: Muhon crached
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 17:12 UTC by Aurélien57
Modified: 2012-01-12 17:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aurélien57 2012-01-12 17:12:01 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crasched :
I was opening Muhon, when it was crached.

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7779930 (LWP 2202))]

Thread 2 (Thread 0xb3ca5b70 (LWP 2210)):
#0  pthread_mutex_unlock (mutex=0x8593414) at forward.c:184
#1  0x048e6785 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x048e6c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x005ceb37 in QEventDispatcherGlib::processEvents (this=0x8577b48, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x0059f1dd in QEventLoop::processEvents (this=0xb3ca52b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x0059f421 in QEventLoop::exec (this=0xb3ca52b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x004a290b in QThread::exec (this=0x85b1438) at thread/qthread.cpp:498
#7  0x0057fe2d in QInotifyFileSystemWatcherEngine::run (this=0x85b1438) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x004a57b3 in QThreadPrivate::start (arg=0x85b1438) at thread/qthread_unix.cpp:331
#9  0x008e0d31 in start_thread (arg=0xb3ca5b70) at pthread_create.c:304
#10 0x00a9a0ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7779930 (LWP 2202)):
[KCrash Handler]
#7  0x004f9e11 in QtPrivate::QStringList_contains (that=0xbfdb1584, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfdb1584) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x84ee408) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x84ee408, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdb17a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x005a6b7d in metacall (argv=0xbfdb17a4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x84ee408) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x84ee408, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfdb17a4) at kernel/qmetaobject.cpp:232
#13 0x005b5a6a in QMetaObject::activate (sender=0x84ca7e0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x84ca7e0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x84ca7e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdb18e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x005a6b7d in metacall (argv=0xbfdb18e8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x84ca7e0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x84ca7e0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfdb18e8) at kernel/qmetaobject.cpp:232
#18 0x005b5a6a in QMetaObject::activate (sender=0x84ee408, m=0x80950c0, local_signal_index=0, argv=0xbfdb18e8) at kernel/qobject.cpp:3278
#19 0x009947c5 in MuonMainWindow::backendReady (this=0x84ee408, _t1=0x849cdf8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00994933 in MuonMainWindow::initObject (this=0x84ee408) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x84ee408) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x84ee408, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdb1a14) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x005a6b7d in metacall (argv=0xbfdb1a14, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x84ee408) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x84ee408, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfdb1a14) at kernel/qmetaobject.cpp:232
#25 0x005b5a6a in QMetaObject::activate (sender=0x861ef60, m=0x6d6238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x005bd375 in QSingleShotTimer::timeout (this=0x861ef60) at .moc/release-shared/qtimer.moc:82
#27 0x005bd42c in QSingleShotTimer::timerEvent (this=0x861ef60) at kernel/qtimer.cpp:308
#28 0x005b8994 in QObject::event (this=0x861ef60, e=0xbfdb1e0c) at kernel/qobject.cpp:1181
#29 0x02ad6d54 in notify_helper (e=0xbfdb1e0c, receiver=0x861ef60, this=0x840cf40) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x840cf40, receiver=0x861ef60, e=0xbfdb1e0c) at kernel/qapplication.cpp:4458
#31 0x02adc103 in QApplication::notify (this=0xbfdb1e0c, receiver=0x861ef60, e=0xbfdb1e0c) at kernel/qapplication.cpp:3886
#32 0x010ab681 in KApplication::notify (this=0xbfdb2120, receiver=0x861ef60, event=0xbfdb1e0c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x005a019e in QCoreApplication::notifyInternal (this=0xbfdb2120, receiver=0x861ef60, event=0xbfdb1e0c) at kernel/qcoreapplication.cpp:787
#34 0x005d0c10 in sendEvent (event=0xbfdb1e0c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x840fbcc) at kernel/qeventdispatcher_unix.cpp:603
#36 0x005ce122 in timerSourceDispatch (source=0x840fb98) at kernel/qeventdispatcher_glib.cpp:184
#37 0x048e625f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x048e6990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x048e6c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x005ceada in QEventDispatcherGlib::processEvents (this=0x83ef238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02b8ee3a in QGuiEventDispatcherGlib::processEvents (this=0x83ef238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0059f1dd in QEventLoop::processEvents (this=0xbfdb2084, flags=...) at kernel/qeventloop.cpp:149
#43 0x0059f421 in QEventLoop::exec (this=0xbfdb2084, flags=...) at kernel/qeventloop.cpp:201
#44 0x005a419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02ad48f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291384, bug 291382, bug 291368, bug 291365, bug 291363.

Reported using DrKonqi
Comment 1 Thijs 2012-01-12 17:17:47 UTC

*** This bug has been marked as a duplicate of bug 291262 ***