Bug 291363 - muon-installer crash at start even deleting and reinstalling the aplication
Summary: muon-installer crash at start even deleting and reinstalling the aplication
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 11:57 UTC by rodrix
Modified: 2012-01-12 12:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rodrix 2012-01-12 11:57:47 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Just opening it from k menu or konsole. It does not start.

Nothing more is running, all aplications closed.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d9930 (LWP 2082))]

Thread 2 (Thread 0xb5ce8b70 (LWP 2083)):
#0  0x01514efe in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x0151656d in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x01516c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x007e4b37 in QEventDispatcherGlib::processEvents (this=0x8c90860, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x007b51dd in QEventLoop::processEvents (this=0xb5ce82b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x007b5421 in QEventLoop::exec (this=0xb5ce82b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x006b890b in QThread::exec (this=0x8c96c00) at thread/qthread.cpp:498
#7  0x00795e2d in QInotifyFileSystemWatcherEngine::run (this=0x8c96c00) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x006bb7b3 in QThreadPrivate::start (arg=0x8c96c00) at thread/qthread_unix.cpp:331
#9  0x00baad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00afa0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77d9930 (LWP 2082)):
[KCrash Handler]
#7  0x0070fe11 in QtPrivate::QStringList_contains (that=0xbf8df2c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8df2c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8c8ff50) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8c8ff50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8df4e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x007bcb7d in metacall (argv=0xbf8df4e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8c8ff50) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8c8ff50, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8df4e4) at kernel/qmetaobject.cpp:232
#13 0x007cba6a in QMetaObject::activate (sender=0x8d24c18, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8d24c18) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8d24c18, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8df628) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x007bcb7d in metacall (argv=0xbf8df628, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8d24c18) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8d24c18, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8df628) at kernel/qmetaobject.cpp:232
#18 0x007cba6a in QMetaObject::activate (sender=0x8c8ff50, m=0x80950c0, local_signal_index=0, argv=0xbf8df628) at kernel/qobject.cpp:3278
#19 0x005a17c5 in MuonMainWindow::backendReady (this=0x8c8ff50, _t1=0x8ce5c40) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x005a1933 in MuonMainWindow::initObject (this=0x8c8ff50) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8c8ff50) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8c8ff50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8df754) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x007bcb7d in metacall (argv=0xbf8df754, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8c8ff50) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8c8ff50, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf8df754) at kernel/qmetaobject.cpp:232
#25 0x007cba6a in QMetaObject::activate (sender=0x8cf7868, m=0x8ec238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x007d3375 in QSingleShotTimer::timeout (this=0x8cf7868) at .moc/release-shared/qtimer.moc:82
#27 0x007d342c in QSingleShotTimer::timerEvent (this=0x8cf7868) at kernel/qtimer.cpp:308
#28 0x007ce994 in QObject::event (this=0x8cf7868, e=0xbf8dfb4c) at kernel/qobject.cpp:1181
#29 0x02c17d54 in notify_helper (e=0xbf8dfb4c, receiver=0x8cf7868, this=0x8ba0e70) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8ba0e70, receiver=0x8cf7868, e=0xbf8dfb4c) at kernel/qapplication.cpp:4458
#31 0x02c1d103 in QApplication::notify (this=0xbf8dfb4c, receiver=0x8cf7868, e=0xbf8dfb4c) at kernel/qapplication.cpp:3886
#32 0x010d4681 in KApplication::notify (this=0xbf8dfe60, receiver=0x8cf7868, event=0xbf8dfb4c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x007b619e in QCoreApplication::notifyInternal (this=0xbf8dfe60, receiver=0x8cf7868, event=0xbf8dfb4c) at kernel/qcoreapplication.cpp:787
#34 0x007e6c10 in sendEvent (event=0xbf8dfb4c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8b9e134) at kernel/qeventdispatcher_unix.cpp:603
#36 0x007e4122 in timerSourceDispatch (source=0x8b9e100) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0151625f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01516990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01516c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x007e4ada in QEventDispatcherGlib::processEvents (this=0x8b7f220, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02ccfe3a in QGuiEventDispatcherGlib::processEvents (this=0x8b7f220, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x007b51dd in QEventLoop::processEvents (this=0xbf8dfdc4, flags=...) at kernel/qeventloop.cpp:149
#43 0x007b5421 in QEventLoop::exec (this=0xbf8dfdc4, flags=...) at kernel/qeventloop.cpp:201
#44 0x007ba19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02c158f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291353, bug 291339, bug 291335, bug 291329, bug 291317.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-01-12 12:36:28 UTC

*** This bug has been marked as a duplicate of bug 291262 ***