Bug 291353 - Muon Software Center Crash on Start
Summary: Muon Software Center Crash on Start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 10:54 UTC by Mats Kindahl
Modified: 2012-01-12 12:55 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.71 KB, text/plain)
2012-01-12 11:30 UTC, rodrix
Details
New crash information added by DrKonqi (6.71 KB, text/plain)
2012-01-12 11:30 UTC, rodrix
Details
New crash information added by DrKonqi (6.71 KB, text/plain)
2012-01-12 11:30 UTC, rodrix
Details
New crash information added by DrKonqi (6.05 KB, text/plain)
2012-01-12 12:24 UTC, andrea arrotta
Details
New crash information added by DrKonqi (7.52 KB, text/plain)
2012-01-12 12:55 UTC, Reza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mats Kindahl 2012-01-12 10:54:15 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Just starting the Muon software center triggered this crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4841930 (LWP 32468))]

Thread 2 (Thread 0xb2559b70 (LWP 32471)):
#0  0xb538ed10 in __GI_clock_gettime (clock_id=1, tp=0xb2559028) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb72697d5 in do_gettime (frac=0xb2559020, sec=0xb2559018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb733c4b6 in QTimerInfoList::updateCurrentTime (this=0x956dc34) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb733c80a in QTimerInfoList::timerWait (this=0x956dc34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb733b053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb255912c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb733b0ed in timerSourcePrepare (source=0x956dc00, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb52d488c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb52d5637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb52d5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb733bb37 in QEventDispatcherGlib::processEvents (this=0x9556f70, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb730c1dd in QEventLoop::processEvents (this=0xb25592b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb730c421 in QEventLoop::exec (this=0xb25592b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb720f90b in QThread::exec (this=0x955d868) at thread/qthread.cpp:498
#14 0xb72ece2d in QInotifyFileSystemWatcherEngine::run (this=0x955d868) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb72127b3 in QThreadPrivate::start (arg=0x955d868) at thread/qthread_unix.cpp:331
#16 0xb53bbd31 in start_thread (arg=0xb2559b70) at pthread_create.c:304
#17 0xb5e080ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb4841930 (LWP 32468)):
[KCrash Handler]
#7  0xb7266e11 in QtPrivate::QStringList_contains (that=0xbfb2a834, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb2a834) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x94fa530) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x94fa530, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb2aa54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7313b7d in metacall (argv=0xbfb2aa54, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x94fa530) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x94fa530, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb2aa54) at kernel/qmetaobject.cpp:232
#13 0xb7322a6a in QMetaObject::activate (sender=0x946e618, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x946e618) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x946e618, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb2ab98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7313b7d in metacall (argv=0xbfb2ab98, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x946e618) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x946e618, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb2ab98) at kernel/qmetaobject.cpp:232
#18 0xb7322a6a in QMetaObject::activate (sender=0x94fa530, m=0x80950c0, local_signal_index=0, argv=0xbfb2ab98) at kernel/qobject.cpp:3278
#19 0xb77817c5 in MuonMainWindow::backendReady (this=0x94fa530, _t1=0x94f8e00) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb7781933 in MuonMainWindow::initObject (this=0x94fa530) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x94fa530) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x94fa530, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb2acc4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7313b7d in metacall (argv=0xbfb2acc4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x94fa530) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x94fa530, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb2acc4) at kernel/qmetaobject.cpp:232
#25 0xb7322a6a in QMetaObject::activate (sender=0x9573838, m=0xb7443238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb732a375 in QSingleShotTimer::timeout (this=0x9573838) at .moc/release-shared/qtimer.moc:82
#27 0xb732a42c in QSingleShotTimer::timerEvent (this=0x9573838) at kernel/qtimer.cpp:308
#28 0xb7325994 in QObject::event (this=0x9573838, e=0xbfb2b0bc) at kernel/qobject.cpp:1181
#29 0xb60f4d54 in notify_helper (e=0xbfb2b0bc, receiver=0x9573838, this=0x93f8098) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x93f8098, receiver=0x9573838, e=0xbfb2b0bc) at kernel/qapplication.cpp:4458
#31 0xb60fa103 in QApplication::notify (this=0xbfb2b0bc, receiver=0x9573838, e=0xbfb2b0bc) at kernel/qapplication.cpp:3886
#32 0xb6f13681 in KApplication::notify (this=0xbfb2b3d0, receiver=0x9573838, event=0xbfb2b0bc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb730d19e in QCoreApplication::notifyInternal (this=0xbfb2b3d0, receiver=0x9573838, event=0xbfb2b0bc) at kernel/qcoreapplication.cpp:787
#34 0xb733dc10 in sendEvent (event=0xbfb2b0bc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x93f9f34) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb733b155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x93f9f68) at kernel/qeventdispatcher_glib.cpp:231
#38 0xb52d525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb52d5990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb52d5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0xb733bada in QEventDispatcherGlib::processEvents (this=0x93db238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0xb61ace3a in QGuiEventDispatcherGlib::processEvents (this=0x93db238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0xb730c1dd in QEventLoop::processEvents (this=0xbfb2b334, flags=...) at kernel/qeventloop.cpp:149
#44 0xb730c421 in QEventLoop::exec (this=0xbfb2b334, flags=...) at kernel/qeventloop.cpp:201
#45 0xb731119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0xb60f28f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291339, bug 291335, bug 291329, bug 291317, bug 291286.

Reported using DrKonqi
Comment 1 rodrix 2012-01-12 11:30:11 UTC
Created attachment 67729 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

Just opening muon from the K menu/Aplications/System/Software Center

-- Backtrace (Reduced):
#7  0x00770e11 in QtPrivate::QStringList_contains (that=0xbff25514, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff25514) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x832b5d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x832b5d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff25734) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0081db7d in metacall (argv=0xbff25734, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x832b5d0) at kernel/qmetaobject.cpp:237
Comment 2 rodrix 2012-01-12 11:30:12 UTC
Created attachment 67730 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

Just opening muon from the K menu/Aplications/System/Software Center

-- Backtrace (Reduced):
#7  0x00770e11 in QtPrivate::QStringList_contains (that=0xbff25514, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff25514) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x832b5d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x832b5d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff25734) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0081db7d in metacall (argv=0xbff25734, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x832b5d0) at kernel/qmetaobject.cpp:237
Comment 3 rodrix 2012-01-12 11:30:12 UTC
Created attachment 67731 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

Just opening muon from the K menu/Aplications/System/Software Center

-- Backtrace (Reduced):
#7  0x00770e11 in QtPrivate::QStringList_contains (that=0xbff25514, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff25514) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x832b5d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x832b5d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff25734) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0081db7d in metacall (argv=0xbff25734, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x832b5d0) at kernel/qmetaobject.cpp:237
Comment 4 andrea arrotta 2012-01-12 12:24:44 UTC
Created attachment 67736 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:
I just opened the Muon Package Manager when it crashed

-- Backtrace (Reduced):
#6  0x00007f4ca952aa5e in QtPrivate::QStringList_contains (that=0x7fffcf4f4920, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffcf4f4920) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x25ec2d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x25ec2d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcf4f4ef0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x247d080, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffcf4f5050) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 5 Christoph Feck 2012-01-12 12:36:07 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 6 Reza 2012-01-12 12:55:54 UTC
Created attachment 67739 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- Unusual behavior I noticed: Have screen refresh problem. got linear or pixel ate noise on  windows and buttons. Got slower startup than before. Terminal dose not recognize commands, but Run Command do. 
" kdesu muon" command bring up the Muon Software Center window, but by  clicking launcher  menu it crashes.

-- Backtrace (Reduced):
#7  0x0048ee11 in QtPrivate::QStringList_contains (that=0xbfe0d7d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe0d7d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8f77820) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8f77820, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe0d9f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0053bb7d in metacall (argv=0xbfe0d9f4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8f77820) at kernel/qmetaobject.cpp:237