Bug 291368 - muon
Summary: muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 12:47 UTC by chkan_vn
Modified: 2012-01-12 12:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chkan_vn 2012-01-12 12:47:46 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
don't work anymore, problem bug with KDE

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fed8fca0780 (LWP 2622))]

Thread 2 (Thread 0x7fed7b2d5700 (LWP 2623)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fed7b2d4af0 in ?? ()
#2  0x00007fff7f7c77e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7fed8fca0780 (LWP 2622)):
[KCrash Handler]
#6  0x00007fed8e967a5e in QtPrivate::QStringList_contains (that=0x7fff7f790520, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff7f790520) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x20f3120) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x20f3120, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff7f790af0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fed8ea13eba in QMetaObject::activate (sender=0x21c5b00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x21c5b00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff7f790c50) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fed8ea13eba in QMetaObject::activate (sender=0x20f3120, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff7f790c50) at kernel/qobject.cpp:3278
#13 0x00007fed8f886e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1f8f630) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fed8f886f8e in MuonMainWindow::initObject (this=0x20f3120) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x20f3120) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x20f3120, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff7f790d20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fed8ea13eba in QMetaObject::activate (sender=0x21873b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fed8ea1bf7f in QSingleShotTimer::timerEvent (this=0x21873b0) at kernel/qtimer.cpp:308
#19 0x00007fed8ea17789 in QObject::event (this=0x21873b0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fed8d03b424 in notify_helper (e=0x7fff7f791290, receiver=0x21873b0, this=0x1f967a0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1f967a0, receiver=0x21873b0, e=0x7fff7f791290) at kernel/qapplication.cpp:4458
#22 0x00007fed8d040291 in QApplication::notify (this=0x7fff7f791590, receiver=0x21873b0, e=0x7fff7f791290) at kernel/qapplication.cpp:4365
#23 0x00007fed8e21f126 in KApplication::notify (this=0x7fff7f791590, receiver=0x21873b0, event=0x7fff7f791290) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fed8ea00afc in QCoreApplication::notifyInternal (this=0x7fff7f791590, receiver=0x21873b0, event=0x7fff7f791290) at kernel/qcoreapplication.cpp:787
#25 0x00007fed8ea2dd62 in sendEvent (event=0x7fff7f791290, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1f928d0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fed8ea2b514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fed890e3a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fed890e4258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fed890e4429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fed8ea2bed6 in QEventDispatcherGlib::processEvents (this=0x1f6d6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fed8d0e307e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fed8e9ffcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fed8e9ffef7 in QEventLoop::exec (this=0x7fff7f791520, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fed8ea04789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff7f791808) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291365, bug 291363, bug 291353, bug 291339, bug 291335.

Reported using DrKonqi
Comment 1 Thijs 2012-01-12 12:50:09 UTC

*** This bug has been marked as a duplicate of bug 291262 ***