Bug 291365 - Muon Software Center Failed to Launch
Summary: Muon Software Center Failed to Launch
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 12:05 UTC by mikemanzella
Modified: 2012-01-12 12:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikemanzella 2012-01-12 12:05:11 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Nothing.
Tried to launch the Muon Software Center first thing after starting PC

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa13e2a7780 (LWP 3068))]

Thread 2 (Thread 0x7fa12a083700 (LWP 3069)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fa12a082af0 in ?? ()
#2  0x00007fff237ff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7fa13e2a7780 (LWP 3068)):
[KCrash Handler]
#6  0x00007fa13cf71a5e in QtPrivate::QStringList_contains (that=0x7fff23776ec0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff23776ec0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1131d60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1131d60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff23777490) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fa13d01deba in QMetaObject::activate (sender=0x11d99b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x11d99b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff237775f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fa13d01deba in QMetaObject::activate (sender=0x1131d60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff237775f0) at kernel/qobject.cpp:3278
#13 0x00007fa13de90e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x103ca30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fa13de90f8e in MuonMainWindow::initObject (this=0x1131d60) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1131d60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1131d60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff237776c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fa13d01deba in QMetaObject::activate (sender=0x11caa10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fa13d025f7f in QSingleShotTimer::timerEvent (this=0x11caa10) at kernel/qtimer.cpp:308
#19 0x00007fa13d021789 in QObject::event (this=0x11caa10, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fa13b645424 in notify_helper (e=0x7fff23777c30, receiver=0x11caa10, this=0x104a0f0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x104a0f0, receiver=0x11caa10, e=0x7fff23777c30) at kernel/qapplication.cpp:4458
#22 0x00007fa13b64a291 in QApplication::notify (this=0x7fff23777f30, receiver=0x11caa10, e=0x7fff23777c30) at kernel/qapplication.cpp:4365
#23 0x00007fa13c829126 in KApplication::notify (this=0x7fff23777f30, receiver=0x11caa10, event=0x7fff23777c30) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fa13d00aafc in QCoreApplication::notifyInternal (this=0x7fff23777f30, receiver=0x11caa10, event=0x7fff23777c30) at kernel/qcoreapplication.cpp:787
#25 0x00007fa13d037d62 in sendEvent (event=0x7fff23777c30, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1046150) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fa13d035514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fa1376eda5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fa1376ee258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fa1376ee429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fa13d035ed6 in QEventDispatcherGlib::processEvents (this=0x10216f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fa13b6ed07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fa13d009cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fa13d009ef7 in QEventLoop::exec (this=0x7fff23777ec0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fa13d00e789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff237781a8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291363, bug 291353, bug 291339, bug 291335, bug 291329.

Reported using DrKonqi
Comment 1 Thijs 2012-01-12 12:36:05 UTC

*** This bug has been marked as a duplicate of bug 291262 ***