Bug 291339 - Muon Software Center Crashes
Summary: Muon Software Center Crashes
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 07:55 UTC by Jacob
Modified: 2012-01-12 09:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacob 2012-01-12 07:55:27 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Opening Muon Software Center after a few seconds it closes out and opens the crash report assistant

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f59e1c20780 (LWP 2958))]

Thread 2 (Thread 0x7f59cd1fc700 (LWP 2962)):
#0  0x00007f59de7ee773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f59db063f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f59db064429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f59e09abf3e in QEventDispatcherGlib::processEvents (this=0x26752d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f59e097fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f59e097fef7 in QEventLoop::exec (this=0x7f59cd1fbdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f59e089727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f59e0962cbf in QInotifyFileSystemWatcherEngine::run (this=0x266eae0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f59e0899d05 in QThreadPrivate::start (arg=0x266eae0) at thread/qthread_unix.cpp:331
#9  0x00007f59dbb45efc in start_thread (arg=0x7f59cd1fc700) at pthread_create.c:304
#10 0x00007f59de7fa89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f59e1c20780 (LWP 2958)):
[KCrash Handler]
#6  0x00007f59e08e7a5e in QtPrivate::QStringList_contains (that=0x7fff08d1e150, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff08d1e150) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x24a0770) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x24a0770, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff08d1e720) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f59e0993eba in QMetaObject::activate (sender=0x234dbb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x234dbb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff08d1e880) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f59e0993eba in QMetaObject::activate (sender=0x24a0770, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff08d1e880) at kernel/qobject.cpp:3278
#13 0x00007f59e1806e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x24cf2d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f59e1806f8e in MuonMainWindow::initObject (this=0x24a0770) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x24a0770) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x24a0770, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff08d1e950) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f59e0993eba in QMetaObject::activate (sender=0x253a3f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f59e099bf7f in QSingleShotTimer::timerEvent (this=0x253a3f0) at kernel/qtimer.cpp:308
#19 0x00007f59e0997789 in QObject::event (this=0x253a3f0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f59defbb424 in notify_helper (e=0x7fff08d1eec0, receiver=0x253a3f0, this=0x23610f0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x23610f0, receiver=0x253a3f0, e=0x7fff08d1eec0) at kernel/qapplication.cpp:4458
#22 0x00007f59defc0291 in QApplication::notify (this=0x7fff08d1f1c0, receiver=0x253a3f0, e=0x7fff08d1eec0) at kernel/qapplication.cpp:4365
#23 0x00007f59e019f126 in KApplication::notify (this=0x7fff08d1f1c0, receiver=0x253a3f0, event=0x7fff08d1eec0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f59e0980afc in QCoreApplication::notifyInternal (this=0x7fff08d1f1c0, receiver=0x253a3f0, event=0x7fff08d1eec0) at kernel/qcoreapplication.cpp:787
#25 0x00007f59e09add62 in sendEvent (event=0x7fff08d1eec0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x235e1e0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f59e09ab514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f59db063a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f59db064258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f59db064429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f59e09abed6 in QEventDispatcherGlib::processEvents (this=0x23376f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f59df06307e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f59e097fcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f59e097fef7 in QEventLoop::exec (this=0x7fff08d1f150, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f59e0984789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff08d1f438) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291335, bug 291329, bug 291317, bug 291286, bug 291268.

Reported using DrKonqi
Comment 1 Thijs 2012-01-12 09:40:19 UTC

*** This bug has been marked as a duplicate of bug 291262 ***