Bug 291382 - Muon Software Centre crushed on every loading
Summary: Muon Software Centre crushed on every loading
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 16:25 UTC by rainy_sky
Modified: 2012-01-12 16:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rainy_sky 2012-01-12 16:25:58 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Muon Software Centre crushed on every loading

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f6c68c87780 (LWP 5380))]

Thread 2 (Thread 0x7f6c5370c700 (LWP 5382)):
#0  0x00007f6c65859773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6c620cef68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6c620cf792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6c5aa0f516 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f6c620f42b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6c62bb0efc in start_thread (arg=0x7f6c5370c700) at pthread_create.c:304
#6  0x00007f6c6586589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6c68c87780 (LWP 5380)):
[KCrash Handler]
#6  0x00007f6c67952a5e in QtPrivate::QStringList_contains (that=0x7fff66d1c9b0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff66d1c9b0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1f20040) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1f20040, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff66d1cf80) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f6c679feeba in QMetaObject::activate (sender=0x1f22520, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1f22520, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff66d1d0e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f6c679feeba in QMetaObject::activate (sender=0x1f20040, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff66d1d0e0) at kernel/qobject.cpp:3278
#13 0x00007f6c68871e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1f0c900) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f6c68871f8e in MuonMainWindow::initObject (this=0x1f20040) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1f20040) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1f20040, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff66d1d1b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f6c679feeba in QMetaObject::activate (sender=0x1fc5f00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f6c67a06f7f in QSingleShotTimer::timerEvent (this=0x1fc5f00) at kernel/qtimer.cpp:308
#19 0x00007f6c67a02789 in QObject::event (this=0x1fc5f00, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f6c66026424 in notify_helper (e=0x7fff66d1d720, receiver=0x1fc5f00, this=0x1cac5a0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1cac5a0, receiver=0x1fc5f00, e=0x7fff66d1d720) at kernel/qapplication.cpp:4458
#22 0x00007f6c6602b291 in QApplication::notify (this=0x7fff66d1da20, receiver=0x1fc5f00, e=0x7fff66d1d720) at kernel/qapplication.cpp:4365
#23 0x00007f6c6720a126 in KApplication::notify (this=0x7fff66d1da20, receiver=0x1fc5f00, event=0x7fff66d1d720) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f6c679ebafc in QCoreApplication::notifyInternal (this=0x7fff66d1da20, receiver=0x1fc5f00, event=0x7fff66d1d720) at kernel/qcoreapplication.cpp:787
#25 0x00007f6c67a18d62 in sendEvent (event=0x7fff66d1d720, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1cb07f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f6c67a16514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f6c620cea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f6c620cf258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f6c620cf429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f6c67a16ed6 in QEventDispatcherGlib::processEvents (this=0x1c876f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f6c660ce07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f6c679eacf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f6c679eaef7 in QEventLoop::exec (this=0x7fff66d1d9b0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f6c679ef789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff66d1dc98) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291368, bug 291365, bug 291363, bug 291353, bug 291339.

Reported using DrKonqi
Comment 1 Thijs 2012-01-12 16:49:05 UTC

*** This bug has been marked as a duplicate of bug 291262 ***