Bug 291384 - Muon opening crashed
Summary: Muon opening crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 16:59 UTC by Jens Werner
Modified: 2012-01-12 17:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Werner 2012-01-12 16:59:31 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Bevor I try to open Muon, I opend kopete, then closed Kopete, next I closed the news plugin on Taskbar.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb788d930 (LWP 1894))]

Thread 2 (Thread 0xb4064b70 (LWP 1900)):
#0  0x009ad416 in __kernel_vsyscall ()
#1  0x008be40e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x055df34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x055d0896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x055d0c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x006eeb37 in QEventDispatcherGlib::processEvents (this=0x945d540, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x006bf1dd in QEventLoop::processEvents (this=0xb40642b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x006bf421 in QEventLoop::exec (this=0xb40642b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x005c290b in QThread::exec (this=0x95491d0) at thread/qthread.cpp:498
#9  0x0069fe2d in QInotifyFileSystemWatcherEngine::run (this=0x95491d0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x005c57b3 in QThreadPrivate::start (arg=0x95491d0) at thread/qthread_unix.cpp:331
#11 0x00991d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x008cd0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb788d930 (LWP 1894)):
[KCrash Handler]
#7  0x00619e11 in QtPrivate::QStringList_contains (that=0xbf8cf994, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8cf994) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x93de230) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x93de230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8cfbb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x006c6b7d in metacall (argv=0xbf8cfbb4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x93de230) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x93de230, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8cfbb4) at kernel/qmetaobject.cpp:232
#13 0x006d5a6a in QMetaObject::activate (sender=0x93cc0d0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x93cc0d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x93cc0d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8cfcf8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x006c6b7d in metacall (argv=0xbf8cfcf8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x93cc0d0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x93cc0d0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8cfcf8) at kernel/qmetaobject.cpp:232
#18 0x006d5a6a in QMetaObject::activate (sender=0x93de230, m=0x80950c0, local_signal_index=0, argv=0xbf8cfcf8) at kernel/qobject.cpp:3278
#19 0x00bb07c5 in MuonMainWindow::backendReady (this=0x93de230, _t1=0x9312a88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00bb0933 in MuonMainWindow::initObject (this=0x93de230) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x93de230) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x93de230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8cfe24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x006c6b7d in metacall (argv=0xbf8cfe24, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x93de230) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x93de230, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf8cfe24) at kernel/qmetaobject.cpp:232
#25 0x006d5a6a in QMetaObject::activate (sender=0x944ff18, m=0x7f6238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x006dd375 in QSingleShotTimer::timeout (this=0x944ff18) at .moc/release-shared/qtimer.moc:82
#27 0x006dd42c in QSingleShotTimer::timerEvent (this=0x944ff18) at kernel/qtimer.cpp:308
#28 0x006d8994 in QObject::event (this=0x944ff18, e=0xbf8d021c) at kernel/qobject.cpp:1181
#29 0x0141cd54 in notify_helper (e=0xbf8d021c, receiver=0x944ff18, this=0x9314168) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9314168, receiver=0x944ff18, e=0xbf8d021c) at kernel/qapplication.cpp:4458
#31 0x01422103 in QApplication::notify (this=0xbf8d021c, receiver=0x944ff18, e=0xbf8d021c) at kernel/qapplication.cpp:3886
#32 0x01073681 in KApplication::notify (this=0xbf8d0530, receiver=0x944ff18, event=0xbf8d021c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x006c019e in QCoreApplication::notifyInternal (this=0xbf8d0530, receiver=0x944ff18, event=0xbf8d021c) at kernel/qcoreapplication.cpp:787
#34 0x006f0c10 in sendEvent (event=0xbf8d021c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x931338c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x006ee122 in timerSourceDispatch (source=0x9313358) at kernel/qeventdispatcher_glib.cpp:184
#37 0x055d025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x055d0990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x055d0c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x006eeada in QEventDispatcherGlib::processEvents (this=0x92f6238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x014d4e3a in QGuiEventDispatcherGlib::processEvents (this=0x92f6238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x006bf1dd in QEventLoop::processEvents (this=0xbf8d0494, flags=...) at kernel/qeventloop.cpp:149
#43 0x006bf421 in QEventLoop::exec (this=0xbf8d0494, flags=...) at kernel/qeventloop.cpp:201
#44 0x006c419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0141a8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291382, bug 291368, bug 291365, bug 291363, bug 291353.

Reported using DrKonqi
Comment 1 Thijs 2012-01-12 17:18:13 UTC

*** This bug has been marked as a duplicate of bug 291262 ***