Bug 291335 - Muon crash
Summary: Muon crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 06:38 UTC by Paavo Suhonen
Modified: 2012-01-12 09:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.29 KB, text/plain)
2012-01-12 07:33 UTC, grahamt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paavo Suhonen 2012-01-12 06:38:37 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Crashes repeatedly and consistently on startup, the window borders start śhow for a second before the crash but no content.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb47a4930 (LWP 1995))]

Thread 2 (Thread 0xb2367b70 (LWP 1996)):
#0  0xb7731424 in __kernel_vsyscall ()
#1  0xb5d5c40e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb524734b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb5238896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5238c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb729eb37 in QEventDispatcherGlib::processEvents (this=0xa0d07d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb726f1dd in QEventLoop::processEvents (this=0xb23672b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb726f421 in QEventLoop::exec (this=0xb23672b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb717290b in QThread::exec (this=0xa0887f0) at thread/qthread.cpp:498
#9  0xb724fe2d in QInotifyFileSystemWatcherEngine::run (this=0xa0887f0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb71757b3 in QThreadPrivate::start (arg=0xa0887f0) at thread/qthread_unix.cpp:331
#11 0xb531ed31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5d6b0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb47a4930 (LWP 1995)):
[KCrash Handler]
#7  0xb71c9e11 in QtPrivate::QStringList_contains (that=0xbfc5da04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc5da04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa070768) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa070768, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc5dc24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7276b7d in metacall (argv=0xbfc5dc24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa070768) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa070768, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc5dc24) at kernel/qmetaobject.cpp:232
#13 0xb7285a6a in QMetaObject::activate (sender=0xa115db0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa115db0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa115db0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc5dd68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7276b7d in metacall (argv=0xbfc5dd68, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa115db0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa115db0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc5dd68) at kernel/qmetaobject.cpp:232
#18 0xb7285a6a in QMetaObject::activate (sender=0xa070768, m=0x80950c0, local_signal_index=0, argv=0xbfc5dd68) at kernel/qobject.cpp:3278
#19 0xb76e47c5 in MuonMainWindow::backendReady (this=0xa070768, _t1=0x9feace8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb76e4933 in MuonMainWindow::initObject (this=0xa070768) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa070768) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa070768, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc5de94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7276b7d in metacall (argv=0xbfc5de94, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa070768) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa070768, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc5de94) at kernel/qmetaobject.cpp:232
#25 0xb7285a6a in QMetaObject::activate (sender=0xa0e5c20, m=0xb73a6238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb728d375 in QSingleShotTimer::timeout (this=0xa0e5c20) at .moc/release-shared/qtimer.moc:82
#27 0xb728d42c in QSingleShotTimer::timerEvent (this=0xa0e5c20) at kernel/qtimer.cpp:308
#28 0xb7288994 in QObject::event (this=0xa0e5c20, e=0xbfc5e28c) at kernel/qobject.cpp:1181
#29 0xb6057d54 in notify_helper (e=0xbfc5e28c, receiver=0xa0e5c20, this=0x9f70dc0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9f70dc0, receiver=0xa0e5c20, e=0xbfc5e28c) at kernel/qapplication.cpp:4458
#31 0xb605d103 in QApplication::notify (this=0xbfc5e28c, receiver=0xa0e5c20, e=0xbfc5e28c) at kernel/qapplication.cpp:3886
#32 0xb6e76681 in KApplication::notify (this=0xbfc5e5a0, receiver=0xa0e5c20, event=0xbfc5e28c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb727019e in QCoreApplication::notifyInternal (this=0xbfc5e5a0, receiver=0xa0e5c20, event=0xbfc5e28c) at kernel/qcoreapplication.cpp:787
#34 0xb72a0c10 in sendEvent (event=0xbfc5e28c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9f6b724) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb729e122 in timerSourceDispatch (source=0x9f6b6f0) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb523825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb5238990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb5238c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb729eada in QEventDispatcherGlib::processEvents (this=0x9f4c238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb610fe3a in QGuiEventDispatcherGlib::processEvents (this=0x9f4c238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb726f1dd in QEventLoop::processEvents (this=0xbfc5e504, flags=...) at kernel/qeventloop.cpp:149
#43 0xb726f421 in QEventLoop::exec (this=0xbfc5e504, flags=...) at kernel/qeventloop.cpp:201
#44 0xb727419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb60558f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291329, bug 291317, bug 291286, bug 291268, bug 291267.

Reported using DrKonqi
Comment 1 grahamt 2012-01-12 07:33:09 UTC
Created attachment 67726 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

Fresh Launch of Muon from the K Menu | Computer | Muon Software Centre menu item

-- Backtrace (Reduced):
#7  0x004e7e11 in QtPrivate::QStringList_contains (that=0xbfd9b934, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd9b934) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x921f028) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x921f028, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd9bb54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00594b7d in metacall (argv=0xbfd9bb54, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x921f028) at kernel/qmetaobject.cpp:237
Comment 2 Thijs 2012-01-12 09:40:40 UTC

*** This bug has been marked as a duplicate of bug 291262 ***