Bug 291329 - software center crash
Summary: software center crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-12 03:08 UTC by Rick
Modified: 2012-01-12 03:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rick 2012-01-12 03:08:53 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
only just opened the program.  There was kopete open and that is all.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe1bc89f780 (LWP 1972))]

Thread 2 (Thread 0x7fe1a7fec700 (LWP 1973)):
#0  0x00007fe1b946a773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe1b5cdff68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe1b5ce0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe1bb627f3e in QEventDispatcherGlib::processEvents (this=0xddb9a0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe1bb5fbcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe1bb5fbef7 in QEventLoop::exec (this=0x7fe1a7febdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe1bb51327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fe1bb5decbf in QInotifyFileSystemWatcherEngine::run (this=0xe3b520) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe1bb515d05 in QThreadPrivate::start (arg=0xe3b520) at thread/qthread_unix.cpp:331
#9  0x00007fe1b67c1efc in start_thread (arg=0x7fe1a7fec700) at pthread_create.c:304
#10 0x00007fe1b947689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe1bc89f780 (LWP 1972)):
[KCrash Handler]
#6  0x00007fe1bb563a5e in QtPrivate::QStringList_contains (that=0x7fff5e213300, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff5e213300) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xd66920) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xd66920, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5e2138d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fe1bb60feba in QMetaObject::activate (sender=0xdea280, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xdea280, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5e213a30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fe1bb60feba in QMetaObject::activate (sender=0xd66920, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff5e213a30) at kernel/qobject.cpp:3278
#13 0x00007fe1bc482e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xdc4220) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fe1bc482f8e in MuonMainWindow::initObject (this=0xd66920) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xd66920) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xd66920, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5e213b00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fe1bb60feba in QMetaObject::activate (sender=0xe1b6b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fe1bb617f7f in QSingleShotTimer::timerEvent (this=0xe1b6b0) at kernel/qtimer.cpp:308
#19 0x00007fe1bb613789 in QObject::event (this=0xe1b6b0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fe1b9c37424 in notify_helper (e=0x7fff5e214070, receiver=0xe1b6b0, this=0xc277c0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xc277c0, receiver=0xe1b6b0, e=0x7fff5e214070) at kernel/qapplication.cpp:4458
#22 0x00007fe1b9c3c291 in QApplication::notify (this=0x7fff5e214370, receiver=0xe1b6b0, e=0x7fff5e214070) at kernel/qapplication.cpp:4365
#23 0x00007fe1bae1b126 in KApplication::notify (this=0x7fff5e214370, receiver=0xe1b6b0, event=0x7fff5e214070) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fe1bb5fcafc in QCoreApplication::notifyInternal (this=0x7fff5e214370, receiver=0xe1b6b0, event=0x7fff5e214070) at kernel/qcoreapplication.cpp:787
#25 0x00007fe1bb629d62 in sendEvent (event=0x7fff5e214070, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xc23c10) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fe1bb627514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fe1b5cdfa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fe1b5ce0258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fe1b5ce0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fe1bb627ed6 in QEventDispatcherGlib::processEvents (this=0xbff6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fe1b9cdf07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fe1bb5fbcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fe1bb5fbef7 in QEventLoop::exec (this=0x7fff5e214300, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fe1bb600789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff5e2145e8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291317, bug 291286, bug 291268, bug 291267, bug 291266.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-01-12 03:58:33 UTC

*** This bug has been marked as a duplicate of bug 291262 ***