Bug 291317 - Muon crashes on start
Summary: Muon crashes on start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-11 23:14 UTC by Sabine Mill
Modified: 2012-01-17 15:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.24 KB, text/plain)
2012-01-17 15:57 UTC, George S. Wardlow
Details
New crash information added by DrKonqi (6.24 KB, text/plain)
2012-01-17 15:57 UTC, George S. Wardlow
Details
New crash information added by DrKonqi (6.24 KB, text/plain)
2012-01-17 15:57 UTC, George S. Wardlow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sabine Mill 2012-01-11 23:14:35 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: starting muon. Happens independent to what other program (Amarok, firefox,..) runs or not

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb775b930 (LWP 9934))]

Thread 2 (Thread 0xb548fb70 (LWP 9938)):
#0  0x00da8dc6 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x037d3f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x014ec70b in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x014ed637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x014edc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x005f3b37 in QEventDispatcherGlib::processEvents (this=0x89f5dc0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x005c41dd in QEventLoop::processEvents (this=0xb548f2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x005c4421 in QEventLoop::exec (this=0xb548f2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x004c790b in QThread::exec (this=0x89fd3f0) at thread/qthread.cpp:498
#9  0x005a4e2d in QInotifyFileSystemWatcherEngine::run (this=0x89fd3f0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x004ca7b3 in QThreadPrivate::start (arg=0x89fd3f0) at thread/qthread_unix.cpp:331
#11 0x00da6d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x037c60ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb775b930 (LWP 9934)):
[KCrash Handler]
#7  0x0051ee11 in QtPrivate::QStringList_contains (that=0xbf84f664, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf84f664) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x88988f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x88988f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf84f884) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x005cbb7d in metacall (argv=0xbf84f884, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x88988f8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x88988f8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf84f884) at kernel/qmetaobject.cpp:232
#13 0x005daa6a in QMetaObject::activate (sender=0x8a3c8f0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8a3c8f0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8a3c8f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf84f9c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x005cbb7d in metacall (argv=0xbf84f9c8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8a3c8f0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8a3c8f0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf84f9c8) at kernel/qmetaobject.cpp:232
#18 0x005daa6a in QMetaObject::activate (sender=0x88988f8, m=0x80950c0, local_signal_index=0, argv=0xbf84f9c8) at kernel/qobject.cpp:3278
#19 0x001457c5 in MuonMainWindow::backendReady (this=0x88988f8, _t1=0x88a2838) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00145933 in MuonMainWindow::initObject (this=0x88988f8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x88988f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x88988f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf84faf4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x005cbb7d in metacall (argv=0xbf84faf4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x88988f8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x88988f8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf84faf4) at kernel/qmetaobject.cpp:232
#25 0x005daa6a in QMetaObject::activate (sender=0x89f71e8, m=0x6fb238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x005e2375 in QSingleShotTimer::timeout (this=0x89f71e8) at .moc/release-shared/qtimer.moc:82
#27 0x005e242c in QSingleShotTimer::timerEvent (this=0x89f71e8) at kernel/qtimer.cpp:308
#28 0x005dd994 in QObject::event (this=0x89f71e8, e=0xbf84feec) at kernel/qobject.cpp:1181
#29 0x05d96d54 in notify_helper (e=0xbf84feec, receiver=0x89f71e8, this=0x88960d8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x88960d8, receiver=0x89f71e8, e=0xbf84feec) at kernel/qapplication.cpp:4458
#31 0x05d9c103 in QApplication::notify (this=0xbf84feec, receiver=0x89f71e8, e=0xbf84feec) at kernel/qapplication.cpp:3886
#32 0x00928681 in KApplication::notify (this=0xbf850200, receiver=0x89f71e8, event=0xbf84feec) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x005c519e in QCoreApplication::notifyInternal (this=0xbf850200, receiver=0x89f71e8, event=0xbf84feec) at kernel/qcoreapplication.cpp:787
#34 0x005f5c10 in sendEvent (event=0xbf84feec, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x888f234) at kernel/qeventdispatcher_unix.cpp:603
#36 0x005f3122 in timerSourceDispatch (source=0x888f200) at kernel/qeventdispatcher_glib.cpp:184
#37 0x014ed25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x014ed990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x014edc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x005f3ada in QEventDispatcherGlib::processEvents (this=0x8870238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05e4ee3a in QGuiEventDispatcherGlib::processEvents (this=0x8870238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005c41dd in QEventLoop::processEvents (this=0xbf850164, flags=...) at kernel/qeventloop.cpp:149
#43 0x005c4421 in QEventLoop::exec (this=0xbf850164, flags=...) at kernel/qeventloop.cpp:201
#44 0x005c919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05d948f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291286, bug 291268, bug 291267, bug 291266.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-01-11 23:25:03 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 George S. Wardlow 2012-01-17 15:57:26 UTC
Created attachment 67928 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: I had just installed two updates from muon package manager and then went to muon software manager and it crashed every time i tried to open it, this has happened before if i reboot it usually fixes it, I have been running Kubuntu 11.10 for three months.

-- Backtrace (Reduced):
#6  0x00007f2b8ab1ca5e in QtPrivate::QStringList_contains (that=0x7fffca675830, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffca675830) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x86ab90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x86ab90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffca675e00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x896580, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffca675f60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 3 George S. Wardlow 2012-01-17 15:57:27 UTC
Created attachment 67929 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: I had just installed two updates from muon package manager and then went to muon software manager and it crashed every time i tried to open it, this has happened before if i reboot it usually fixes it, I have been running Kubuntu 11.10 for three months.

-- Backtrace (Reduced):
#6  0x00007f2b8ab1ca5e in QtPrivate::QStringList_contains (that=0x7fffca675830, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffca675830) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x86ab90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x86ab90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffca675e00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x896580, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffca675f60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 4 George S. Wardlow 2012-01-17 15:57:27 UTC
Created attachment 67930 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: I had just installed two updates from muon package manager and then went to muon software manager and it crashed every time i tried to open it, this has happened before if i reboot it usually fixes it, I have been running Kubuntu 11.10 for three months.

-- Backtrace (Reduced):
#6  0x00007f2b8ab1ca5e in QtPrivate::QStringList_contains (that=0x7fffca675830, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffca675830) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x86ab90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x86ab90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffca675e00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x896580, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffca675f60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109