Bug 291286 - Muon Software Manager Crash
Summary: Muon Software Manager Crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-11 18:49 UTC by Alex
Modified: 2012-01-11 22:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.00 KB, text/plain)
2012-01-11 21:29 UTC, David Engraf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2012-01-11 18:49:29 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Just tried to open it. The window popped up then got a seg fault.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f37276e3780 (LWP 18367))]

Thread 2 (Thread 0x7f3712e33700 (LWP 18368)):
#0  0x00007f37242b1773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3720b26f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3720b27429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f372646ef3e in QEventDispatcherGlib::processEvents (this=0xb9c620, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f3726442cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3726442ef7 in QEventLoop::exec (this=0x7f3712e32dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f372635a27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f3726425cbf in QInotifyFileSystemWatcherEngine::run (this=0xbfcf40) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f372635cd05 in QThreadPrivate::start (arg=0xbfcf40) at thread/qthread_unix.cpp:331
#9  0x00007f3721608efc in start_thread (arg=0x7f3712e33700) at pthread_create.c:304
#10 0x00007f37242bd89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f37276e3780 (LWP 18367)):
[KCrash Handler]
#6  0x00007f37263aaa5e in QtPrivate::QStringList_contains (that=0x7fff279ae8e0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff279ae8e0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xb50770) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xb50770, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff279aeeb0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f3726456eba in QMetaObject::activate (sender=0xc31770, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xc31770, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff279af010) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f3726456eba in QMetaObject::activate (sender=0xb50770, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff279af010) at kernel/qobject.cpp:3278
#13 0x00007f37272c9e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xbb6260) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f37272c9f8e in MuonMainWindow::initObject (this=0xb50770) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xb50770) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xb50770, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff279af0e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f3726456eba in QMetaObject::activate (sender=0xbd8340, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f372645ef7f in QSingleShotTimer::timerEvent (this=0xbd8340) at kernel/qtimer.cpp:308
#19 0x00007f372645a789 in QObject::event (this=0xbd8340, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f3724a7e424 in notify_helper (e=0x7fff279af650, receiver=0xbd8340, this=0xa1cba0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xa1cba0, receiver=0xbd8340, e=0x7fff279af650) at kernel/qapplication.cpp:4458
#22 0x00007f3724a83291 in QApplication::notify (this=0x7fff279af950, receiver=0xbd8340, e=0x7fff279af650) at kernel/qapplication.cpp:4365
#23 0x00007f3725c62126 in KApplication::notify (this=0x7fff279af950, receiver=0xbd8340, event=0x7fff279af650) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f3726443afc in QCoreApplication::notifyInternal (this=0x7fff279af950, receiver=0xbd8340, event=0x7fff279af650) at kernel/qcoreapplication.cpp:787
#25 0x00007f3726470d62 in sendEvent (event=0x7fff279af650, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xa18910) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f372646e514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f3720b26a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f3720b27258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f3720b27429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f372646eed6 in QEventDispatcherGlib::processEvents (this=0x9f46f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f3724b2607e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f3726442cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f3726442ef7 in QEventLoop::exec (this=0x7fff279af8e0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f3726447789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff279afbc8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291268.

Possible duplicates by query: bug 291268, bug 291267, bug 291266.

Reported using DrKonqi
Comment 1 David Engraf 2012-01-11 21:29:26 UTC
Created attachment 67715 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

Happens always when starting the application.

-- Backtrace (Reduced):
#6  0x00007f331b54da5e in QtPrivate::QStringList_contains (that=0x7fff5e908040, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff5e908040) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x20c5270) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x20c5270, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5e908610) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x212e010, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5e908770) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 2 Christoph Feck 2012-01-11 21:58:11 UTC

*** This bug has been marked as a duplicate of bug 291262 ***