Bug 285299 - Muon crashes on uninstall.
Summary: Muon crashes on uninstall.
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-30 07:31 UTC by underline
Modified: 2011-10-30 09:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description underline 2011-10-30 07:31:19 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was uninstalling LibreOffice applications and made quick clicks when performing uninstallation.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8c0e18c780 (LWP 2482))]

Thread 2 (Thread 0x7f8bf939c700 (LWP 2485)):
#0  0x00007f8c0ad6a773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8c075dff68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8c075e0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8c0cf27f3e in QEventDispatcherGlib::processEvents (this=0x1e0e850, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f8c0cefbcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8c0cefbef7 in QEventLoop::exec (this=0x7f8bf939bdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f8c0ce1327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f8c0cedecbf in QInotifyFileSystemWatcherEngine::run (this=0x1e0e6d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8c0ce15d05 in QThreadPrivate::start (arg=0x1e0e6d0) at thread/qthread_unix.cpp:331
#9  0x00007f8c080c1efc in start_thread (arg=0x7f8bf939c700) at pthread_create.c:304
#10 0x00007f8c0ad7689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8c0e18c780 (LWP 2482)):
[KCrash Handler]
#6  value (akey=..., this=0x2586138) at /usr/include/qt4/QtCore/qhash.h:607
#7  Application::getField (this=0x2586130, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#8  0x000000000041d0dd in Application::untranslatedName (this=0x2586130) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#9  0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#10 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0x1dabeb0, job=0x4272b40) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#11 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0x1dabeb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe5b290c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#12 0x00007f8c0cf0feba in QMetaObject::activate (sender=0x4272b40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe5b290c0) at kernel/qobject.cpp:3278
#13 0x00007f8c0c14b5b2 in KJob::result (this=<optimized out>, _t1=0x4272b40) at ./kjob.moc:194
#14 0x00007f8c0c14b5f0 in KJob::emitResult (this=0x4272b40) at ../../kdecore/jobs/kjob.cpp:312
#15 0x00007f8c0d9a1a4a in KIO::FileCopyJob::slotResult (this=0x4272b40, job=0x37dfc30) at ../../kio/kio/job.cpp:2440
#16 0x00007f8c0d9a17f0 in KIO::FileCopyJob::qt_metacall (this=0x4272b40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe5b29230) at ./jobclasses.moc:724
#17 0x00007f8c0cf0feba in QMetaObject::activate (sender=0x37dfc30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe5b29230) at kernel/qobject.cpp:3278
#18 0x00007f8c0c14b5b2 in KJob::result (this=<optimized out>, _t1=0x37dfc30) at ./kjob.moc:194
#19 0x00007f8c0c14b5f0 in KJob::emitResult (this=0x37dfc30) at ../../kdecore/jobs/kjob.cpp:312
#20 0x00007f8c0d99a2c4 in KIO::SimpleJob::slotFinished (this=0x37dfc30) at ../../kio/kio/job.cpp:494
#21 0x00007f8c0d9a1c9d in KIO::TransferJob::slotFinished (this=0x37dfc30) at ../../kio/kio/job.cpp:1081
#22 0x00007f8c0d9a0601 in KIO::TransferJob::qt_metacall (this=0x37dfc30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe5b295e0) at ./jobclasses.moc:369
#23 0x00007f8c0cf0feba in QMetaObject::activate (sender=0x2b03440, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#24 0x00007f8c0da469c1 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#25 0x00007f8c0da43875 in KIO::SlaveInterface::dispatch (this=0x2b03440) at ../../kio/kio/slaveinterface.cpp:88
#26 0x00007f8c0da36ace in KIO::Slave::gotInput (this=0x2b03440) at ../../kio/kio/slave.cpp:344
#27 0x00007f8c0da3722c in KIO::Slave::qt_metacall (this=0x2b03440, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe5b29a10) at ./slave.moc:82
#28 0x00007f8c0cf0feba in QMetaObject::activate (sender=0x2cfd030, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#29 0x00007f8c0d96b3a7 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#30 KIO::ConnectionPrivate::dequeue (this=0x4216740) at ../../kio/kio/connection.cpp:71
#31 0x00007f8c0d96b44d in KIO::Connection::qt_metacall (this=0x2cfd030, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x3f20b20) at ./connection.moc:79
#32 0x00007f8c0cf13a5e in QObject::event (this=0x2cfd030, e=<optimized out>) at kernel/qobject.cpp:1217
#33 0x00007f8c0b537424 in notify_helper (e=0x2c5a870, receiver=0x2cfd030, this=0x1bee480) at kernel/qapplication.cpp:4486
#34 QApplicationPrivate::notify_helper (this=0x1bee480, receiver=0x2cfd030, e=0x2c5a870) at kernel/qapplication.cpp:4458
#35 0x00007f8c0b53c291 in QApplication::notify (this=0x7fffe5b2a2c0, receiver=0x2cfd030, e=0x2c5a870) at kernel/qapplication.cpp:4365
#36 0x00007f8c0c71b126 in KApplication::notify (this=0x7fffe5b2a2c0, receiver=0x2cfd030, event=0x2c5a870) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007f8c0cefcafc in QCoreApplication::notifyInternal (this=0x7fffe5b2a2c0, receiver=0x2cfd030, event=0x2c5a870) at kernel/qcoreapplication.cpp:787
#38 0x00007f8c0cf0051f in sendEvent (event=0x2c5a870, receiver=0x2cfd030) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1bc4be0) at kernel/qcoreapplication.cpp:1428
#40 0x00007f8c0cf27a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#42 0x00007f8c075dfa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f8c075e0258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007f8c075e0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f8c0cf27ed6 in QEventDispatcherGlib::processEvents (this=0x1bc66f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#46 0x00007f8c0b5df07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007f8c0cefbcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007f8c0cefbef7 in QEventLoop::exec (this=0x7fffe5b2a250, flags=...) at kernel/qeventloop.cpp:201
#49 0x00007f8c0cf00789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#50 0x000000000041bd67 in main (argc=5, argv=0x7fffe5b2a538) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-30 09:46:42 UTC

*** This bug has been marked as a duplicate of bug 283728 ***