Bug 288070 - kmail2 crash when expand folder
Summary: kmail2 crash when expand folder
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-02 16:14 UTC by Sérgio Basto
Modified: 2011-12-02 16:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sérgio Basto 2011-12-02 16:14:13 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.z590880.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
I don't have kpartwebkit enable , but I still have the crash .

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7aa3bea840 (LWP 18265))]

Thread 4 (Thread 0x7f7a9891f700 (LWP 18273)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000033997973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x339a190f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000033997974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003374a07d90 in start_thread (arg=0x7f7a9891f700) at pthread_create.c:309
#4  0x0000003373eeed0d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f7a9801e700 (LWP 18274)):
#0  0x0000003373ee6373 in poll () from /lib64/libc.so.6
#1  0x0000003376e44f88 in g_main_context_poll (n_fds=1, fds=0x7f7a900013e0, priority=<optimized out>, timeout=3506, context=0x7f7a900009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7f7a900009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x0000003376e4544c in g_main_context_iteration (context=0x7f7a900009a0, may_block=1) at gmain.c:3136
#4  0x000000337cfa6896 in QEventDispatcherGlib::processEvents (this=0x7f7a900008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000337cf76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x000000337cf76ed7 in QEventLoop::exec (this=0x7f7a9801dd40, flags=...) at kernel/qeventloop.cpp:204
#7  0x000000337ce78ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000337ce7bb1b in QThreadPrivate::start (arg=0x73e550) at thread/qthread_unix.cpp:298
#9  0x0000003374a07d90 in start_thread (arg=0x7f7a9801e700) at pthread_create.c:309
#10 0x0000003373eeed0d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f7a448f2700 (LWP 14800)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000337ce7bf8f in wait (time=30000, this=0x7f7a40003030) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f7a40002fa8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000337ce6f55f in QThreadPoolThread::run (this=0x7f7a40007780) at concurrent/qthreadpool.cpp:141
#4  0x000000337ce7bb1b in QThreadPrivate::start (arg=0x7f7a40007780) at thread/qthread_unix.cpp:298
#5  0x0000003374a07d90 in start_thread (arg=0x7f7a448f2700) at pthread_create.c:309
#6  0x0000003373eeed0d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f7aa3bea840 (LWP 18265)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xde80530, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000033812f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xde80530, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x000000337cf909e6 in QObject::event (this=0xde80530, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x000000337edc96f4 in notify_helper (e=0x7f7a30006fc0, receiver=0xde80530, this=0x726ed0) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x726ed0, receiver=0xde80530, e=0x7f7a30006fc0) at kernel/qapplication.cpp:4490
#11 0x000000337edce573 in QApplication::notify (this=0x7fffcae49600, receiver=0xde80530, e=0x7f7a30006fc0) at kernel/qapplication.cpp:4379
#12 0x0000003385a50396 in KApplication::notify (this=0x7fffcae49600, receiver=0xde80530, event=0x7f7a30006fc0) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#13 0x000000337cf77b4c in QCoreApplication::notifyInternal (this=0x7fffcae49600, receiver=0xde80530, event=0x7f7a30006fc0) at kernel/qcoreapplication.cpp:876
#14 0x000000337cf7b5da in sendEvent (event=0x7f7a30006fc0, receiver=0xde80530) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6f5050) at kernel/qcoreapplication.cpp:1500
#16 0x000000337cfa6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x734830) at kernel/qeventdispatcher_glib.cpp:279
#18 0x0000003376e44a7d in g_main_dispatch (context=0x728d00) at gmain.c:2425
#19 g_main_context_dispatch (context=0x728d00) at gmain.c:2995
#20 0x0000003376e45278 in g_main_context_iterate (context=0x728d00, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x0000003376e4544c in g_main_context_iteration (context=0x728d00, may_block=1) at gmain.c:3136
#22 0x000000337cfa682f in QEventDispatcherGlib::processEvents (this=0x6f6510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x000000337ee6c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x000000337cf76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x000000337cf76ed7 in QEventLoop::exec (this=0x7fffcae49590, flags=...) at kernel/qeventloop.cpp:204
#26 0x000000337cf7b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fffcae49c28) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 283657.

Possible duplicates by query: bug 288015, bug 287929, bug 287926, bug 287874, bug 287870.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-02 16:39:54 UTC

*** This bug has been marked as a duplicate of bug 286307 ***