Bug 287870 - Kmail2 crash when i'm Filtre messages
Summary: Kmail2 crash when i'm Filtre messages
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-29 21:50 UTC by didier.garde
Modified: 2011-11-30 23:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description didier.garde 2011-11-29 21:50:14 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
when i type CTRL + J (filter) Kmail2 crash (and with Kontact)

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcd2e071840 (LWP 5072))]

Thread 3 (Thread 0x7fcd22f89700 (LWP 5073)):
#0  0x0000003efee0bad5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003f241973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3f24b90f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003f241974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003efee07d90 in start_thread () from /lib64/libpthread.so.0
#4  0x0000003efe6eed0d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fcd22670700 (LWP 5074)):
#0  0x0000003efe6e6373 in poll () from /lib64/libc.so.6
#1  0x0000003f01244f88 in g_main_context_poll (n_fds=1, fds=0x7fcd1c0013e0, priority=<optimized out>, timeout=7736, context=0x7fcd1c0009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7fcd1c0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x0000003f0124544c in g_main_context_iteration (context=0x7fcd1c0009a0, may_block=1) at gmain.c:3136
#4  0x0000003f0afa6896 in QEventDispatcherGlib::processEvents (this=0x7fcd1c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003f0af76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003f0af76ed7 in QEventLoop::exec (this=0x7fcd2266fd40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003f0ae78ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003f0ae7bb1b in QThreadPrivate::start (arg=0x1070520) at thread/qthread_unix.cpp:298
#9  0x0000003efee07d90 in start_thread () from /lib64/libpthread.so.0
#10 0x0000003efe6eed0d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fcd2e071840 (LWP 5072)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x2a4e220, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x0000003f0bcf4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x2a4e220, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003f0af909e6 in QObject::event (this=0x2a4e220, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x0000003f0d3c96f4 in notify_helper (e=0x7fccc8014ab0, receiver=0x2a4e220, this=0xefd0a0) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0xefd0a0, receiver=0x2a4e220, e=0x7fccc8014ab0) at kernel/qapplication.cpp:4490
#11 0x0000003f0d3ce573 in QApplication::notify (this=0x7fff7130fa50, receiver=0x2a4e220, e=0x7fccc8014ab0) at kernel/qapplication.cpp:4379
#12 0x0000003f0e250396 in KApplication::notify (this=0x7fff7130fa50, receiver=0x2a4e220, event=0x7fccc8014ab0) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#13 0x0000003f0af77b4c in QCoreApplication::notifyInternal (this=0x7fff7130fa50, receiver=0x2a4e220, event=0x7fccc8014ab0) at kernel/qcoreapplication.cpp:876
#14 0x0000003f0af7b5da in sendEvent (event=0x7fccc8014ab0, receiver=0x2a4e220) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xec0070) at kernel/qcoreapplication.cpp:1500
#16 0x0000003f0afa6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0xeef4f0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x0000003f01244a7d in g_main_dispatch (context=0xeef400) at gmain.c:2425
#19 g_main_context_dispatch (context=0xeef400) at gmain.c:2995
#20 0x0000003f01245278 in g_main_context_iterate (context=0xeef400, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x0000003f0124544c in g_main_context_iteration (context=0xeef400, may_block=1) at gmain.c:3136
#22 0x0000003f0afa682f in QEventDispatcherGlib::processEvents (this=0xec1530, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x0000003f0d46c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x0000003f0af76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x0000003f0af76ed7 in QEventLoop::exec (this=0x7fff7130f9e0, flags=...) at kernel/qeventloop.cpp:204
#26 0x0000003f0af7b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fff71310078) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

Possible duplicates by query: bug 287656, bug 287479, bug 286962, bug 286307.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-11-30 23:27:01 UTC

*** This bug has been marked as a duplicate of bug 286307 ***