Bug 287926 - Kmial crashes while deleting mail
Summary: Kmial crashes while deleting mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-30 17:36 UTC by Chris
Modified: 2011-11-30 23:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2011-11-30 17:36:13 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 2.6.37.6-0.9-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
This may be a duplicate of the crash during a move of email.  I was deleting email.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2f05889760 (LWP 3946))]

Thread 7 (Thread 0x7f2eeda64700 (LWP 3950)):
#0  0x00007f2efd7d938c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2f0208cd74 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f2efd7d4a3f in start_thread () from /lib64/libpthread.so.0
#3  0x00007f2f02dbe66d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f2eed163700 (LWP 3951)):
#0  0x00007f2f02db54f3 in poll () from /lib64/libc.so.6
#1  0x00007f2efc463114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f2efc463650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f2f041f03e6 in QEventDispatcherGlib::processEvents (this=0x6464e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f2f041c0492 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2f041c070d in QEventLoop::exec (this=0x7f2eed162e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f2f040be458 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:501
#7  0x00007f2f040c0b4b in QThreadPrivate::start (arg=0x645b80) at thread/qthread_unix.cpp:298
#8  0x00007f2efd7d4a3f in start_thread () from /lib64/libpthread.so.0
#9  0x00007f2f02dbe66d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f2e9b6da700 (LWP 4021)):
#0  0x00007f2efd7d96f9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2f040c1a23 in wait (this=<value optimized out>, mutex=0x1533ef8, time=30000) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1533ef8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2f040b5060 in QThreadPoolThread::run (this=0x1534160) at concurrent/qthreadpool.cpp:141
#4  0x00007f2f040c0b4b in QThreadPrivate::start (arg=0x1534160) at thread/qthread_unix.cpp:298
#5  0x00007f2efd7d4a3f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f2f02dbe66d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f2e9aed9700 (LWP 4022)):
#0  0x00007f2efd7d96f9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2f040c1a23 in wait (this=<value optimized out>, mutex=0x1533ef8, time=30000) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1533ef8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2f040b5060 in QThreadPoolThread::run (this=0x24f93d0) at concurrent/qthreadpool.cpp:141
#4  0x00007f2f040c0b4b in QThreadPrivate::start (arg=0x24f93d0) at thread/qthread_unix.cpp:298
#5  0x00007f2efd7d4a3f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f2f02dbe66d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f2e9a6d8700 (LWP 4024)):
#0  0x00007f2efd7d96f9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2f040c1a23 in wait (this=<value optimized out>, mutex=0x1533ef8, time=30000) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1533ef8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2f040b5060 in QThreadPoolThread::run (this=0x7f2ee802ebf0) at concurrent/qthreadpool.cpp:141
#4  0x00007f2f040c0b4b in QThreadPrivate::start (arg=0x7f2ee802ebf0) at thread/qthread_unix.cpp:298
#5  0x00007f2efd7d4a3f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f2f02dbe66d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2e99ed7700 (LWP 4026)):
#0  0x00007f2efd7d96f9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2f040c1a23 in wait (this=<value optimized out>, mutex=0x1533ef8, time=30000) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1533ef8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2f040b5060 in QThreadPoolThread::run (this=0x7f2ee8032cd0) at concurrent/qthreadpool.cpp:141
#4  0x00007f2f040c0b4b in QThreadPrivate::start (arg=0x7f2ee8032cd0) at thread/qthread_unix.cpp:298
#5  0x00007f2efd7d4a3f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f2f02dbe66d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2f05889760 (LWP 3946)):
[KCrash Handler]
#6  0x00007f2efe7095d3 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x199f350, hm=<value optimized out>, sc=<value optimized out>, rp=<value optimized out>, pu=<value optimized out>, db=<value optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f2efe78b1f5 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x199f350, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f2f041d5df6 in QObject::event (this=0x199f350, e=<value optimized out>) at kernel/qobject.cpp:1203
#9  0x00007f2f0353b2a4 in QApplicationPrivate::notify_helper (this=0x639140, receiver=0x199f350, e=0x7f2ee807bd90) at kernel/qapplication.cpp:4518
#10 0x00007f2f0354390f in QApplication::notify (this=<value optimized out>, receiver=0x199f350, e=0x7f2ee807bd90) at kernel/qapplication.cpp:4379
#11 0x00007f2f04c34076 in KApplication::notify (this=0x7fff60afea00, receiver=0x199f350, event=0x7f2ee807bd90) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#12 0x00007f2f041c13bc in QCoreApplication::notifyInternal (this=0x7fff60afea00, receiver=0x199f350, event=0x7f2ee807bd90) at kernel/qcoreapplication.cpp:876
#13 0x00007f2f041c49b8 in sendEvent (receiver=0x0, event_type=0, data=0x6128a0) at kernel/qcoreapplication.h:231
#14 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6128a0) at kernel/qcoreapplication.cpp:1500
#15 0x00007f2f041f01f3 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#17 0x00007f2efc462bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#18 0x00007f2efc4633b0 in ?? () from /lib64/libglib-2.0.so.0
#19 0x00007f2efc463650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#20 0x00007f2f041f038f in QEventDispatcherGlib::processEvents (this=0x612160, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#21 0x00007f2f035e140e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#22 0x00007f2f041c0492 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#23 0x00007f2f041c070d in QEventLoop::exec (this=0x7fff60afe950, flags=...) at kernel/qeventloop.cpp:204
#24 0x00007f2f041c4e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#25 0x00000000004041cf in _start ()

Possible duplicates by query: bug 287874, bug 287870, bug 287656, bug 287479, bug 286962.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-11-30 23:26:37 UTC

*** This bug has been marked as a duplicate of bug 286307 ***