Bug 288015 - KMail Crashes when deleting mail
Summary: KMail Crashes when deleting mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-01 20:33 UTC by Jeff Fitzmaurice
Modified: 2011-12-05 09:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.58 KB, text/plain)
2011-12-05 09:52 UTC, Megaherz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Fitzmaurice 2011-12-01 20:33:22 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
I was deleting mail, line by line, using my keyboard delete button.  I can replicate this and KMail will crash every time.  Not sure if KDE is not recogizing the Keyboard.  I'll check that.  Also, not sure if this happens when I use the GUI Trash button.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fb85f74c840 (LWP 26916))]

Thread 8 (Thread 0x7fb854076700 (LWP 26917)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000032203973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3220d90f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000032203974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00000031fd007d90 in start_thread (arg=0x7fb854076700) at pthread_create.c:309
#4  0x00000031fc8eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 7 (Thread 0x7fb853765700 (LWP 26918)):
#0  0x00000031fc8e6373 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000031ff844f88 in g_main_context_poll (n_fds=1, fds=0x7fb84c0013e0, priority=<optimized out>, timeout=6631, context=0x7fb84c0009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7fb84c0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x00000031ff84544c in g_main_context_iteration (context=0x7fb84c0009a0, may_block=1) at gmain.c:3136
#4  0x00000032081a6896 in QEventDispatcherGlib::processEvents (this=0x7fb84c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003208176c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003208176ed7 in QEventLoop::exec (this=0x7fb853764d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003208078ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000320807bb1b in QThreadPrivate::start (arg=0x72e020) at thread/qthread_unix.cpp:298
#9  0x00000031fd007d90 in start_thread (arg=0x7fb853765700) at pthread_create.c:309
#10 0x00000031fc8eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 6 (Thread 0x7fb7f7fff700 (LWP 26931)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000320807bf8f in wait (time=30000, this=0x7fb800002310) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb800002da8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000320806f55f in QThreadPoolThread::run (this=0x7fb7f8005e30) at concurrent/qthreadpool.cpp:141
#4  0x000000320807bb1b in QThreadPrivate::start (arg=0x7fb7f8005e30) at thread/qthread_unix.cpp:298
#5  0x00000031fd007d90 in start_thread (arg=0x7fb7f7fff700) at pthread_create.c:309
#6  0x00000031fc8eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7fb7f77fe700 (LWP 26932)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000320807bf8f in wait (time=30000, this=0x7fb800002310) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb800002da8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000320806f55f in QThreadPoolThread::run (this=0x7fb7f8009f10) at concurrent/qthreadpool.cpp:141
#4  0x000000320807bb1b in QThreadPrivate::start (arg=0x7fb7f8009f10) at thread/qthread_unix.cpp:298
#5  0x00000031fd007d90 in start_thread (arg=0x7fb7f77fe700) at pthread_create.c:309
#6  0x00000031fc8eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7fb7f6ffd700 (LWP 26940)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000320807bf8f in wait (time=30000, this=0x7fb800002310) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb800002da8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000320806f55f in QThreadPoolThread::run (this=0x7fb7f8008fb0) at concurrent/qthreadpool.cpp:141
#4  0x000000320807bb1b in QThreadPrivate::start (arg=0x7fb7f8008fb0) at thread/qthread_unix.cpp:298
#5  0x00000031fd007d90 in start_thread (arg=0x7fb7f6ffd700) at pthread_create.c:309
#6  0x00000031fc8eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fb7f65b6700 (LWP 26956)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000320807bf8f in wait (time=30000, this=0x7fb800002310) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb800002da8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000320806f55f in QThreadPoolThread::run (this=0x7fb7f8016a90) at concurrent/qthreadpool.cpp:141
#4  0x000000320807bb1b in QThreadPrivate::start (arg=0x7fb7f8016a90) at thread/qthread_unix.cpp:298
#5  0x00000031fd007d90 in start_thread (arg=0x7fb7f65b6700) at pthread_create.c:309
#6  0x00000031fc8eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fb7f5db5700 (LWP 26957)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000320807bf8f in wait (time=30000, this=0x7fb800002310) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb800002da8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000320806f55f in QThreadPoolThread::run (this=0x7fb7f801aa00) at concurrent/qthreadpool.cpp:141
#4  0x000000320807bb1b in QThreadPrivate::start (arg=0x7fb7f801aa00) at thread/qthread_unix.cpp:298
#5  0x00000031fd007d90 in start_thread (arg=0x7fb7f5db5700) at pthread_create.c:309
#6  0x00000031fc8eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fb85f74c840 (LWP 26916)):
[KCrash Handler]
#6  0x0000000000000060 in ?? ()
#7  0x0000003208a7053f in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x2fe1500, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#8  0x0000003208af4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x2fe1500, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#9  0x00000032081909e6 in QObject::event (this=0x2fe1500, e=<optimized out>) at kernel/qobject.cpp:1194
#10 0x000000320a1c96f4 in notify_helper (e=0x7fb800015580, receiver=0x2fe1500, this=0x727da0) at kernel/qapplication.cpp:4518
#11 QApplicationPrivate::notify_helper (this=0x727da0, receiver=0x2fe1500, e=0x7fb800015580) at kernel/qapplication.cpp:4490
#12 0x000000320a1ce573 in QApplication::notify (this=0x7fffc2fe60e0, receiver=0x2fe1500, e=0x7fb800015580) at kernel/qapplication.cpp:4379
#13 0x000000320bc50396 in KApplication::notify (this=0x7fffc2fe60e0, receiver=0x2fe1500, event=0x7fb800015580) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#14 0x0000003208177b4c in QCoreApplication::notifyInternal (this=0x7fffc2fe60e0, receiver=0x2fe1500, event=0x7fb800015580) at kernel/qcoreapplication.cpp:876
#15 0x000000320817b5da in sendEvent (event=0x7fb800015580, receiver=0x2fe1500) at kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6f7070) at kernel/qcoreapplication.cpp:1500
#17 0x00000032081a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=0x723980) at kernel/qeventdispatcher_glib.cpp:279
#19 0x00000031ff844a7d in g_main_dispatch (context=0x723890) at gmain.c:2425
#20 g_main_context_dispatch (context=0x723890) at gmain.c:2995
#21 0x00000031ff845278 in g_main_context_iterate (context=0x723890, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#22 0x00000031ff84544c in g_main_context_iteration (context=0x723890, may_block=1) at gmain.c:3136
#23 0x00000032081a682f in QEventDispatcherGlib::processEvents (this=0x6f8530, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#24 0x000000320a26c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#25 0x0000003208176c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x0000003208176ed7 in QEventLoop::exec (this=0x7fffc2fe6070, flags=...) at kernel/qeventloop.cpp:204
#27 0x000000320817b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#28 0x00000000004037b9 in main (argc=1, argv=0x7fffc2fe6708) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

Possible duplicates by query: bug 287929, bug 287926, bug 287874, bug 287870, bug 287656.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-01 21:42:31 UTC

*** This bug has been marked as a duplicate of bug 286307 ***
Comment 2 Megaherz 2011-12-05 09:52:46 UTC
Created attachment 66395 [details]
New crash information added by DrKonqi

kontact (4.7.3) on KDE Platform 4.7.3 (4.7.3) using Qt 4.8.0

- What I was doing when the application crashed:
Kamil crashed when I deleted emails. Pressing "Delete" button on my keyboard causes this.

-- Backtrace (Reduced):
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3b5fbf0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000034d38f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3b5fbf0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00000034d23909e6 in QObject::event (this=0x3b5fbf0, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x00000031b41c96f4 in notify_helper (e=0x7ff3c4005a30, receiver=0x3b5fbf0, this=0x1191fa0) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x1191fa0, receiver=0x3b5fbf0, e=0x7ff3c4005a30) at kernel/qapplication.cpp:4490