Bug 287874 - kmail crash while moving messages
Summary: kmail crash while moving messages
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-30 00:11 UTC by Alan House
Modified: 2011-12-14 09:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan House 2011-11-30 00:11:26 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

I was moving 3 messages from the inbox to a sub-folder of a sub-folder (3rd level) when kmail crashed.. I've moved messages from one folder to another in the past without problems.

Messages where very small and did not have external links.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f518e743840 (LWP 21229))]

Thread 6 (Thread 0x7f518351a700 (LWP 21230)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000033b05973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x33b0f90f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000033b05974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003387607d90 in start_thread (arg=0x7f518351a700) at pthread_create.c:309
#4  0x0000003386aeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7f5182c19700 (LWP 21231)):
#0  0x00007fff9c3b698f in clock_gettime ()
#1  0x0000003387e041f1 in __GI_clock_gettime (clock_id=1, tp=0x7f5182c18ad0) at ../sysdeps/unix/clock_gettime.c:100
#2  0x000000338e6d2004 in do_gettime (frac=0x7f5182c18ae8, sec=0x7f5182c18ae0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x000000338e7a6f9d in QTimerInfoList::updateCurrentTime (this=0x7f517c0020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x000000338e7a72d3 in QTimerInfoList::timerWait (this=0x7f517c0020d0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x000000338e7a5d6c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f5182c18bac) at kernel/qeventdispatcher_glib.cpp:136
#7  0x0000003389644012 in g_main_context_prepare (context=0x7f517c0009a0, priority=0x7f5182c18c18) at gmain.c:2746
#8  0x0000003389644e1d in g_main_context_iterate (context=0x7f517c0009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3053
#9  0x000000338964544c in g_main_context_iteration (context=0x7f517c0009a0, may_block=1) at gmain.c:3136
#10 0x000000338e7a6896 in QEventDispatcherGlib::processEvents (this=0x7f517c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x000000338e776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x000000338e776ed7 in QEventLoop::exec (this=0x7f5182c18d40, flags=...) at kernel/qeventloop.cpp:204
#13 0x000000338e678ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x000000338e67bb1b in QThreadPrivate::start (arg=0xbcc6a0) at thread/qthread_unix.cpp:298
#15 0x0000003387607d90 in start_thread (arg=0x7f5182c19700) at pthread_create.c:309
#16 0x0000003386aeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f5136f87700 (LWP 31182)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000338e67bf8f in wait (time=30000, this=0x7f5130005ec0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f5130005e68, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000338e66f55f in QThreadPoolThread::run (this=0x7f5130006140) at concurrent/qthreadpool.cpp:141
#4  0x000000338e67bb1b in QThreadPrivate::start (arg=0x7f5130006140) at thread/qthread_unix.cpp:298
#5  0x0000003387607d90 in start_thread (arg=0x7f5136f87700) at pthread_create.c:309
#6  0x0000003386aeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f512598e700 (LWP 31183)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000338e67bf8f in wait (time=30000, this=0x7f5130005ec0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f5130005e68, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000338e66f55f in QThreadPoolThread::run (this=0x7f512c016210) at concurrent/qthreadpool.cpp:141
#4  0x000000338e67bb1b in QThreadPrivate::start (arg=0x7f512c016210) at thread/qthread_unix.cpp:298
#5  0x0000003387607d90 in start_thread (arg=0x7f512598e700) at pthread_create.c:309
#6  0x0000003386aeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f512498c700 (LWP 31184)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x000000338e67bf8f in wait (time=30000, this=0x7f5130005ec0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f5130005e68, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x000000338e66f55f in QThreadPoolThread::run (this=0x7f513000a1b0) at concurrent/qthreadpool.cpp:141
#4  0x000000338e67bb1b in QThreadPrivate::start (arg=0x7f513000a1b0) at thread/qthread_unix.cpp:298
#5  0x0000003387607d90 in start_thread (arg=0x7f512498c700) at pthread_create.c:309
#6  0x0000003386aeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f518e743840 (LWP 21229)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff9c2989c0) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff9c298ce0) at access/qabstractnetworkcache.cpp:240
#8  0x000000339266edcc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x637bf40, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x0000003392670564 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x637bf40, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00000033926f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x637bf40, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x000000338e7909e6 in QObject::event (this=0x637bf40, e=<optimized out>) at kernel/qobject.cpp:1194
#12 0x000000338edc96f4 in notify_helper (e=0x7f5130016330, receiver=0x637bf40, this=0x9f8b40) at kernel/qapplication.cpp:4518
#13 QApplicationPrivate::notify_helper (this=0x9f8b40, receiver=0x637bf40, e=0x7f5130016330) at kernel/qapplication.cpp:4490
#14 0x000000338edce573 in QApplication::notify (this=0x7fff9c299760, receiver=0x637bf40, e=0x7f5130016330) at kernel/qapplication.cpp:4379
#15 0x0000003397250396 in KApplication::notify (this=0x7fff9c299760, receiver=0x637bf40, event=0x7f5130016330) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#16 0x000000338e777b4c in QCoreApplication::notifyInternal (this=0x7fff9c299760, receiver=0x637bf40, event=0x7f5130016330) at kernel/qcoreapplication.cpp:876
#17 0x000000338e77b5da in sendEvent (event=0x7f5130016330, receiver=0x637bf40) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9cd050) at kernel/qcoreapplication.cpp:1500
#19 0x000000338e7a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0xa06490) at kernel/qeventdispatcher_glib.cpp:279
#21 0x0000003389644a7d in g_main_dispatch (context=0xa060e0) at gmain.c:2425
#22 g_main_context_dispatch (context=0xa060e0) at gmain.c:2995
#23 0x0000003389645278 in g_main_context_iterate (context=0xa060e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#24 0x000000338964544c in g_main_context_iteration (context=0xa060e0, may_block=1) at gmain.c:3136
#25 0x000000338e7a682f in QEventDispatcherGlib::processEvents (this=0x9ce510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#26 0x000000338ee6c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#27 0x000000338e776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x000000338e776ed7 in QEventLoop::exec (this=0x7fff9c2996f0, flags=...) at kernel/qeventloop.cpp:204
#29 0x000000338e77b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x00000000004037b9 in main (argc=1, argv=0x7fff9c299d88) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-11-30 23:26:47 UTC

*** This bug has been marked as a duplicate of bug 286307 ***
Comment 2 Alan House 2011-12-14 07:40:33 UTC
This is also occurring with version 4.7.4 as well as crashes when reading external links.  Is there a patch for this, if so where do I find it (i've tried googling)
Comment 3 Christophe Giboudeaux 2011-12-14 09:16:15 UTC

*** This bug has been marked as a duplicate of bug 286307 ***