Bug 287929 - KMail crash when applying filters
Summary: KMail crash when applying filters
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-30 17:52 UTC by abenson
Modified: 2011-11-30 23:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abenson 2011-11-30 17:52:31 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed: After adding a new filter, I applied all filters (Ctrl+J) to a message. KMail crashed.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x2b9b8c20f6c0 (LWP 2123))]

Thread 4 (Thread 0x2b9b97bcd700 (LWP 2170)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000361a5973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x361af90f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x000000361a5974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00000035fa207d90 in start_thread (arg=0x2b9b97bcd700) at pthread_create.c:309
#4  0x00000035f96eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x2b9b97ee6700 (LWP 2171)):
#0  0x00000035fa209dd5 in __pthread_mutex_lock (mutex=0x2b9b980009a8) at pthread_mutex_lock.c:65
#1  0x00000035fc244043 in g_main_context_prepare (context=0x2b9b980009a0, priority=0x2b9b97ee5c18) at gmain.c:2748
#2  0x00000035fc244e1d in g_main_context_iterate (context=0x2b9b980009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3053
#3  0x00000035fc24544c in g_main_context_iteration (context=0x2b9b980009a0, may_block=1) at gmain.c:3136
#4  0x00000036047a6896 in QEventDispatcherGlib::processEvents (this=0x2b9b980008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003604776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003604776ed7 in QEventLoop::exec (this=0x2b9b97ee5d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003604678ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000360467bb1b in QThreadPrivate::start (arg=0x21cf3c0) at thread/qthread_unix.cpp:298
#9  0x00000035fa207d90 in start_thread (arg=0x2b9b97ee6700) at pthread_create.c:309
#10 0x00000035f96eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x2b9bec9bb700 (LWP 1392)):
#0  0x00000035f96e6373 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000035fc244f88 in g_main_context_poll (n_fds=1, fds=0x2b9bf4001630, priority=<optimized out>, timeout=-1, context=0x2b9bf40012f0) at gmain.c:3386
#2  g_main_context_iterate (context=0x2b9bf40012f0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x00000035fc24544c in g_main_context_iteration (context=0x2b9bf40012f0, may_block=1) at gmain.c:3136
#4  0x00000036047a6896 in QEventDispatcherGlib::processEvents (this=0x2b9bf400d890, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003604776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003604776ed7 in QEventLoop::exec (this=0x2b9bec9bad10, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003604678ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003604756a5f in QInotifyFileSystemWatcherEngine::run (this=0xd66e050) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x000000360467bb1b in QThreadPrivate::start (arg=0xd66e050) at thread/qthread_unix.cpp:298
#10 0x00000035fa207d90 in start_thread (arg=0x2b9bec9bb700) at pthread_create.c:309
#11 0x00000035f96eed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x2b9b8c20f6c0 (LWP 2123)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xd4197e0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000036054f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xd4197e0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00000036047909e6 in QObject::event (this=0xd4197e0, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x0000003606fc96f4 in notify_helper (e=0x2b9bf000cad0, receiver=0xd4197e0, this=0x21d2aa0) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x21d2aa0, receiver=0xd4197e0, e=0x2b9bf000cad0) at kernel/qapplication.cpp:4490
#11 0x0000003606fce573 in QApplication::notify (this=0x7fff38f695a0, receiver=0xd4197e0, e=0x2b9bf000cad0) at kernel/qapplication.cpp:4379
#12 0x0000003609250396 in KApplication::notify (this=0x7fff38f695a0, receiver=0xd4197e0, event=0x2b9bf000cad0) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#13 0x0000003604777b4c in QCoreApplication::notifyInternal (this=0x7fff38f695a0, receiver=0xd4197e0, event=0x2b9bf000cad0) at kernel/qcoreapplication.cpp:876
#14 0x000000360477b5da in sendEvent (event=0x2b9bf000cad0, receiver=0xd4197e0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x21a4070) at kernel/qcoreapplication.cpp:1500
#16 0x00000036047a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x21d9a70) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00000035fc244a7d in g_main_dispatch (context=0x21d16e0) at gmain.c:2425
#19 g_main_context_dispatch (context=0x21d16e0) at gmain.c:2995
#20 0x00000035fc245278 in g_main_context_iterate (context=0x21d16e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x00000035fc24544c in g_main_context_iteration (context=0x21d16e0, may_block=1) at gmain.c:3136
#22 0x00000036047a682f in QEventDispatcherGlib::processEvents (this=0x21a5530, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x000000360706c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x0000003604776c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x0000003604776ed7 in QEventLoop::exec (this=0x7fff38f69530, flags=...) at kernel/qeventloop.cpp:204
#26 0x000000360477b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fff38f69bc8) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 287870.

Possible duplicates by query: bug 287926, bug 287874, bug 287870, bug 287656, bug 287479.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-11-30 23:26:17 UTC

*** This bug has been marked as a duplicate of bug 286307 ***