Bug 287479 - kwebkitpart makes kmail2 crash
Summary: kwebkitpart makes kmail2 crash
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-24 17:59 UTC by Sérgio Basto
Modified: 2011-11-24 21:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sérgio Basto 2011-11-24 17:59:21 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.2-1.z590880.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
Just try read some html email  

- Custom settings of the application:
this happens with kwebkitpart-1.2-0.2.20111119  enabled on 
konqueror 
https://bugzilla.redhat.com/show_bug.cgi?id=755145#c10
Applying patches from commits 999eac446a49e6126df04aa8717f95e6aef136fc and
63cfec6ddc79703a34c20a7b27f1aadd819da092 to kdelibs-4.7.3-5.fc16 fix some crashes.
This crash is clean of flash11 , so is not flash11 fault.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f71f59fc840 (LWP 17048))]

Thread 5 (Thread 0x7f71ea731700 (LWP 17049)):
#0  0x000000334c80bad5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003371b973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3372590f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003371b974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x000000334c807d90 in start_thread () from /lib64/libpthread.so.0
#4  0x000000334bceed8d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f71e9e30700 (LWP 17050)):
#0  0x000000334bce63f3 in poll () from /lib64/libc.so.6
#1  0x000000334ec44f88 in g_main_context_poll (n_fds=1, fds=0x7f71e40013e0, priority=<optimized out>, timeout=9685, context=0x7f71e40009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7f71e40009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x000000334ec4544c in g_main_context_iteration (context=0x7f71e40009a0, may_block=1) at gmain.c:3136
#4  0x0000003355da6896 in QEventDispatcherGlib::processEvents (this=0x7f71e40008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003355d76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003355d76ed7 in QEventLoop::exec (this=0x7f71e9e2fd40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003355c78ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003355c7bb1b in QThreadPrivate::start (arg=0x1c3c020) at thread/qthread_unix.cpp:298
#9  0x000000334c807d90 in start_thread () from /lib64/libpthread.so.0
#10 0x000000334bceed8d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f719e3d4700 (LWP 17105)):
#0  0x000000334c80be3f in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003355c7bf8f in wait (time=30000, this=0x7f7198005ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f7198005e78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003355c6f55f in QThreadPoolThread::run (this=0x7f7198006120) at concurrent/qthreadpool.cpp:141
#4  0x0000003355c7bb1b in QThreadPrivate::start (arg=0x7f7198006120) at thread/qthread_unix.cpp:298
#5  0x000000334c807d90 in start_thread () from /lib64/libpthread.so.0
#6  0x000000334bceed8d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f719db8e700 (LWP 17106)):
#0  0x000000334c80be3f in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003355c7bf8f in wait (time=30000, this=0x7f7198005ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f7198005e78, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003355c6f55f in QThreadPoolThread::run (this=0x7f719800a0a0) at concurrent/qthreadpool.cpp:141
#4  0x0000003355c7bb1b in QThreadPrivate::start (arg=0x7f719800a0a0) at thread/qthread_unix.cpp:298
#5  0x000000334c807d90 in start_thread () from /lib64/libpthread.so.0
#6  0x000000334bceed8d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f71f59fc840 (LWP 17048)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3395a60, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000033590f4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3395a60, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003355d909e6 in QObject::event (this=0x3395a60, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x00000033567c96f4 in notify_helper (e=0x7f719800caa0, receiver=0x3395a60, this=0x1c29880) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x1c29880, receiver=0x3395a60, e=0x7f719800caa0) at kernel/qapplication.cpp:4490
#11 0x00000033567ce573 in QApplication::notify (this=0x7fff433ebf90, receiver=0x3395a60, e=0x7f719800caa0) at kernel/qapplication.cpp:4379
#12 0x000000335d050396 in KApplication::notify (this=0x7fff433ebf90, receiver=0x3395a60, event=0x7f719800caa0) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#13 0x0000003355d77b4c in QCoreApplication::notifyInternal (this=0x7fff433ebf90, receiver=0x3395a60, event=0x7f719800caa0) at kernel/qcoreapplication.cpp:876
#14 0x0000003355d7b5da in sendEvent (event=0x7f719800caa0, receiver=0x3395a60) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1bf3050) at kernel/qcoreapplication.cpp:1500
#16 0x0000003355da6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x1c329e0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x000000334ec44a7d in g_main_dispatch (context=0x1c2c0e0) at gmain.c:2425
#19 g_main_context_dispatch (context=0x1c2c0e0) at gmain.c:2995
#20 0x000000334ec45278 in g_main_context_iterate (context=0x1c2c0e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x000000334ec4544c in g_main_context_iteration (context=0x1c2c0e0, may_block=1) at gmain.c:3136
#22 0x0000003355da682f in QEventDispatcherGlib::processEvents (this=0x1bf4510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x000000335686c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x0000003355d76c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x0000003355d76ed7 in QEventLoop::exec (this=0x7fff433ebf20, flags=...) at kernel/qeventloop.cpp:204
#26 0x0000003355d7b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fff433ec5b8) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286962.

Possible duplicates by query: bug 286962, bug 286307.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-11-24 21:53:51 UTC

*** This bug has been marked as a duplicate of bug 286307 ***