Bug 286962 - kmail crashes while trying to read mail
Summary: kmail crashes while trying to read mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-18 22:19 UTC by eli
Modified: 2011-11-19 10:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eli 2011-11-18 22:19:32 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.1-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:

I was trying to read my email and kmail crashed. It would seem that this happens with some html mail while text only mail seems to be ok

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f56c1aa0840 (LWP 6051))]

Thread 3 (Thread 0x7f56b637c700 (LWP 6052)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003bd5b973cc in WTF::TCMalloc_PageHeap::scavengerThread (this=0x3bd6590f80) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003bd5b974f9 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00000033efe07d90 in start_thread (arg=0x7f56b637c700) at pthread_create.c:309
#4  0x00000033ef6eeddd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f56b5a63700 (LWP 6053)):
#0  0x00000033efe0af8a in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:53
#1  __pthread_mutex_unlock (mutex=0x7f56b00009a8) at pthread_mutex_unlock.c:298
#2  0x00000033f1e44415 in g_main_context_query (context=0x7f56b00009a0, max_priority=<optimized out>, timeout=0x7f56b5a62c1c, fds=<optimized out>, n_fds=1) at gmain.c:2856
#3  0x00000033f1e44e8a in g_main_context_iterate (context=0x7f56b00009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3055
#4  0x00000033f1e4544c in g_main_context_iteration (context=0x7f56b00009a0, may_block=1) at gmain.c:3136
#5  0x0000003bc53a6896 in QEventDispatcherGlib::processEvents (this=0x7f56b00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#6  0x0000003bc5376c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x0000003bc5376ed7 in QEventLoop::exec (this=0x7f56b5a62d40, flags=...) at kernel/qeventloop.cpp:204
#8  0x0000003bc5278ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x0000003bc527bb1b in QThreadPrivate::start (arg=0x1e32050) at thread/qthread_unix.cpp:298
#10 0x00000033efe07d90 in start_thread (arg=0x7f56b5a63700) at pthread_create.c:309
#11 0x00000033ef6eeddd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f56c1aa0840 (LWP 6051)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4a7d7a0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x0000003bc5cf4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4a7d7a0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003bc53909e6 in QObject::event (this=0x4a7d7a0, e=<optimized out>) at kernel/qobject.cpp:1194
#9  0x0000003bc65c96f4 in notify_helper (e=0x7f5660013610, receiver=0x4a7d7a0, this=0x1e2adc0) at kernel/qapplication.cpp:4518
#10 QApplicationPrivate::notify_helper (this=0x1e2adc0, receiver=0x4a7d7a0, e=0x7f5660013610) at kernel/qapplication.cpp:4490
#11 0x0000003bc65ce573 in QApplication::notify (this=0x7fff7d0882d0, receiver=0x4a7d7a0, e=0x7f5660013610) at kernel/qapplication.cpp:4379
#12 0x0000003bc8250396 in KApplication::notify (this=0x7fff7d0882d0, receiver=0x4a7d7a0, event=0x7f5660013610) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#13 0x0000003bc5377b4c in QCoreApplication::notifyInternal (this=0x7fff7d0882d0, receiver=0x4a7d7a0, event=0x7f5660013610) at kernel/qcoreapplication.cpp:876
#14 0x0000003bc537b5da in sendEvent (event=0x7f5660013610, receiver=0x4a7d7a0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1df8050) at kernel/qcoreapplication.cpp:1500
#16 0x0000003bc53a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x1e26e10) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00000033f1e44a7d in g_main_dispatch (context=0x1e26d20) at gmain.c:2425
#19 g_main_context_dispatch (context=0x1e26d20) at gmain.c:2995
#20 0x00000033f1e45278 in g_main_context_iterate (context=0x1e26d20, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#21 0x00000033f1e4544c in g_main_context_iteration (context=0x1e26d20, may_block=1) at gmain.c:3136
#22 0x0000003bc53a682f in QEventDispatcherGlib::processEvents (this=0x1df9510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#23 0x0000003bc666c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#24 0x0000003bc5376c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#25 0x0000003bc5376ed7 in QEventLoop::exec (this=0x7fff7d088260, flags=...) at kernel/qeventloop.cpp:204
#26 0x0000003bc537b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#27 0x00000000004037b9 in main (argc=1, argv=0x7fff7d0888f8) at /usr/src/debug/kdepim-4.7.3/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 286307.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-11-19 10:22:14 UTC

*** This bug has been marked as a duplicate of bug 286307 ***